-   Linux - Software (
-   -   Intel HDA and ALSA problems (

SLaCk_KiD 09-22-2005 02:22 PM

Intel HDA and ALSA problems
Hi all;

I recently purchased a new laptop, a SAGER NP 3880 Supra. The machine is absolutely amazing and works great, with the exception of sound. I have searched and searched all over the internet for an answer to my problem, but without any help at all.

I have slackware 10.2 installed, with alsa 1.0.9a. I have gotten to a point where the modules are inserted and working correctly. but i get no sound from my speakers. Now most of you would say that i should unmute my speakers with alsamixer. been there done that, i have set every channel to 80% volume and unmuted them all. In XMMS the little analyzer is moving, and it acts like it is plsying an audio stream with the alsa output plugin, but still no sound.

I even tried install the alsa 1.0.10rc1 drivers, and then the alsa mixer was giving me an error about an INVALID ARGUMENT, so i went back to the alsa 1.0.9a drivers and everything appears to work correctly, the alsamixer, alsaconf recognizes my hardware, and the only error that i can find is in dmesg output:

ALSA sound/pci/hda/hda_codec.c:511: hda_codec: no AFG node found

which i cannot find anything online about either. If someone could please point me int he proper direction i would appreciate it. I am really at a dead end here, and i am about to try the OSS drivers to see if they work out. Thanks for any help, and if anyone would like any more information i will provide it.



All times are GMT -5. The time now is 08:58 PM.