-   Linux - Software (
-   -   Installing XMLTV; error (

shubb 09-11-2005 10:15 PM

Installing XMLTV; error
I'm trying to install XMLTV as a part of the install process for MythTV.

When I run the perl MakeFile.PL command, I get the following error.


root@pvr:/usr/local/src/xmltv-0.5.39# perl Makefile.PL
You may want to explicitly give PREFIX to work around MakeMaker bugs.
Can't locate Term/ in @INC (@INC contains:
/usr/lib/perl5/5.8.6/i486-linux /usr/lib/perl5/5.8.6
/usr/lib/perl5/site_perl/5.8.6/i486-linux /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/site_perl .) at lib/Ask/ line 9.
BEGIN failed--compilation aborted at lib/Ask/ line 9.
Compilation failed in require at Makefile.PL line 201.

Line 9 of the file lib/Ask/ says:

use Term::ReadKey;
I'm guessing I need to install ReadKey? How do I do that?

david_ross 09-12-2005 02:49 PM

The easiest way is with cpan:
perl -MCPAN -eshell

Then at the cpan> prompt:
install Term::ReadKey

shubb 09-12-2005 04:13 PM

I thought I tried that and it didnt work. I tried your command, however, and it worked, and the makefile worked.


All times are GMT -5. The time now is 03:54 PM.