-   Linux - Software (
-   -   Installing wireless drivers with Atheros AR9285 Wireless Network Adapter (

nine9nine 01-12-2011 11:35 AM

Installing wireless drivers with Atheros AR9285 Wireless Network Adapter

I have recently installed Linux Mint 10 on my laptop. When I look at the Device Manager in Windows 7, it says I have an Atheros AR9285 Wireless Network Adapter. Right now, I am unable to connect to wifi with Linux. What drivers am I able to install, and how would I install them?

fbsduser 01-12-2011 11:44 AM

You should try first ath5k and ath9k. If none work, try madwifi and if it doesn't work. Try ndiswrapper using the winxp drivers for your card (google "Atheros AR9285 winxp driver").

yooy 01-12-2011 11:47 AM

strange. i thought that atheros wouldn't need any driver to install on ubuntu&mint. what is your output of iwconfig?

3 ways to install wi-fi on linux

nine9nine 01-16-2011 09:51 AM

I have managed to install the ath9k driver. However, when I click the connection icon on the bottom bar, my wifi network doesn't come up. I also am unable to connect when I put the wifi info into 'connect to hidden wireless network'. What should I do?

littlebigman 04-07-2017 08:27 AM


Using Wicd provided by the LXDE distro (Debian 8.5), I'm stuck trying to authenticate with wifi hotspots from an Asus Eee PC 1001PXD notebook that uses a Qualcomm Atheros AR9285 chip.

I tried the default "WPA 1/2 (Hex [0-9/A-F])", and then "WPA 1/2 (passphrase)", same result.

What other authenticating mode should I try? Since MadWiFi is deprecated, should I try ndiswrapper + Windows driver?

FWIW, this notebook ran Windows10 successfully - although dead slow -, before I reformated and installed LXDE. I tried Slackware-based distros (Proteus, PuppyLinux), to no avail.

Thank you.


Since Wicd says my home wifi hotspot uses WPA, I tried the following:
WPA 1/2 (Hex [0-9/A-F]), WPA 1/2 (Passphrase): Fails authenticating.

WPA-PEAP, WPA-LEAP, WPA2-LEAP: Requires Username + domain + password; Since I never had to provide those to connect from Windows, it can't be that.

Also, I notice that after trying to connect with Wicd, the Ethernet module loses its IP address: I have to run "ifdown eth0 ; ifup eth0" to recover.

All times are GMT -5. The time now is 05:53 PM.