-   Linux - Software (
-   -   installing wine under slack 9.1 (

j4m13 04-06-2004 11:10 AM

installing wine under slack 9.1
I have downloaded Wine-20040309-i686-S9.tgz to my /tmp from winehq, and run tar -xzvf (as both su and logged in as root, from the command line and in Konqueror) on it, which unpacks a mess of files. I however cannot find ./configure or ./tools/wineinstall anywhere, neither by looking "manually" nor by running find. I have Show Hidden Files turned on in Konqueror and can see hidden files in other directories. I have put some effort into this, reading howto's, doing google searches, etc., but I'm stumped. It's probably right in front of my face, but I'm damned if I can see it.
Thanks in advance for any help.

Tinkster 04-06-2004 03:50 PM

Maybe you should familiarise yourself a bit
with slackware rather than using clicky-pointy
thing-a-majicks ... What you uncompressed isn't
wine-source but a slack-pack. And the only
proper way to deal with that is to use installpkg,
or pkgtool .... both command-line tools if you didn't
guess it ;)


pyromania 04-06-2004 05:26 PM

download it from here ftp and use the rpm

hope that helps

Tinkster 04-06-2004 06:21 PM

Arrrh pee emm!

/me shivers


j4m13 04-07-2004 02:10 AM


Originally posted by Tinkster
Maybe you should familiarise yourself a bit
with slackware rather than using clicky-pointy
thing-a-majicks ...

I was using the command line as well as Konqueror. I may not have learned much about linux and even less about slack, but I have learned that there is no substitute for the command line. From this experience I've also learned that no matter how much the program splashes the screen with "make sure you read the README and man files", that can be a load of crap.

So, now I've installpkg'd the wine.yadayada.tgz that I'd downloaded to /tmp. When I run pkgtool it shows that wine is one of the packages installed. When I try to run wine at the command line, I'm told by wine that /root/.wine doesn't exist. According to README there should be a config file, but find only unearths the sample config files. Is wine looking for a config file in /root because I ran installpkg as root? Do I need to edit the sample config file and save it as wine.config somewhere?

Thanks again for any help.

doralsoral 04-07-2004 09:16 AM

why dont you just get the plain old generic source code and compile it yourself. i dont mess with those slack packs unless i have to

All times are GMT -5. The time now is 07:55 PM.