LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-14-2006, 02:44 AM   #1
Nauntilus
Member
 
Registered: Oct 2005
Distribution: All of them
Posts: 140

Rep: Reputation: 18
Installing Software giving me an error, I install what is requested and it wont work.


I have been trying to install Diva, the new Gnome video editor which runs on a python compiler, it is found at this site http://www.diva-project.org/ and I have also been trying to install Kino for KDE, and that you install from source and that is giving me almost the same error. What happens with Diva is this I follow the directions to compile using the command scons PREFIX=/usr and it gives me this error.
Quote:
[root@Nauntilus diva-0.0.2]# scons PREFIX=/usr
scons: Reading SConscript files ...

Dependency check:

Checking for pkg gstreamer-0.10 >= 0.10.4 ... (cached) no
[root@Nauntilus diva-0.0.2]#
Then I went and installed the newest version of gstreamer and it still gives me the error, so I try it again and it says already installed but it still wont diva install.

Then I go to install Kino from source and I type in ./configure and it goes so far and gives me this error.
Quote:
checking for LIBDV... configure: error: Package requirements (libdv >= 0.103) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the LIBDV_CFLAGS and LIBDV_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.
[root@Nauntilus kino-0.8.1]#
I did the same thing I did with Diva and went and installed that file and it still gives me the same error. These are near the same errors and I dont know if there is just something I am doing wrong, or if my computer is just being stupid.
All help is appreciated. I am doing this on a Dell Inspiron 5100 Laptop and with Mandriva 2006.

Last edited by Nauntilus; 05-14-2006 at 02:46 AM.
 
Old 05-14-2006, 03:02 AM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
You need to install the gstreamer and libdv devel packages.
 
Old 05-14-2006, 12:18 PM   #3
Nauntilus
Member
 
Registered: Oct 2005
Distribution: All of them
Posts: 140

Original Poster
Rep: Reputation: 18
I did that and it still gives me the same error, maybe I did it wrong, but one of them was an RPM and the other was source. The one I probably did wrong was the source if any, but then I also found an RPM for that File too and so I Dont understand why I am still getting this error.
 
Old 05-14-2006, 12:36 PM   #4
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
Do
Code:
$rpm -qa | grep -i gstreamer
Post back the results.
 
Old 05-14-2006, 12:52 PM   #5
Nauntilus
Member
 
Registered: Oct 2005
Distribution: All of them
Posts: 140

Original Poster
Rep: Reputation: 18
Quote:
[root@Nauntilus nauntilus]# rpm -qa | grep -i gstreamer
gstreamer-vorbis-0.8.11-4mdk
gstreamer-mad-0.8.11-4mdk
gstreamer-plugins-0.8.11-4mdk
gstreamer-tools-0.8.11-2mdk
gstreamer-cdparanoia-0.8.11-4mdk
gstreamer-flac-0.8.11-4mdk
libgstreamer0.8-0.8.11-2mdk
libgstreamer-plugins0.8-0.8.11-4mdk
gstreamer-GConf-0.8.11-4mdk
gstreamer-gnomevfs-0.8.11-4mdk
gstreamer-audio-formats-0.8.11-4mdk
[root@Nauntilus nauntilus]#
So I am guessing this means that I didnt actualy install it right? Can you help me to get it done right?
 
Old 05-14-2006, 01:10 PM   #6
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
The devel package isn't installed so you need to install that using rpmdrake. Unfortunately I can't give you the exact name of the package since I don't use Mandriva anymore. It should be something like libgstreamer-devel or gstreamer-devel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Get Microphone to Work - Help Requested mac57 Mandriva 1 02-26-2005 05:55 PM
apt-get -f install wont work newbieX Linux - Newbie 1 02-23-2005 07:54 AM
why wont the emerge command work when i am installing gentoo? mdpniesta Linux - Software 1 11-27-2004 03:16 AM
wine wont work..weird error akudewan Linux - Software 8 07-19-2004 09:26 PM
keyboard wont work on install!!! jpat1023 Linux - General 10 12-26-2003 09:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration