LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installing RTLinux in RHEL 4 - WS (https://www.linuxquestions.org/questions/linux-software-2/installing-rtlinux-in-rhel-4-ws-376123/)

alkesh.shah 10-23-2005 03:45 PM

Installing RTLinux in RHEL 4 - WS
 
Hi everybody,

I am trying to install RTLinux on RHEL 4 - WS. I have downloaded the prepatched version of rtlinux for 2.6.9 kernel from the fsmlab's rtlinuxfree website.

my fs -
/dev/hda8 /
/dev/hda6 /boot
/dev/hda7 swap

I then ran the following commands -
make 0=/usr/src/linux-2.6.9-rtfree/kernel config
make 0=/usr/src/linux-2.6.9-rtfree/kernel
make 0=/usr/src/linux-2.6.9-rtfree/kernel modules_install install

I checked the /boot partition and found the newly compiled kernel and the initrd image in the /boot partition alongwith the other 2.6.9-11 kernel of rhel 4. The initrd and vmlinuz are pointing towards the new initrd and vmlinux image.
Also the grub.conf was also modified to include the entry for the new kernel... the entried been similar to the other kernel entry...

after rebooting i am able to boot from the other kernel but i am not able to boot to the rtlinux kernel... it gives the foll error -

Kernel Panic - Not Syncing : unable to find root fs on block (0,0)

i tried giving the root= option in the kernel command with root=/dev/hda8
again the same error...

i tried giving the root=/dev/hda6 option... it gave a new error...
kernel panic - not syncin - init not found : try using the init= option

If somebody can help me it would be great

thanks

...
alkesh

kumarnine 09-15-2006 08:46 AM

Hi , did u get the solutions for that
 
Hi,
I aslo tried to install RTLinux on my RHEL4 machine.. but its not getting up. if u came across any solution pls suggest me. put it on the board.
bye
swamy


All times are GMT -5. The time now is 04:36 AM.