LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-26-2010, 05:49 PM   #1
Drigo
Member
 
Registered: Jun 2009
Posts: 111

Rep: Reputation: 17
Installing RPMs in Suse 11.


Here is what I want to do but I get the following error:

~ # rpm -iv --replacepkgs ~/compat-expat1-1.95.8-6.i686.rpm
warning: /root/compat-expat1-1.95.8-6.i686.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 57bbccba
error: Failed dependencies:
rpmlib(FileDigests) <= 4.6.0-1 is needed by compat-expat1-1.95.8-6.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by compat-expat1-1.95.8-6.i686


There is a similar computer with same specs and supposely it worked. It is a Dell Optiplex 960 64 bit
 
Old 02-26-2010, 06:32 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
Which distribution and version are you using? A quick google for rpmlib suggests that you need to update rpm on your system.
 
Old 02-27-2010, 02:17 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,325

Rep: Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583
Duplicate of http://www.linuxquestions.org/questi...1/#post3877463



And no, you still cannot install a Fedora 12 package
into Suse 11.

.....
 
Old 02-27-2010, 04:46 AM   #4
Drigo
Member
 
Registered: Jun 2009
Posts: 111

Original Poster
Rep: Reputation: 17
Angry

I tried with both, force reinstall the packages and still the same error....im looking for a way to make this work only! but still none of them work
 
Old 02-27-2010, 06:11 AM   #5
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
Quote:
Originally Posted by XavierP View Post
A quick google for rpmlib suggests that you need to update rpm on your system.
Since knudfl's detective work has found out the distro/version, how about searching on the actual error message?
http://www.linuxquestions.org/questi...he-net-720245/
http://forums.fedoraforum.org/showthread.php?t=225435 for the first error

Upgrade rpm (you will probably need rpm-devel upgraded as well).
 
Old 02-27-2010, 06:42 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,325

Rep: Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583
Well, it's Suse 11.0 , 11.1 or 11.2 .
It may be x86 (32-bit) or x86_64 (64-bit)

The unknown application : probably x86_64 ?
But who knows, when you supply no information.
.....
 
Old 02-28-2010, 12:32 AM   #7
Drigo
Member
 
Registered: Jun 2009
Posts: 111

Original Poster
Rep: Reputation: 17
Suse 11.2 i believe and yes its a 64 bit computer
 
Old 02-28-2010, 04:06 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,325

Rep: Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583
And all the other missing information ........ ?
http://www.linuxquestions.org/questi...m-help-791511/

1) Output of the command : uname -a

2) The application : FSLview ? A 64-bit 'x86_64' version is
not using libraries x86, i.e. '.i686.rpm' and '.i386.rpm'
are useless.

Name of the application, please ! And a link to the exact
version, you are trying to use, please.
.....
..... This 64 - bit package may work ?
http://download.fedora.redhat.com/pu...8-4.x86_64.rpm
> compat-expat1-1.95.8-4.x86_64.rpm
.....

Last edited by knudfl; 02-28-2010 at 05:21 AM.
 
Old 03-01-2010, 12:24 AM   #9
Drigo
Member
 
Registered: Jun 2009
Posts: 111

Original Poster
Rep: Reputation: 17
Thanks for all your help. The application is FSL. http://www.fmrib.ox.ac.uk/fsl/fsl/downloading.html and I downloaded centos-5 64 bit (look at the download website for this info). FSLView is the viewer of this applcicatino that uses gives me the error shown above.
 
Old 03-01-2010, 04:01 AM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,325

Rep: Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583
OK , I would then assume the application to look for
libexpat.so.0 in /usr/lib64/

The package compat-expat1-1.95.8-4.x86_64.rpm
linked in post # 8 provides :
/usr/lib64/libexpat.so.0
/usr/lib64/libexpat.so.0.5.0

.....
 
Old 03-01-2010, 11:01 AM   #11
Drigo
Member
 
Registered: Jun 2009
Posts: 111

Original Poster
Rep: Reputation: 17
This actually did the trick. Thank you very much knudfl! You made my day at work on a Monday morning!
I have another issue with this 64bit computer, I hope you could take a look if possible:
http://www.linuxquestions.org/questi...1/#post3881088
 
Old 03-01-2010, 11:49 AM   #12
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,325

Rep: Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583
It's OK then : You could have got the right information
four days ago, if you had said "64 bit application" etc.

Your other thread :
I have no idea, and have no 64 bit computers currently.
But you may hit the edit button to specify Suse :
→ → There are four Suse 11.x, all different → →
1) Suse SLES 11 ( or SLED 11 ).
2) Suse 11.0 OSS
3) Suse 11.1 OSS
4) Suse 11.2 OSS
.....

Last edited by knudfl; 03-01-2010 at 11:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 10.1 - Installing downloaded RPMs IanC66 SUSE / openSUSE 15 06-07-2006 02:35 PM
having trouble installing MySQL with RPMs on Suse 9.1 asilentmurmur Linux - Software 2 08-28-2005 10:25 AM
Problems installing RPMs in suse linux 9.0 jginger Linux - Newbie 3 07-27-2004 04:13 PM
Installing RPMs on Suse 9.1 inline.skater Linux - Distributions 7 06-28-2004 09:17 PM
SuSE 9.1 -- Installing RPMs in YaST MrFubar Linux - Software 9 05-30-2004 04:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration