-   Linux - Software (
-   -   Installing RPMs in Suse 11. (

Drigo 02-26-2010 04:49 PM

Installing RPMs in Suse 11.
Here is what I want to do but I get the following error:

~ # rpm -iv --replacepkgs ~/compat-expat1-1.95.8-6.i686.rpm
warning: /root/compat-expat1-1.95.8-6.i686.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 57bbccba
error: Failed dependencies:
rpmlib(FileDigests) <= 4.6.0-1 is needed by compat-expat1-1.95.8-6.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by compat-expat1-1.95.8-6.i686

There is a similar computer with same specs and supposely it worked. It is a Dell Optiplex 960 64 bit

XavierP 02-26-2010 05:32 PM

Which distribution and version are you using? A quick google for rpmlib suggests that you need to update rpm on your system.

knudfl 02-27-2010 01:17 AM

Duplicate of

And no, you still cannot install a Fedora 12 package
into Suse 11.


Drigo 02-27-2010 03:46 AM

I tried with both, force reinstall the packages and still the same looking for a way to make this work only! but still none of them work

XavierP 02-27-2010 05:11 AM


Originally Posted by XavierP (Post 3878257)
A quick google for rpmlib suggests that you need to update rpm on your system.

Since knudfl's detective work has found out the distro/version, how about searching on the actual error message? for the first error

Upgrade rpm (you will probably need rpm-devel upgraded as well).

knudfl 02-27-2010 05:42 AM

Well, it's Suse 11.0 , 11.1 or 11.2 .
It may be x86 (32-bit) or x86_64 (64-bit)

The unknown application : probably x86_64 ?
But who knows, when you supply no information.

Drigo 02-27-2010 11:32 PM

Suse 11.2 i believe and yes its a 64 bit computer

knudfl 02-28-2010 03:06 AM

And all the other missing information ........ ?

1) Output of the command : uname -a

2) The application : FSLview ? A 64-bit 'x86_64' version is
not using libraries x86, i.e. '.i686.rpm' and '.i386.rpm'
are useless.

Name of the application, please ! And a link to the exact
version, you are trying to use, please.
..... This 64 - bit package may work ?
> compat-expat1-1.95.8-4.x86_64.rpm

Drigo 02-28-2010 11:24 PM

Thanks for all your help. The application is FSL. and I downloaded centos-5 64 bit (look at the download website for this info). FSLView is the viewer of this applcicatino that uses gives me the error shown above.

knudfl 03-01-2010 03:01 AM

OK , I would then assume the application to look for in /usr/lib64/

The package compat-expat1-1.95.8-4.x86_64.rpm
linked in post # 8 provides :


Drigo 03-01-2010 10:01 AM

This actually did the trick. Thank you very much knudfl! You made my day at work on a Monday morning!
I have another issue with this 64bit computer, I hope you could take a look if possible:

knudfl 03-01-2010 10:49 AM

It's OK then : You could have got the right information
four days ago, if you had said "64 bit application" etc.

Your other thread :
I have no idea, and have no 64 bit computers currently.
But you may hit the edit button to specify Suse :
→ → There are four Suse 11.x, all different → →
1) Suse SLES 11 ( or SLED 11 ).
2) Suse 11.0 OSS
3) Suse 11.1 OSS
4) Suse 11.2 OSS

All times are GMT -5. The time now is 10:55 AM.