-   Linux - Software (
-   -   Installing pango with cairo support, so pangocairo is available (

murtuzanaqvi 08-27-2010 06:35 AM

Installing pango with cairo support, so pangocairo is available

My Distro is RHEL4 .
I am trying to install pango-1.28.1 with cairo support. I have already installed cairo-1.8.10, fontconfig-2.4.2 and freetype-2.4.2.
These installation were done without giving any additional parameter with ./configure
All are installed from Desktop folder.
On doing a make check for cairo, the report says that 121 of 200 tests failed.
Then i do a make install.
While doing ./configure for pango the following message is displayed:

checking for CAIRO... yes
checking which cairo font backends could be used... none
configure: Disabling cairo support
checking for GLIB... yes
checking for LIBTHAI... no

As pango is not installing with cairo support so i do not have a pangocairo file required be most recent browsers. Which is blocking me from upgrading to latest browser.

David the H. 08-27-2010 07:03 AM

Are you doing this all from source? If you're installing through a package manager, have you installed all the development files for the packages in question as well?

Are there any configure options available? Usually ./configure --help shows what's available.

RHEL4 is rather out-of-date. Any chance of upgrading it?

And a link to your other post on the subject:

murtuzanaqvi 08-27-2010 07:09 AM

development files ?????

i installed the following packages:

all were installed with
#make check
#make install

murtuzanaqvi 08-27-2010 07:21 AM

I am doin all the installation from source.
Upgrade is not an option for now.

David the H. 08-27-2010 07:41 AM

Most distributions like to separate out the library headers into separate packages. It often causes unfamiliar users problems when compiling. But I guess that's not your issue.

By the way, I see that there have been at least a few previous threads on this subject. A few of them are listed at the bottom of the page. Have you used the search function here yet? Or Google?

knudfl 08-27-2010 07:41 AM

RH EL4 : Compatibility libraries for a newer firefox are available :
... Please read this LQ thread :

murtuzanaqvi 08-30-2010 04:02 AM


I installed all these packages from centOS.
After installing all these packages, i downloaded a rpm for installing firefox.
The rpm package did not install, it said that, nss nspr are missing packages.
I downloaded nss and nspr RPMs also from centOS but they also did not install, failed due to package dependency.
Kindly suggest the way forward.

murtuzanaqvi 08-30-2010 04:10 AM

I have set the path in .bashrc as follows:
[root@localhost firefox]# echo $PATH

[root@localhost firefox]# locate

On running the updater script that is provided in the tarball download, there is an error saying
[root@localhost firefox]# ./updater
./updater: error while loading shared libraries: cannot open shared object file: No such file or directory

Why is it not able to locate the library when there is a path available for it.
I am doin these operations as a root user, have also tried these as local user.

murtuzanaqvi 08-30-2010 06:24 AM

When i'm doing a "rpm -q mozilla-nspr"

But when i try to install nspr with "nspr-4.7.1-1.el4.i386.rpm", also downloaded from centOS.
It says that following packages can not be found:
mozilla-nspr ('mozilla-nss','1.7.3','18.EL4')
mozilla-nspr ('mozilla','1.7.3','18.EL4')
mozilla-nspr ('mozilla-nspr-devel','1.7.3','18.EL4')

I am not sure, why, if the mozilla-nspr package is already installed, the rpm is not able to find it.
Also when i tried to upgrade with another older version of mozilla-nspr, there was a message saying that a newer version of it is already installed.

murtuzanaqvi 09-01-2010 06:12 AM

I'm consolidating the solution to the problem i was facing:
As i do not have support for RHEL, so downloaded and installed RPMs


Then followed comment #7 in the thread below:

Untarred the latest version of firefox i.e firefox3.6.8

changed .bashrc file in my home directory to incorporate:
export LD_LIBRARY_PATH=/usr/evolution28/lib:/usr/local/lib

Did a ./firefox from the directory in which it was untarred.
Viola!!!! firefox is up and running.

Thanks to all those who contributed to making this possible..

knudfl 09-01-2010 10:06 AM


changed .bashrc file in my home directory to incorporate:
export LD_LIBRARY_PATH=/usr/evolution28/lib:/usr/local/lib
May not be a good idea. If e.g. Gnome opens with the new versions
of gtk, etc., it will not work correctly.

The CentOS 4 / RH EL4 way with the libraries is :
Point to the libraries, only when starting firefox (or evolution28).

It can be done by adding the export LD_ etc. in the 'firefox/firefox' start script :

50 #uncomment for debugging
51 #set -x
53 export LD_LIBRARY_PATH=/usr/evolution28/lib/
55 moz_libdir=/usr/local/lib/firefox-3.5.6
The example is from firefox 3.5.6 : line 53 is added.

All times are GMT -5. The time now is 09:29 PM.