LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-21-2012, 12:19 PM   #1
bumshotz
LQ Newbie
 
Registered: Jun 2012
Posts: 2

Rep: Reputation: Disabled
Installing openoffice 3.4 on red hat enterprise linux 5 (tikanga)server


I ve been a unix user(solaris) for some time now and decided to try my hands on Red Hat enterprise linux 5.5 (Tikanga) Server OS, I decided to start with installation of common applications that would take me away from complete dependence on microsoft word and star office just for a change; after downloading the installation package below; Apache_OpenOffice_incubating_3.4.0_Linux_x86_install-rpm_en-US.tar
I unpacked with the; tar -xvf Apache_*.tar, and got the installation folder; en-US, I proceeded to installing with the rpm -viUF *.rpm command for all the different packages in the en-US folder.
It installed very properly but failed to start when I change into the /opt/openoffice.org3/program and executed the command ./soffice.
here is the error massage I got;






/opt/openoffice.org3/program/../basis-link/ure-link/bin/javaldx: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /opt/openoffice.org/ure/bin/../lib/libuno_sal.so.3)
/opt/openoffice.org3/program/../basis-link/ure-link/bin/javaldx: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /opt/openoffice.org/ure/bin/../lib/libxml2.so.2)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /opt/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /opt/openoffice.org3/program/../basis-link/program/libsvt.so)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /opt/openoffice.org3/program/../basis-link/program/libsvt.so)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version `GLIBC_2.11' not found (required by /opt/openoffice.org3/program/../basis-link/program/libvcl.so)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version `GLIBC_2.7' not found (required by /opt/openoffice.org3/program/../basis-link/program/../ure-link/lib/libxml2.so.2)

I thought the jdk I was using was out of date so I proceeded to download from the site and installing; jdk-7u5-linux-i586.rpm after which I got the same error while trying to execute the ./soffice command, on changing to /opt/openoffice.org3/program.


I tried looking for the file libc.so.6: version GLIBC_2.7 without success. I which to ask; how do I solve this problem?
 
Old 06-21-2012, 01:12 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,409

Rep: Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611
Welcome to LQ.

1) RHEL 5.5 is an old version. The current update is 5.8.
2) Openoffice 3.4 is meant for an OS later than 2007.
.... An OS with at least glibc-2.7.
3) RHEL 5 is based on packages from year 2006. ( Fedora 6.)

4) Glibc-2.5 is your OS ( together with the kernel )
.... and cannot be replaced.

5) Suggest : Use RHEL 6 or one of the (identical) free versions :
CentOS 6.2 , Scientific Linux SL 6.2 .

.

Last edited by knudfl; 06-21-2012 at 01:19 PM.
 
Old 06-21-2012, 08:35 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 7.7 (?), Centos 8.1
Posts: 17,849

Rep: Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584
In addition, don't try to download and install tar files (if you can avoid it).
Use the built-in pkg handling tool yum http://linux.die.net/man/8/yum, which will auto-handle dependencies.
 
Old 06-22-2012, 08:30 AM   #4
bumshotz
LQ Newbie
 
Registered: Jun 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
thank u so very much for this information its appreciated! However I tried libreoffice3.5 and its working very well. As an intending professional linux/unix admin duo in a stage of incubation I appreciate ur response and would always be hear for more info. once again thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Installing OpenOffice 3.2 on Red Hat Enterprise Linux 5/6/CentOS 5.x networking.dept Red Hat 6 02-17-2013 07:30 PM
[SOLVED] Problem in installing openldap on Red Hat Linux Server release 5.3 (Tikanga) Infotechie Red Hat 1 04-23-2012 09:17 AM
Red Hat Enterprise Linux Server release 5.5 (Tikanga) - swap dhranraj.chilla Linux - Software 7 08-23-2011 07:30 AM
[SOLVED] want to download vsftpd for Red Hat Enterprise Linux Server release 5.1 (Tikanga) rupea Linux - Newbie 5 06-08-2011 09:23 AM
Red Hat Enterprise Linux Server release 5.3 (Tikanga) htb.support Linux - Newbie 3 08-25-2010 02:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration