LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-18-2003, 08:38 PM   #16
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30

Your answers
1) fluxbox: /opt/fluxbox/bin/fluxbox (this is where i tried to extract the tar.gz)
2) root

oh yea, executing from the terminal worked for gaim and stuff! Thanks, and thanks for teaching me the whereis command But i just hope i can get fluxbox up and running somehow!
 
Old 03-19-2003, 07:28 AM   #17
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
i tried typing this in the terminal:
> exec /opt/fluxbox/bin/fluxbox
but it just closed the terminal and nothing happned
 
Old 03-19-2003, 08:08 AM   #18
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
but it just closed the terminal and nothing happned
I should have asked this before.... Are you already running a graphical interface when you try to start fluxbox? If so, it isn't going to work because you can only have one wm running at a time. In other words, trying to start fluxbox from a terminal in Gnome isn't going to work. Window managers like fluxbox need to be started along with the X windows system.

If you haven't already, try editing your .xinitrc file to include the line you typed at the terminal (exec /opt/fluxbox/bin/fluxbox) and be sure to comment out any other lines that might start a different wm. If you do that, when you starx fluxbox should come up.

You also might want to do a search here on using xwmconfig. If you want to bounce around between window managers it is an easy way of doing it.
 
Old 03-19-2003, 06:22 PM   #19
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
ok i did exec /opt/fluxbox/bin/fluxbox and i got:
BaseDisplay::BaseDisplay: connection to X server failed.
so then i tried executing blackbox (which works when i run it from gwm) using the command exec and it gave me the same error. I found this strange since i could run it fine when choosing it from the list in gwm but when i gave the command i got an error...it makes me think, is there a way i can add fluxbox to the list of wm in gwm so i can pick it from there. Also i did "whereis xinitrc" and got no results so it comes down to:
- Can i add fluxbox into the menu of wms in gwm?
- Where is my xinitrc!?!
Thanks for all your help, but i still need it

(me afferos Hangdog42)

*edit* woops ur not a member of affero well its the thought that counts!

Last edited by DiZASTiX; 03-19-2003 at 06:57 PM.
 
Old 03-20-2003, 08:50 AM   #20
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Lets see here. You should be able to get fluxbox into gwm, but I'm unfamiliar with that program. You might try doing a search here or man gwm. However, since we are talking Slackware, it is almost certainly just an issue of adding a file to a gwm directory.

Another thing to try instead of exec /opt/fluxbox/bin/fluxbox would be to enter ./opt/fluxbox/bin/fluxbox (and that first period is important). However, from the error message you posted, it looks like fluxbox is trying to load and just failing. And speaking of important periods, the file you are looking for is .xinintrc, not xinitric. For files and directories, adding a period to the the start of the name makes them "hidden". It should be in your home directory.

If fluxbox is still being a pain, it might be worth compiling the source. Just download the tarball and after upacking it (tar -zxvf fluxbox*.tar.gz) drop into the directory and do the ./configure, make and make install thing. It could be your slack package got corrupted somehow and that is causing trouble.


And I do agree that it's the thought that counts!
 
Old 03-20-2003, 05:00 PM   #21
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
try running the command xwmconfig and see if slack has picked it up on its own
 
Old 03-24-2003, 06:37 PM   #22
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
ok new error, got rid of slackware and installed red hat, tried installing fluxbox, finsihed all good, then went and did exec /usr/local/bin/fluxbox and it just gives an error real fast that i cant read, clears the screen, and logs me ot
 
Old 03-24-2003, 07:54 PM   #23
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Quote:
Originally posted by DiZASTiX
ok new error, got rid of slackware and installed red hat, tried installing fluxbox, finsihed all good, then went and did exec /usr/local/bin/fluxbox and it just gives an error real fast that i cant read, clears the screen, and logs me ot
I wish I had seen this post earlier as I might have been able to help you out with your Slackware. But, in time, you'll be back to Slack.

Anyway, if you want to see the error again, go to /var/log/XFree86.0.log and it will show you what went right as well as what went wrong. RedHat might have a different file name and if so, let us know and we'll try to get the right one for you. Hope this helps.
 
Old 03-24-2003, 08:01 PM   #24
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
Ok, that file is there, but when i looked at it, its kinda confusing and i tried but couldnt see what i was looking for. So tried instead of exec /usr/local/bin/fluxbox to browse to /usr/local/bin and type ./fluxbox and i get:

BaseDisplay::BaseDisplay: connection to X server failed.

Any clue what this means and how i can fix it?

(BTW: lol why you say ill be back to slack )
 
Old 03-24-2003, 08:03 PM   #25
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Also, in relation to your earlier question regarding the location of your .xinitrc file, there's actually more than one. By default, when you startx, X looks for your .xinitrc in:

/home/DiZASTiX/.xinitrc

However, this will only load your defaults. If you want to add fluxbox or blackbox to the system's .xinitrc file in Slackware 8.1, you'd have to go to:

/etc/X11/xinit/.xinitrc

Basically this file is used if your user profile doesn't have one of it's own. Also, since you were trying to get it added to the list of avialable window managers for gwm or whatever, I would assume you'd have to add it to your system's .xinitrc and not your user's. You'd have to configure your gwm to look for it.

I know you're not using Slack anymore, but hopefully this is of some help anyway.
 
Old 03-24-2003, 08:18 PM   #26
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Quote:
Originally posted by DiZASTiX
Ok, that file is there, but when i looked at it, its kinda confusing and i tried but couldnt see what i was looking for. So tried instead of exec /usr/local/bin/fluxbox to browse to /usr/local/bin and type ./fluxbox and i get:

BaseDisplay::BaseDisplay: connection to X server failed.

Any clue what this means and how i can fix it?
Are you typing this in a terminal inside X or are you in purely text command line? This means that the command you're using to call up fluxbox is not correct. Try to do the following:

locate fluxbox | less

This will find "fluxbox" and allow you to scroll up and down with arrow keys. To get out of the "less" feature, hit your Q key. You should find a file in a /bin directory somewhere that will have fluxbox in it. This will be an executable. Actually, we'll go into this later if we need to. I'd like to try another way first as a "test"--plus you'll learn how to configure your .xinitrc file if you haven't already.

I'll tell you what...find your /home/DiZASTiX directory. Type ls -a and you see all your hidden files. In there you should see a file called .xinitrc. Now, open it up with vi as root:

vi /home/DiZASTiX/.xinitrc

Hit your down arrow until you get to your window manager section. Once you get there, press the letter i for inserting text. Now, go to the beginning of the only line in there that does not have a # in front of it and put a # in front of it. Now, go back to the beginning of the line by pressing your left arrow once. Hit return. This will create an empty line above the one you just put the # at the beginning. Now, hit your up arrow and get to the empty line. Type this:

exec fluxbox

Now, you have to press ESCAPE, then type this:

:wq

You must have the colon ":" and the w writes while the q quits. Now, you should be back to a regular command line and vi should be gone. Type:

logout

You'll get a login prompt. Type in your user profile name and password. When you get to a normal command line, type:

startx

This will open X and you should have Fluxbox running. Now, if this doesn't work, then we need to check into other options as fluxbox might not be installed correctly or have the right permissions set for users to use.

Quote:
(BTW: lol why you say ill be back to slack )
You'll see. Oh, and let me know when you do.

Last edited by Texicle; 03-24-2003 at 08:20 PM.
 
Old 03-24-2003, 08:18 PM   #27
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
/home/DiZASTiX/.xinitrc does not exist but /etc/X11/xinit/.xinitrc is there, theres also /usr/X11R6/X11/xinit/xinitrc Wow this is confusing lol. I dont see what i can edit in those files. Ive done a google search and it seems that many have this problem with black and fluxbox, but i see no solutions. Thanks for all your help, guess ill have to just keep looking, (btw, ill affero you) thanks again!

*edit* from what i hear, seems like i should put exec /usr/local/bin/fluxbox somewhere in .xinitrc

Last edited by DiZASTiX; 03-24-2003 at 08:22 PM.
 
Old 03-24-2003, 08:22 PM   #28
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Okay...you're there!!! Follow the information I gave you about using vi to edit the file...but instead, type this:

vi /etc/X11/xinit/.xinitrc

And the rest is the same. You should be up and running fluxbox in no time!
 
Old 03-24-2003, 08:23 PM   #29
DiZASTiX
Member
 
Registered: Mar 2003
Location: Boston Area
Distribution: Ubuntu (Edgy)
Posts: 247

Original Poster
Rep: Reputation: 30
lol, we posting at the same time i wasnt seeing ur posts! Ill try what you said now and let you now (THANKYOU!)
 
Old 03-24-2003, 08:24 PM   #30
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
/home/DiZASTiX/.xinitrc was just an example. Substitue the DiZASTiX with whatever your user profile name is. Not always does this file exist by default and you might have to create it...but we'll do that later. For now, let's get flux up as your default window manager, then we'll work on your user's .xinitc file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installing a new window manager interndan Slackware 6 11-16-2005 01:50 PM
Installing a window manager with yum stevewillis Linux - Software 0 02-16-2005 10:04 PM
Installing slackware with a different window manager rustyz82 Linux - Software 11 05-17-2004 04:44 PM
installing and changing to a new window manager hamish Linux - Newbie 2 02-05-2004 05:22 PM
Installing a new window manager Travis86 Linux - Newbie 4 03-15-2003 09:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration