LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-28-2005, 02:45 PM   #1
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Rep: Reputation: 35
Installing MPlayer: GTK Devel missing


Hi all

I'm trying to install MPlayer on my system (KDE) and during the build command:
Code:
DEB_BUILD_OPTIONS="--enable-gui --enable-menu" fakeroot debian/rules binary
it comes across Error 1, which is "The GUI requires GTK devel packages (which were not found)

I obviously need the GTK devel packages, but I can t find them to get anywhere. I tried gtk.org, anp-get and synaptic...

Can anyone help me?

Thanks

Hong
 
Old 02-28-2005, 02:52 PM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
in synaptic look for the gtk+-1.2.x-devel package. you will not find it on gtk.org, as it has the sources for the full build. you should also be able to get it through apt-get but I'm not sure on the exact command.
 
Old 02-28-2005, 02:59 PM   #3
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Hmm, cant find it in Synaptic...

If anyone knows its name in Synaptic, or Apt-get, or has any other suggestions please let me know!!
 
Old 02-28-2005, 03:19 PM   #4
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Ok, I got it installed (GTK1.2 devel)...

So when I run the DEB_BUILD command, I get lots of errors. LOTS.

How would I get it output to a file so I can post the errors? I have them on-screen now.
 
Old 02-28-2005, 03:21 PM   #5
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Heh. Seems Ctrl+C dont work, right click and 'Copy' does...

So: Any suggestions my helpful friends?

/usr/include/sys/socket.h:218: error: `shutdown' redeclared as different kind of symbol
/usr/include/gtk/gtkobject.h:192: error: previous declaration of `shutdown'
In file included from mp_msg.c:19:
Gui/mplayer/widgets.h:49: error: parse error before '*' token
Gui/mplayer/widgets.h:57: error: parse error before "gchar"
/usr/include/gtk/gtkclist.h:323: error: storage size of `area' isn't known
/usr/include/gdk/gdktypes.h:1245: error: storage size of `preedit_area' isn't known
/usr/include/gdk/gdktypes.h:1246: error: storage size of `preedit_area_needed' isn't known
/usr/include/gdk/gdktypes.h:1247: error: storage size of `preedit_foreground' isn't known
/usr/include/gdk/gdktypes.h:1248: error: storage size of `preedit_background' isn't known
/usr/include/gdk/gdktypes.h:1253: error: storage size of `status_area' isn't known
/usr/include/gdk/gdktypes.h:1254: error: storage size of `status_area_needed' isn't known
/usr/include/gdk/gdktypes.h:1255: error: storage size of `status_foreground' isn't known
/usr/include/gdk/gdktypes.h:1256: error: storage size of `status_background' isn't known
/usr/include/gtk/gtknotebook.h:104: error: storage size of `requisition' isn't known
/usr/include/gtk/gtknotebook.h:105: error: storage size of `allocation' isn't known
/usr/include/gtk/gtkaspectframe.h:60: error: storage size of `center_allocation' isn't known
/usr/include/gtk/gtkclist.h:160: error: storage size of `internal_allocation' isn't known
/usr/include/gtk/gtkclist.h:171: error: storage size of `column_title_area' isn't known
/usr/include/gtk/gtktext.h:129: error: storage size of `point' isn't known
/usr/include/gtk/gtkfontsel.h:162: error: storage size of `filters' isn't known
/usr/include/gtk/gtkhandlebox.h:73: error: storage size of `attach_allocation' isn't known
/usr/include/gtk/gtkhandlebox.h:74: error: storage size of `float_allocation' isn't known
/usr/include/gtk/gtkruler.h:88: error: storage size of `subdivide' isn't known
/usr/include/gtk/gtkrc.h:54: error: storage size of `fg' isn't known
/usr/include/gtk/gtkrc.h:55: error: storage size of `bg' isn't known
/usr/include/gtk/gtkrc.h:57: error: storage size of `base' isn't known
/usr/include/gtk/gtktext.h:144: error: storage size of `cursor_mark' isn't known
make: *** [mp_msg.o] Error 1
 
Old 02-28-2005, 03:22 PM   #6
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
you need to redirect it :

command &> newfile

for for example if the command was make:

make &> make.txt

creates a file called make.txt with the stdout information of the make command.
 
Old 02-28-2005, 03:31 PM   #7
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Thanks J, I appreciate the commands.

I've managed to get the errors posted (see above).

Does anyone know what I need to do?

Thanks
 
Old 02-28-2005, 04:23 PM   #8
Lier
Member
 
Registered: Jan 2005
Location: Argentina
Distribution: SUSE 9.0, 9.2, 10.0, Slackware 10.2 and slamd64
Posts: 135

Rep: Reputation: 15
First, if want a player for KDE you should know that mplayer it's for gnome; it works in KDE but some features don't, for example fullscreen doesn't, so i recomend you to get some one that works on KDE. You can find it at http://www.mplayerhq.hu/homepage/design7/projects.html as frontends. I recomend you the Kplayer.
If you want to install mplayer you can also search for a rpm file.
I don't know how you can fix your problem, i'm just giving you another way to do that things, maybe it work.
Good luck
 
Old 02-28-2005, 04:29 PM   #9
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Well my main reason for wanting mplayer is that LimeWire seems to require it for previewing vid files, that the only reason. So far, anything I have played worked fine in Xine.

Never mind. Maybe I'll have another go someother time, but right now I just wanna go to bed!!

Thanks, I appreciate all the help

Hong
 
Old 02-28-2005, 08:44 PM   #10
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 116Reputation: 116
Quote:
Does anyone know what I need to do?
That list of errors makes me think you installed the wrong gtk devel package. You installed gtk 1.2; I do believe you need gtk 2.0 or greater. I just upgraded gtk+- to 2.4.4 by compiling the tarball.
 
Old 02-28-2005, 08:45 PM   #11
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 116Reputation: 116
Quote:
First, if want a player for KDE you should know that mplayer it's for gnome; it works in KDE but some features don't, for example fullscreen doesn't
Yes it does. I use full screen all the time. In KDE.

I am not aware of any features that don't work as a result of the display manager in use, though I suppose there could be some.
 
Old 03-15-2005, 11:38 AM   #12
bhughesiii
Member
 
Registered: Aug 2004
Location: Indiana
Distribution: Fedora Core 2 and Suse Personal 9.1
Posts: 55

Rep: Reputation: 15
I am trying to install gtk 2.6 and while trying to get the other apps installed, glib, pango, etc.. I have glib installed.. ./configure,make,make install ... But, when I try to get pango installed it cannot find the glib that I just installed.. Any help?
 
Old 03-15-2005, 12:23 PM   #13
hongman
Member
 
Registered: Feb 2005
Location: UK
Distribution: Knoppix 3.7
Posts: 285

Original Poster
Rep: Reputation: 35
Are you using a debian based distro?

If so, do
Code:
apt-get install synaptic
That will download and install a GUI version of apt-get.

From there, Right click on desktop>Run Command>synaptic

Enter root password

From there you can find Pango and install it.

Hope this helps

Hong
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MPlayer : GUI requires GTK devel packages ?? logicalfuzz Linux From Scratch 6 10-01-2005 02:32 AM
MPlayer - GTK devel packages? Levitate Debian 14 12-30-2004 02:10 PM
error installing gtk---devel-1.0.3-1.i386.rpm on FC1 ben_build#2.1.0 Linux - Newbie 1 04-26-2004 06:09 PM
gtk-devel & mplayer Comarez Linux - Software 11 02-19-2004 11:57 AM
mplayer and gtk-devel and libpng-devel ... purpleburple Linux - Software 1 03-16-2003 04:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration