LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installing Modem Drivers (https://www.linuxquestions.org/questions/linux-software-2/installing-modem-drivers-32609/)

OpenC 10-12-2002 12:22 PM

Installing Modem Drivers
 
Hey all,

Following the meltdown of my FAT32 HDD, I decided that rather than going back to the old, I may as well install my Mandrake 8 distribution as from what I've seen of it, it does more than enough to keep me happy with my PC. The installation was a breeze, but I had a problem with my Riptide modem/sound/gameport card; I know there are issues with this particular card being a controllerless modem (Windows certainly doesn't like it) but I have sourced a set of drivers which seem like they should do the trick under Linux.

The installation instructions were as follows:

METHOD A: BINARY RPM PACKAGE (*.{arch}.rpm)

If you have obtained the driver package in RPM format:

1. install the rpm with "rpm -i hcfpcimodem-{version}.{arch}.rpm" ("rpm -i hcfusbmodem-{version}.{arch}.rpm" for the USB version)

2. optionally re-run "hcfpciconfig" ("hcfusbconfig" for the USB version) to complete the installation (if necessary) or to change your modem's configuration.


This is where my fear of other OS's started to kick in; if that had been DOS, I'd have been fine. However, with nothing to lose but 10 minutes to reformat C: again, I logged in as root and gave it a shot. Unsurprisingly, starting a terminal and running the command from stage 1 produced no response, as the terminal had no way of knowing that the .rpm was on a floppy disk. However, checking the file I noticed that Linux seemed to recognise it as a file type, so I ran it from the desktop - the installer came up and everything seemed to work just fine. The modem still didn't work, however, so I tried stage 2 which started up fine (so I guess stage 1 must have worked at some level) but kicked me back to the prompt with this:


ERROR: /lib/modules/2.4.3-20mdk/build points to a missing directory

lrwxrwxrwx 1 root root 20 Oct 12 11:31 /lib/modules/2.4.3-20mdk/build -> usr/src/linux-2.4.3


At this stage, I have no clue how to proceed. I can see that the installer is looking for something and not finding it, but have no idea how to point it in the right direction, or how to move the files that it's missing from where they are now, to where they should be.

Any help from anyone would be much appreciated - I really want to get Linux up and running so I can forget about Windows forever, but without a modem my PC is a little toy sitting in the corner. Basically, I have a floppy disk with two .rpm files on it, one for modem and one for audio, and I need to know, based on the instructions listed above, the step-by-step procedure for turning them from .rpm's to working drivers.

Thanks for reading my long, garbled and confused sounding message :)

newpenguin 10-12-2002 03:53 PM

dont worry dude
all you need is to install the kernel source RPM from your mandrake cd. the driver needs the kernel source which is missing in /usr/src.
in your mandrake distribution cds there will be a rpm like kernel-source.2.4.3-20mdk.i386.rpm
install it and then you will not see this message again.
good luck.

OpenC 10-12-2002 04:45 PM

Excellent, thank you for that mate :)

So to install what's missing, I go through the Software Manager, yeah? Throw in the CD, start up the Software Manager and poke around until I find what I need...

...I'll give it a go :)

Thanks again...


All times are GMT -5. The time now is 03:16 PM.