LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-09-2005, 12:14 PM   #16
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 57

The problem with mixing repos is that "yum upgrade" can do weird and broken things, also "yum install" on other packages. Dag is probably OK as he tries to ensure his packages are compatible but Fedora upstream generally don't care.

For applications it basically doesn't matter that RPM doesn't know about it, as they aren't dependencies of other stuff. For libraries it does, but the Inkscape autopackages won't install any other libraries.
 
Old 02-10-2005, 07:33 AM   #17
impe
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Rep: Reputation: 0
I'm having the same problem while installing glibmm-2.4.6
()

I downloaded libsigc++-2.0.6.tar.gz, expanded it in a temp directory, then ./configure, make, make install, without giving any path .
When i try to configure glibmm-2.4.6, I get the report:

---snip--
checking for sigc++-2.0 >= 2.0.0 glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 gmodule-2.0 >= 2.4.0... Package sigc++-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `sigc++-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sigc++-2.0' found

configure: error: Library requirements (sigc++-2.0 >= 2.0.0 glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 gmodule-2.0 >= 2.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
---snip--


what should I have to do?

Thanks.
 
Old 02-10-2005, 07:40 AM   #18
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 57
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
 
Old 02-10-2005, 09:05 AM   #19
impe
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Rep: Reputation: 0
thanks, it seems it works.
now the report is:


---snip---
checking for sigc++-2.0 >= 2.0.0 glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 gmodule-2.0 >= 2.4.0... Package glib-2.0 was not found in the pkg-config search path.Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found

configure: error: Library requirements (sigc++-2.0 >= 2.0.0 glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 gmodule-2.0 >= 2.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
---snip---
and i cannot locate glib-2.0....
 
Old 02-10-2005, 10:29 AM   #20
impe
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Rep: Reputation: 0
I installed the glib-2.5.6.tar.gz, configured it, made, removed the files as in INSTALL, and then made install.

It seem it has not been installes. I'm still finding glib 2.0.6 in the path.

Thanks.
 
Old 02-11-2005, 12:39 AM   #21
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Original Poster
Rep: Reputation: 32
i solved the install problem by using apt-get for SuSE

Code:
apt-get install inkscape
 
Old 02-12-2005, 11:37 AM   #22
LionKimbro
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Rep: Reputation: 0
I got it to work with another repository as well:

Code:
 [Extras]
 name=Fedora Extras
 baseurl=http://download.fedora.redhat.com/pub/fedora/linux/extras/$releasever/$basearch/
This should alleviate the "mixing repositories" objection.

I had to turn gpgcheck=0 in /etc/yum.conf to get it to work.

I don't know if it was necessary, but I had also set gpgcheck=0 in /etc/yum.repos.d for everything.
 
Old 02-15-2005, 09:27 AM   #23
impe
LQ Newbie
 
Registered: Feb 2005
Posts: 4

Rep: Reputation: 0
Conflict between glib1-devel and glib2 devel

I would like to install an application that requires different libraries (under Fedora core3).
Some of those libraries need to be compiled using glib1-devel and other requires glib2-devel.
But the last two development libraries conflict.

Has someone an idea about how to solve that problem.
Thanks.
Davide
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 10 and Inkscape 0.43 dyrer SUSE / openSUSE 1 11-25-2005 08:35 AM
inkscape problem slack 10.1 salahuddin_66 Slackware 1 03-05-2005 11:17 PM
Installing Inkscape on Debian/Knoppix jlregister Linux - Software 2 02-05-2005 05:59 AM
Printing from Inkscape mykrob Linux - Software 4 11-18-2004 01:06 AM
Installing Inkscape (RPM?) nistelrooy Fedora 3 10-15-2004 08:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration