LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installing Glibc 2.3 HELP PLEASE! (https://www.linuxquestions.org/questions/linux-software-2/installing-glibc-2-3-help-please-190132/)

NLR 06-05-2004 05:48 PM

Installing Glibc 2.3 HELP PLEASE!
 
Hello,

I asm new to Linux and I am trying to set up a Counter-Strike server...

I have had it set up for a while, but the my friend, the server owner, wanted me to install AMX Admin mod.

AMX Admin mod though needs to have Glibc 2.3, people are guessing that is why my server is crashing all the time...

Though I cant figured out how to install Glibc 2.3... Can you please help me?

Thanks,
Andrew

solnul 06-05-2004 05:52 PM

What distro are you using? You should run the upgrade tool (up2date/apt/swaret/whatever) or download the new version from your distro's site (RPMs for RedHat/Fedora/Mandrake/SuSE, tgz for Slackware, etc).

Note that since just about everything depends on glibc, you might need many other upgrades. Probably you should just update the entire distro.

NLR 06-05-2004 06:00 PM

I have Redhat 9.0...

How do I run up2date?

Thanks,
Andrew

solnul 06-05-2004 06:11 PM

Hmm... actually, I think up2date has died along with RH9 official support. Sorry. Nowadays, you should use yum.

This will get you current up to the last official updates (ended in April), including glibc 2.3.2. Eventually, Fedora Legacy will be providing updates.

Note that you can use another mirror, like http://download.fedora.us/fedora/red...updates/RPMS/, if mirror.cpsc.ucalgary.ca doesn't appeal to you.

NLR 06-05-2004 07:11 PM

Hi,

Thanks!, but... I installed Yum and when I run:

yum update
I get:

Gathering header information file(s) from server(s)
Server: Red Hat Linux 3ES - i386 - Base
retrygrab() failed for:
http://mirror.cpsc.ucalgary.ca/yum/r...rs/header.info
Executing failover method
failover: out of servers to try
Error getting file http://mirror.cpsc.ucalgary.ca/yum/r...rs/herder.info
[errno 4] IOError: HTTP Error 404: Not Found


I cant find anything on this... Have any ideas?

Thanks,
Andrew

solnul 06-05-2004 07:31 PM

yum thinks you have RedHat 3 Enterprise Server. (What's in /etc/redhat-release?)

If you really have RH 3ES, binary updates aren't free and you should be downloading them from the RedHat Network you're paying for. :)

If you actually have RH9, I have only the vaguest idea what yum's problem is. You can always download the RPMs [URL=http://download.fedora.us/fedora/redhat/9/i386/yum/updates/RPMS/]manually{/URL} and install them.

NLR 06-05-2004 07:36 PM

I do not believe I have RedHat 3ES... But this is a dedicated server, and I did not install the OS. I do not pay for anything from Red Hat.

Like I said I am new the Linux and not sure about this stuff...

Thanks,
Andrew

NLR 06-05-2004 07:40 PM

O ya...
It is Red Hat Enterprise Linux ES release 3 (Taroon Update 2)...

But I don't pay Red Hat anything... But the data center might...

Now what do I do?

I would like a update that I can have check up updates nightly...

Thanks,
Andrew

solnul 06-05-2004 07:41 PM

Does /etc/redhat-release say anything like "Red Hat Enterprise Linux ES release 3 (Taroon)"? Or "Redhat 9.0 (Shirke)"?

I dunno. I don't use RedHat much. For now, you might as well just grab the RPMs, they're pretty stable at this point.

NLR 06-05-2004 07:51 PM

It says: "Red Hat Enterprise Linux ES release 3 (Taroon Update 2)"...

Ok well that will do for now...

Andrew

solnul 06-05-2004 08:00 PM

If you have ES, you're paying for a support contract with RedHat. Now you can use up2date!

You need to have your support activated and stuff, and then you can just run it.

However, ES is supposed to stay stable, so I don't know if they would makes a real big change like the glibc version. You'll have to see if whoever set up your box has it registered, and if those updates are available.

NLR 06-05-2004 08:11 PM

Well,

up2date worked but it said there was nothing that needs to up updated... So I am guessing that up2date wont install it...

I was going to just us the RPMs to install it.

So When I got it it said I needed into install glibc-common but when I went to install that it said that it conflicts with tzdata-2003c-1...

What is that? What should I do?

THANK YOU VERY MUCH FOR THE HELP SO FAR TOO!!!!!

Andrew

solnul 06-05-2004 08:23 PM

Yeah. RHES3 is almost the same as RH9, but different. So now that we know you don't actually have RH9, I think the RH9 updates might work but I'm not sure. You can get a new tzdata RPM (tzdata-2003a-2.noarch.rpm is the right version I think) and install it on the same command line as the glibc ones. This could break lots of other stuff even if you were using real RH9, so you might as well get all of the updates on that server.

BUT part of the RHEL deal is that you don't install unauthorized updates like that, or RH won't support it. If you do that, you might as well have not paid extra for ES3. You should probably check with whoever set up this machine for you before you go futher. They might not be happy about you screwing up their support contract. :)

NLR 06-05-2004 08:46 PM

I have the tzdata file upgrade. But glibc conficts with it... Man o man I am lost...

Andrew

solnul 06-05-2004 08:59 PM

If you're sure you want to install these upgrades (losing your paid support while they're installed and risking hosing your system) just specify all the RPMs on the same rpm command line: rpm -i glibc* tzdata* (or something like that).


All times are GMT -5. The time now is 11:45 AM.