LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-15-2009, 02:05 AM   #1
Isuru Divarathne
LQ Newbie
 
Registered: Oct 2009
Posts: 9

Rep: Reputation: 0
Angry installing gcc rpm package


while installing gcc 4.4.1 rpm i got following error
so i searched to download glibc-devel-2.3.4-2.19.i386.rpm
but it was not available..


[root@localhost tmp]# rpm -i gcc-4.3.0-8.i386.rpm
warning: gcc-4.3.0-8.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
binutils >= 2.17.50.0.17-3 is needed by gcc-4.3.0-8.i386
cpp = 4.3.0-8 is needed by gcc-4.3.0-8.i386
glibc-devel >= 2.2.90-12 is needed by gcc-4.3.0-8.i386
libc.so.6(GLIBC_2.4) is needed by gcc-4.3.0-8.i386
libgcc >= 4.3.0-8 is needed by gcc-4.3.0-8.i386
libgomp = 4.3.0-8 is needed by gcc-4.3.0-8.i386
libgomp.so.1 is needed by gcc-4.3.0-8.i386
rtld(GNU_HASH) is needed by gcc-4.3.0-8.i386
Suggested resolutions:
glibc-devel-2.3.4-2.19.i386.rpm

Can anybody help me with this...
 
Old 10-15-2009, 02:46 AM   #2
rizhun
Member
 
Registered: Jun 2005
Location: England
Distribution: Ubuntu, SLES, AIX
Posts: 268

Rep: Reputation: 47
Have you looked on your distro CD's?
 
Old 10-15-2009, 02:55 AM   #3
Isuru Divarathne
LQ Newbie
 
Registered: Oct 2009
Posts: 9

Original Poster
Rep: Reputation: 0
i don't have them with me... can i download any update packages from internet?
 
Old 10-15-2009, 03:03 AM   #4
rizhun
Member
 
Registered: Jun 2005
Location: England
Distribution: Ubuntu, SLES, AIX
Posts: 268

Rep: Reputation: 47
Sure, if you have a login to redhat.com
 
Old 10-15-2009, 03:07 AM   #5
eth1
Member
 
Registered: May 2008
Posts: 97

Rep: Reputation: 20
If it's a RPM based distro ( you haven't specified which it is ), check if it has YUM( CentOS, Fedora do but OpenSuse has it's own package manager).

Quote:
yum install gcc
That should take care of gcc as well as any dependencies.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
is there any latest gcc version available in .rpm package anushineforever Linux - Software 1 01-04-2009 01:20 AM
installing gcc package aru_04 Fedora - Installation 2 06-14-2005 03:42 AM
installing and rpm package meliss Linux - Software 2 03-05-2004 07:55 AM
GCC RPM in One Package? bongski55 Red Hat 3 02-19-2004 05:24 AM
installing gcc package guerilla fighta Linux - Software 1 04-27-2002 09:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration