-   Linux - Software (
-   -   Installing gcc on Puppy...NOTHING works! (

MrCode 01-19-2010 05:32 PM

Installing gcc on Puppy...NOTHING works!
Hi, everyone. I've recently installed Puppy Linux on a "second-hand" machine, and I'm trying to get gcc installed so that I can (hopefully) compile some wireless drivers for the USB adapter I'm trying to make work.

I've tried everything I can think of, including following the instructions on the Puppy website. When I click the devx_430.sfs file, it simply fails to mount ("Failed mounting or unmounting."). So I tried getting the gcc and make packages (+dependencies) from the Ubuntu repos, and install those (Puppy has an "undeb" utility). There are actually supposedly two ways of doing that: one is to click on the file in ROX-Filer, and that opens a confirmation dialog to install, so I tried that first (with all the .debs). That seemed to report a successful installation for each package (confirmation dialogs popped up to report installation success), but when I tried typing "gcc" in the terminal, it still couldn't find it ("bash: gcc: command not found").

So then I tried the second way: using "undeb" in the terminal. That again was supposedly successful (no errors), but still "bash: gcc: command not found" and "/usr/bin/gcc: No such file or directory".

So then I tried "file /usr/bin/gcc" and it gives this:


/usr/bin/gcc: broken symbolic link to 'gcc-4.3'
And of course, as expected, "find / -name "gcc-4.3" finds nothing.

Where are these files being extracted to, if at all? And I can't just use the package manager, because I don't have internet (this is how I'm trying to get internet). Am I totally screwed?

EDIT: Sorry if this seems somewhat discontinuous, I'm just getting a bit impatient with this...

colorpurple21859 01-19-2010 06:30 PM

Is the devx_430.sfs file version match the version of puppy you are using? It might also be a bad download of the file

MrCode 01-19-2010 06:53 PM

The machine has Puppy 4.3.0, and I downloaded both the devx_430.sfs and the devx_431.sfs; neither would mount.

I'll try re-downloading, though, just to see if I got bad luck with both files.

EDIT: I'm using a thumb drive to transfer files between the two computers. Does it matter where I'm attempting to mount the devx file from?

UPDATE: Nope, still nothing. The md5sum checks out okay, but it still won't mount. Maybe it's that you can't mount a squashfs filesystem with a HDD installation of Puppy?

colorpurple21859 01-19-2010 07:50 PM

Are these the instructions you used to install file to a hard drive installation?
I have puppy 4.31 and hard drive installation and installed file without no problems. I have the devx_431.sfs file located in my-documents directory. Don't know if that makes a difference or not.
You are left clicking the devx_430.sfs file icon and not right clicking

MrCode 01-19-2010 08:14 PM


Are these the instructions you used to install file to a hard drive installation?
Yes, those are the instructions I'm following. I can't even get past the first step, though. I'm left-clicking, for sure. :D

I'll see if moving the file to the my-documents folder helps or not...

UPDATE: It worked! I moved the devx_430.sfs file to the my-documents folder and it mounted successfully. I was then able to complete the installation.

Now on to compiling the drivers...UGH.

MrCode 01-19-2010 08:53 PM

Posting from Puppy. Thanks for the help! :D

All times are GMT -5. The time now is 12:44 PM.