LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installing Gaim 0.71 (https://www.linuxquestions.org/questions/linux-software-2/installing-gaim-0-71-a-105735/)

hyperriven 10-18-2003 09:20 PM

Installing Gaim 0.71
 
I am trying to install Gaim 0.71 but I get this error:

checking for GLIB - version >= 2.0.0... no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at (the gtk web-page)

I have installed newer versions of GLIB, uninstalled and reinstalled GLIB, but the error message doesn't go away. I am new to Linux and have no idea what to do next. Any ideas? Please give specific instructions.

Thanks,
Tom

trickykid 10-19-2003 12:03 AM

Try running ldconfig to update your lib database.

If that doesn't work, make sure that its in your path.

Cimmerian 10-19-2003 04:34 AM

Isn't it typical for rpm distros to have devel rpm's if you want to compile against libraries? Like glib-devel-2.x.x**.rpm or glib2-devel....

hyperriven 10-19-2003 10:21 AM

I have ran ldconfig, and it didn't seem to help. The files all seem to be in the right path also. By the way I have Mandrake 9.1, so I don't know what to do with rpm's.

Cimmerian 10-19-2003 03:51 PM

I haven't used mdk in a long time, but if I'm not mistaken, there was some app that let me search for packages on the disks and even online. Rpmdrake? Some mdk package manager anyways. I would believe glib2-devel can be found there. You need stuff like devel-headers to compile, and they are not always installed by default, as you don't need them to simply run the distro. I assume when you say you install/reinstall glib and newer versions, that you only install the glib(2) rpm?

hyperriven 10-24-2003 08:24 PM

When I say I install and reinstall glib I mean I unzip(or whatever you call it in Linux) glib-2.2.3.tar.gz and then change to the glib-2.2.3 directory and do
./configure
make
make install

If I am not root I get this error:

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.

hyperriven 10-24-2003 09:03 PM

I found out that there was a gaim rpm package for Mandrake 9.1(and how to install it(I'm still a new to Linux)) and now I have Gaim .71 installed and running on my computer!!! I still don't understand why I couldn't install it using the gaim-0.71.tar.gz file they had on the website. Isn't that supposed to work for all Linux distributions? What if I want to install something that requires glib and there are no Mandrake rpm file for it?

Micro420 10-24-2003 09:06 PM

Quote:

Originally posted by hyperriven
I found out that there was a gaim rpm package for Mandrake 9.1(and how to install it(I'm still a new to Linux)) and now I have Gaim .71 installed and running on my computer!!! I still don't understand why I couldn't install it using the gaim-0.71.tar.gz file they had on the website. Isn't that supposed to work for all Linux distributions? What if I want to install something that requires glib and there are no Mandrake rpm file for it?
Welcome to the world of Linux. My advice: if there's an RPM file, grab it! Avoid *.tar files cause you run into problems like what you did. Others will disagree with me, but you're a newb, I'm a newb, and we just want it to work - simple, fast, and easy! RPM's Rules!!

By the way, if it ever says you need some kind of file, go to your Mandrake Control Center. Then go to Softwares and click on Add RPM and search for whatever it is missing. It may already be on the Mandrake 3 CD's.

quatsch 10-24-2003 09:11 PM

As that message from your attempt to isntall glib shows, you already have glib installed. The problem is that the configure script can't find it. Usually, what needs to be done is some edting of some config files or passing some parameters to the configure scripts. As Micro420 says, it's much more painless to use an rpm if there is one

uglydot 10-25-2003 02:15 AM

I have compiled this version of GAIM under slackware 9.1. When I load it up, it says that it cannot load the MSN plugin. The program works fine, but this is kind of annoying, I do I get rid of the error.

Jefklak 10-25-2003 04:33 AM

Ugly, try starting another thread about your problem, you'll get more answers that way. I honestly don't know, donwload a plugin or recompile and try again?

Pecunia 10-25-2003 04:49 AM

Uglydot, the Gaim FAQ has the answer: you need SSL to load the MSN plugin, either GnuTLS or the combination of NSS and NSPR from the Mozilla project.
I haven't found out yet how to completely disable the MSN plugin since I don't need it ...

namespace 10-25-2003 08:31 AM

Quote:

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
As the cript said you should uninstall your old glib2(2.2.1) first before you install the new one(2.2.3)...In my opinion,if you have time,compiling the source code is the best way in Linux ,as it's fast speed and transparent to you.

Jefklak 10-25-2003 09:14 AM

Especially if you're using Gentoo :)

hyperriven 10-25-2003 11:12 AM

How do you uninstall glib2(2.2.1). I looked in RPMDrake, but I only saw glibc-devel-2.3.1-10mdk.

And if I were to compile the source code, how would I do that? I am new to linux. Complete instructions would be great!


All times are GMT -5. The time now is 07:09 AM.