LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installing from source (https://www.linuxquestions.org/questions/linux-software-2/installing-from-source-88443/)

Mahoot 09-02-2003 11:37 AM

Installing from source
 
Hi people,
I downloaded and installed Mandrake 9.1 and love it. I even managed to install a couple of rpm progams, (anyone who can't install rpms doesn't deserve to run Linux).
I'm trying to install eb-lite, and having probs. I downloaded eb-lite-alpha-9.tar.gz. I was able to unzip and move it to /usr/local/, and I do have a directory there containing core and ebqt subdirectories. There is where I'm stalled. I studied several tutorials on installing programs, and tried the methods explain in them(as I understood it ) with no good results. What am I doing wrong. I'm just learning this so I was wondering if someone could be kind enough to tell me exactly what I have to do, preferably the whole exact command line. I've tried to understand the tutorials, but somewhere I am missing something. I never considered myself any kind of a whiz. Help, Please.
Thank you for any input, you may feel like forewarding. If it is easier you could email me at mahoot51@yahoo.ca
:Pengy:

DrOzz 09-02-2003 11:41 AM

well you should read the INSTALL and README files if they exist in the extracted folders...not all tarballs are the same....but in any case i will show you the most frequent method...
you untar the file
cd into the directory
then type the following commands....
./configure
make
su -c "make install"
type root password

and most often when the above isn't the case, the executable is usually within the extracted folder....so you'll have to be the judge of what your working with...

Mahoot 09-02-2003 06:54 PM

Ok, I unpacked, cd ed into the directory, and typed in ./configure just as the readme file said to.
The full line read
[meuser@localhost eb-lite-alpha-9]$ ./configure
I hit enter and received the message
bash: ./configure: no such file or directory
What am I doing wrong.
I tried the same thing with the sub-directories in the eb-lite dir. with the same results.

sandeep 09-03-2003 02:50 AM

looks like you don't have a 'configure' file or (strangely) if there is one it does'nt have the eXecute flag turned on for the user.
In case you have a configure file do a
chmod 755 configure
then you should be able to execute it.
Most likely you don't have a configure file, look for Makefile instead.
If you have one just do
make
make install.


All times are GMT -5. The time now is 10:56 PM.