LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-20-2005, 10:12 AM   #1
buffed317
Member
 
Registered: Jun 2004
Location: New Jersey, USA
Distribution: Slackware 11
Posts: 191

Rep: Reputation: 31
installing dvd::rip


i am trying to install dvd::rip. i dwl the source and went to install it and got this:

root@brian:/home/brian/Video-DVDRip-0.52.2# perl Makefile.PL
Checking if your kit is complete...
Looks good
Warning: prerequisite Gtk 0.7008 not found.
Warning: prerequisite Gtk::Gdk::Pixbuf 0 not found.
Warning: prerequisite Locale::TextDomain 0 not found.
Writing Makefile for Video:VDRip


so i dwl Gtk-0.1.11 and went to install that and i got this:

root@brian:~/Gtk-0.1.11# perl Makefile.PL
Checking if your kit is complete...
Looks good
Writing Makefile for Gtk
root@brian:~/Gtk-0.1.11# make test
make: *** No rule to make target `Atoms.pm', needed by `pm_to_blib'. Stop.
root@brian:~/Gtk-0.1.11# make install
make: *** No rule to make target `Atoms.pm', needed by `pm_to_blib'. Stop.

so i searched atom.po on google and found this link but i dont know what to do with it:

http://dev.w3.org/cvsweb/perl/module...toms.pm#rev1.8

what do i do with it?

there are three other packages i have to install which are required by dvd::rip so this will most likely be one of many questions.

thanks
 
Old 02-21-2005, 12:27 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
if the program is after gtk 0.7008, why have you got a version called 0.1.11? the version number is there for a reason.....

this version 0.1.11 appears to be more than 8 years old.....!

get the proper version (actually 0.7009 now) from cpan.org.
 
Old 02-21-2005, 10:27 PM   #3
buffed317
Member
 
Registered: Jun 2004
Location: New Jersey, USA
Distribution: Slackware 11
Posts: 191

Original Poster
Rep: Reputation: 31
so dwl the right file now i get this:

root@brian:/usr/lib/Gtk-Perl-0.7008# perl Makefile.PL
Can't exec "gnome-config": No such file or directory at Makefile.PL line 141.
Can't exec "gnome-config": No such file or directory at Makefile.PL line 141.
Can't exec "gnome-config": No such file or directory at Makefile.PL line 141.
Can't exec "libglade-config": No such file or directory at Makefile.PL line 141.Submodule gnome is needed to build applets but it appears
it's misdetected or not selected for compilation.
Available modules: gtk gtkglarea gdkimlib gdkpixbuf gtkhtml gtkxmhtml gnome glade applets gnomeprint.

You can disable the inclusion of a module using --without-pkgname.
If a package is misdetected and you still want it to compile
use --with-pkgname-force.
To disable autodetection of modules use --without-guessing.


what does it mean?
 
Old 02-26-2005, 07:05 AM   #4
covox
LQ Newbie
 
Registered: Feb 2005
Distribution: slackware-current
Posts: 1

Rep: Reputation: 0
You might want to use cpan to get Gtk-Perl 0.7009:
http://search.cpan.org/CPAN/authors/...-0.7009.tar.gz

Gtk-Perl is bound to gtk-1.2; so make sure you have the latest old versions of gtk and glib:
ftp://ftp.gtk.org/pub/gtk/v1.2/glib-1.2.10.tar.gz
ftp://ftp.gtk.org/pub/gtk/v1.2/gtk+-1.2.10.tar.gz

gnome-config is the old configure script used by pre-2.0 versions of gnome. To get it you need to install an old copy of gnome-libs:
http://ftp.gnome.org/pub/GNOME/sourc...-1.4.2.tar.bz2

Also it's looking for an old version of libglade, available at:
http://ftp.gnome.org/pub/GNOME/sourc...de-0.17.tar.gz

I'll say now that it might still kick up a lot of a fuss when you're trying to compile it (especially when it gets up to the CORBA bindings), so be prepared to get your hands dirty :P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installing dvd::rip and dependencies Garibaldi3489 Slackware 10 03-07-2005 04:28 AM
DVD AVI rip to DVD mooreted Mandriva 4 02-20-2005 09:57 AM
installing dvd::rip problem afrodocter Linux - Software 12 11-19-2004 02:30 PM
DVD::Rip and Burning to DVD lapthorn Linux - Software 4 10-19-2004 02:19 PM
Can't rip DVDs with dvd::rip Hammett Linux - Software 2 10-27-2003 09:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration