-   Linux - Software (
-   -   Installing Catalyst 11.12 Drivers, Fedora 16 Gnome3 (

bplis* 01-15-2012 09:18 PM

Installing Catalyst 11.12 Drivers, Fedora 16 Gnome3
Just got a new graphics card, the Radeon HD 6850. I know not what I currently have installed driver-wise, but once installed it immediately worked. I, hoping to optimize speed, installed the new Catalyst 11.12 drivers. However, after rebooting when prompted to do so, my system started in Gnome3 fallback mode, and would not work properly. I rebooted several times, bu to no avail. I found the uninstall, and uninstalled the catalyst driver. Upon rebooting, my system was fixed. However, I would like to know which version of catalyst will work with my system, and weather it would be possible to install 11.12 in a different way to allow Gnome 3 to function normally.

sntnlz 01-16-2012 06:13 PM

If you haven't done this after installing the driver, chances are your problem could be fixed if your run the following command from a terminal and tehn reboot:

aticonfig --initial

larrym82 01-16-2012 06:16 PM

As I recall, when you perform the install from a .iso disk, you would have a function key at the bottom of the screen labeled Driver. I haven't run through the routine, but you should be able to copy the driver onto a USB drive and install it along with the rest of your system.

colorpurple21859 01-16-2012 07:20 PM

adding nomodeset to the linux line in grub2 also might help

bplis* 01-18-2012 07:35 PM

Well I tried installing it from ATI's driver website. The install disk was only for windows. I eventually gave up trying to get the official version to work, and used yum to install drivers from the repositories. Unfortunately, the card runs much slower here than it does running under Windows with the official drivers from the website. I do not like using Windows, though, and would prefer to be able to run graphics-intense applications under Linux (Fedora). For example, I can play a small game (Minecraft) with 20FPS under Linux and about 120 FPS under Windows. And no, I am not installing from an .iso, and I already did the aticonfig. Nothing worked.

colorpurple21859 01-18-2012 09:18 PM

got to click on enable rpm fusion. after installing should give option to install catalyst drivers in fedora software center, if I remember right

All times are GMT -5. The time now is 06:52 AM.