LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Installing Apollon on Debian and getting this error (https://www.linuxquestions.org/questions/linux-software-2/installing-apollon-on-debian-and-getting-this-error-150146/)

shodekiagari 02-24-2004 07:51 PM

Installing Apollon on Debian and getting this error
 
-lSM -lICE -lpthread
grep: /usr/lib/libXft.la: No such file or directory
/bin/sed: can't read /usr/lib/libXft.la: No such file or directory
libtool: link: `/usr/lib/libXft.la' is not a valid libtool archive
make[4]: *** [libapollon.la] Error 1
make[4]: Leaving directory `/home/shodekiagari/Desktop/apollon-dist/apollon-0.9.2/apollon/libapollon'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/shodekiagari/Desktop/apollon-dist/apollon-0.9.2/apollon/libapollon'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/shodekiagari/Desktop/apollon-dist/apollon-0.9.2/apollon'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/shodekiagari/Desktop/apollon-dist/apollon-0.9.2'
make: *** [all] Error 2


Could anyone help? Thanks

shodekiagari

Rounan 02-25-2004 08:59 AM

I don't know anything about Apollon, but just from that error message it looks like you don't have a required dependancy - libXft.
Check the installation readme that came with the software, make sure you have dependancies installed, and perhaps pass a parameter to the ./configure script to tell it where your libraries are.

Have you tried apt-get appollon? Or is that what's generating the error?

--Rounan


All times are GMT -5. The time now is 07:31 PM.