LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-09-2009, 10:13 AM   #1
Hb_Kai
Member
 
Registered: Jan 2008
Distribution: Windows 8.1, Debian 7
Posts: 91

Rep: Reputation: 49
Installing and configuring Firestarter


I've just installed Firestarter and having a problem configuring it. I'm using a wireless connection which isn't actually mine, it's my mums.

I've tried setting it up with

Detected Devices : Unknown Device (Wifi0)
thinking wifi means Wireless, but I don't know why it's not starting. Each time I click to start Firestarter it says;

Quote:
Failed to start the firewall

The device Wifi0 is not ready.

Please check your network device settings and make sure your Internet connection is active.
Have I done it right?

Last edited by Hb_Kai; 01-09-2009 at 10:13 AM. Reason: spelling errors, etc...
 
Old 01-09-2009, 12:55 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 26,920

Rep: Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016
Quote:
Originally Posted by Hb_Kai View Post
I've just installed Firestarter and having a problem configuring it. I'm using a wireless connection which isn't actually mine, it's my mums.

I've tried setting it up with

Detected Devices : Unknown Device (Wifi0)
thinking wifi means Wireless, but I don't know why it's not starting. Each time I click to start Firestarter it says;

Have I done it right?
No. The device is the device on your system, not the name of the access point. What device is your wireless NIC? eth1? wlan0? Type in "ifconfig -a" at a prompt, and it should return the NIC device information. Use that device name.
 
Old 01-09-2009, 01:11 PM   #3
Hb_Kai
Member
 
Registered: Jan 2008
Distribution: Windows 8.1, Debian 7
Posts: 91

Original Poster
Rep: Reputation: 49
Sorry. I don't get what you mean... I typed ifconfig -a in Terminal and got this.

Code:
ryan@ubuntu:~$ ifconfig -a
ath0      Link encap:Ethernet  HWaddr 00:16:e3:be:49:f8  
          inet addr:192.168.1.64  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::216:e3ff:febe:49f8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:79131 errors:0 dropped:0 overruns:0 frame:0
          TX packets:66094 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:90596382 (90.5 MB)  TX bytes:10094116 (10.0 MB)

eth0      Link encap:Ethernet  HWaddr 00:16:36:eb:a5:79  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:21 Base address:0xa000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:228 errors:0 dropped:0 overruns:0 frame:0
          TX packets:228 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11628 (11.6 KB)  TX bytes:11628 (11.6 KB)

pan0      Link encap:Ethernet  HWaddr be:2f:52:66:de:51  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wifi0     Link encap:UNSPEC  HWaddr 00-16-E3-BE-49-F8-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:193122 errors:0 dropped:0 overruns:0 frame:4812
          TX packets:68040 errors:4 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199 
          RX bytes:107431572 (107.4 MB)  TX bytes:12306486 (12.3 MB)
          Interrupt:22 

ryan@ubuntu:~$
 
Old 01-09-2009, 03:06 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 26,920

Rep: Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016
Quote:
Originally Posted by Hb_Kai View Post
Sorry. I don't get what you mean... I typed ifconfig -a in Terminal and got this.

Code:
ryan@ubuntu:~$ ifconfig -a
ath0      Link encap:Ethernet  HWaddr 00:16:e3:be:49:f8  
          inet addr:192.168.1.64  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::216:e3ff:febe:49f8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:79131 errors:0 dropped:0 overruns:0 frame:0
          TX packets:66094 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:90596382 (90.5 MB)  TX bytes:10094116 (10.0 MB)

eth0      Link encap:Ethernet  HWaddr 00:16:36:eb:a5:79  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:21 Base address:0xa000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:228 errors:0 dropped:0 overruns:0 frame:0
          TX packets:228 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11628 (11.6 KB)  TX bytes:11628 (11.6 KB)

pan0      Link encap:Ethernet  HWaddr be:2f:52:66:de:51  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wifi0     Link encap:UNSPEC  HWaddr 00-16-E3-BE-49-F8-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:193122 errors:0 dropped:0 overruns:0 frame:4812
          TX packets:68040 errors:4 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199 
          RX bytes:107431572 (107.4 MB)  TX bytes:12306486 (12.3 MB)
          Interrupt:22 

ryan@ubuntu:~$
Ok. What you got shows you kind of what the error is. Linux is case sensitive...Wifi0 isn't the same as wifi0. Plus, the wifi0 device on your system, isn't configured...it has no IP address.

The one address you have is configured on ath0. You can try one of three different things:

- Use ath0 as your interface
- Configure wifi0 to have an interface
- Change the case of Wifi0 to wifi0, and see if it works.
 
Old 01-09-2009, 03:20 PM   #5
Hb_Kai
Member
 
Registered: Jan 2008
Distribution: Windows 8.1, Debian 7
Posts: 91

Original Poster
Rep: Reputation: 49
How do I configure wifi0 to have an interface?

Wifi0's spelling was my mistake by the way.
 
Old 01-09-2009, 06:27 PM   #6
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
I don't use Firestarter for a long time,but as I remember it's good idea to run it as root,from the terminal,because otherwise it can crash,often.It looks like you should use ath0 to configure your connection in Firestarter,because that is the active connection and I belive it would be the easiest to configure for you,so enter
Quote:
inet addr:192.168.1.64 Bcast:192.168.1.255 Mask:255.255.255
when asked for it and getaway address too in the Firestarter.That was the first option that TBOne suggested.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Firestarter In Opensuse 10.2 Red Knuckles SUSE / openSUSE 3 12-17-2006 07:23 PM
Installing Firestarter Mr.Nemo Linux - Security 4 08-01-2005 06:34 PM
Problems installing firestarter.... Adrian13 Linux - Software 2 10-15-2004 11:01 AM
Error installing Firestarter sharpie Slackware 5 03-12-2004 02:59 AM
Installing Firestarter buckeyejerry Linux - Networking 1 01-18-2003 03:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration