LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-20-2017, 12:26 AM   #1
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,560

Rep: Reputation: 208Reputation: 208Reputation: 208
Installed a new Thunderbird along with language pack, but new language ain't there.


I run Debian 9 (stable, aka Stretch). I decided to upgrade Thunderbird (to try and solve some other problem) from Sid's sources; so, I compiled the source from Sid for Stretch. It installed with no problem and works well. I also installed a language pack for British English (so that "color" will be "colour" --> the former spelling just looks too much like the word "colon" to me). However, Thunderbird still shows "color".

I installed thunderbird_52.2.1-4_amd64.deb along with thunderbird-l10n-en-gb_52.2.1-4_all.deb. Also, I have installed hunspell, and hunspell-en-ca and hunspell-en-gb, but this just gave me spell check dictionaries rather than correcting the spelling on the actual Thunderbird program.
Attached Thumbnails
Click image for larger version

Name:	ThunderColor.png
Views:	17
Size:	21.3 KB
ID:	25519  
 
Old 07-20-2017, 08:06 AM   #2
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Might be .thunderbird/profile dependant?
Have you tried a clean, or new one?

Just saying.
 
Old 07-21-2017, 07:53 AM   #3
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,560

Original Poster
Rep: Reputation: 208Reputation: 208Reputation: 208
Quote:
Originally Posted by Habitual View Post
Might be .thunderbird/profile dependant?
Have you tried a clean, or new one?

Just saying.
I assume you mean deleting the .thunderbird file. No, I haven't. It likely would be fine to try, but the idea spooks me a bit.

I notice that all the programs have en-us spellings in spite of Debian presumably obtaining the locale (Canada) in the initial set-up (the keyboard was set to en-us though, which is typically what's used). I recall some time ago that I did manage, when I was using Vector Linux, to have en-gb set up (I don't think en-ca was recognized by most programs). That may be a part of the problem, in that Canada is simply too small-fry to be acknowledged.

Quote:
mark@debian:~$ locale
LANG=en_CA.utf8
LANGUAGE=en_CA:en
LC_CTYPE="en_CA.utf8"
LC_NUMERIC="en_CA.utf8"
LC_TIME="en_CA.utf8"
LC_COLLATE="en_CA.utf8"
LC_MONETARY="en_CA.utf8"
LC_MESSAGES="en_CA.utf8"
LC_PAPER="en_CA.utf8"
LC_NAME="en_CA.utf8"
LC_ADDRESS="en_CA.utf8"
LC_TELEPHONE="en_CA.utf8"
LC_MEASUREMENT="en_CA.utf8"
LC_IDENTIFICATION="en_CA.utf8"
LC_ALL=
mark@debian:~$
Perhaps if I could change LANG and LANGUAGE to en_GB, though some British spellings are off from what I'm used to (Canada is kinda in the middle of US and British spellings, though it's closer to British spellings than US spellings).

Still, I don't even think this should be an issue with Thunderbird. The language packs are there, yet I'm not sure how to get them working (they are supposedly enabled -- see attached photo).

Well, it's almost nine in the morning. So, I'll look at this later, since it's time to crack open a brewski and watch the Beachcombers.
Attached Thumbnails
Click image for larger version

Name:	TBlangpack.png
Views:	11
Size:	66.3 KB
ID:	25526  

Last edited by mark_alfred; 07-21-2017 at 08:01 AM.
 
Old 07-21-2017, 08:21 AM   #4
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,560

Original Poster
Rep: Reputation: 208Reputation: 208Reputation: 208
Tried the following:
Code:
root@debian:/home/mark# export LANGUAGE=en_GB:en
root@debian:/home/mark# locale
LANG=en_CA.utf8
LANGUAGE=en_GB:en
LC_CTYPE="en_CA.utf8"
LC_NUMERIC="en_CA.utf8"
LC_TIME="en_CA.utf8"
LC_COLLATE="en_CA.utf8"
LC_MONETARY="en_CA.utf8"
LC_MESSAGES="en_CA.utf8"
LC_PAPER="en_CA.utf8"
LC_NAME="en_CA.utf8"
LC_ADDRESS="en_CA.utf8"
LC_TELEPHONE="en_CA.utf8"
LC_MEASUREMENT="en_CA.utf8"
LC_IDENTIFICATION="en_CA.utf8"
LC_ALL=
I initially tried changing the LANG parameter, but that changed everything. So, I went with language. I'll try rebooting to see if there's any difference (I expect not)... ETA: no, that failed. It went back to the default. It's a misplaced idea.

Last edited by mark_alfred; 07-21-2017 at 10:34 AM.
 
Old 07-21-2017, 10:40 AM   #5
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,560

Original Poster
Rep: Reputation: 208Reputation: 208Reputation: 208
I searched and found on another forum how I had successfully done this some years ago, and tried the same thing with this current version of Thunderbird that I have. I opened the config editor in Thunderbird (Preferences -> Advanced -> General), and searched for the entry "general.useragent.locale" and set its value to en-GB. This had worked in the past, but no luck this time. Not sure what to try.
Attached Thumbnails
Click image for larger version

Name:	TBlangConfig.png
Views:	5
Size:	19.3 KB
ID:	25528  
 
Old 07-21-2017, 11:31 AM   #6
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by mark_alfred View Post
I assume you mean deleting the .thunderbird file.
Code:
if [ backups = true ]]  
rm -fr ~/.thunderbird
else
mv ~/.thunderbird ~/.thunderbird.org
fi

I use .org to signify original
 
Old 07-21-2017, 01:50 PM   #7
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,560

Original Poster
Rep: Reputation: 208Reputation: 208Reputation: 208
Thanks for the script. Rather than use it, I just dumped the .thunderbird file in the Trash bin, and then opened up Thunderbird. My email was gone and it asked me to set up my address again. I skipped that and checked to see if the language had changed (IE, if stuff like "color" was now spelled as "colour"), and it wasn't. It was still in en-US, in spite of the English (GB) language packs being present. So, I closed Thunderbird, got rid of the newly created .thunderbird file, and restored the old one (my email and stuff is now back as well).
 
Old 07-21-2017, 07:00 PM   #8
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
The language pack just refers to spelling and window labels. The actual web content remains unchanged.
 
Old 07-21-2017, 09:00 PM   #9
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,560

Original Poster
Rep: Reputation: 208Reputation: 208Reputation: 208
Quote:
Originally Posted by AwesomeMachine View Post
The language pack just refers to spelling and window labels. The actual web content remains unchanged.
Precisely what I'm referring to. See the attachment in the opening post.
 
Old 07-21-2017, 10:05 PM   #10
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
Perhaps the language pack refers only to spelling. See is you can spell colour, and whether it gets marked. In GB both color and colour are considered acceptable.
 
Old 07-22-2017, 12:45 AM   #11
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,560

Original Poster
Rep: Reputation: 208Reputation: 208Reputation: 208
The language pack is not meant as a spell-checker for email that I type. That was provided by the package hunspell-en-ca (the language pack was installed at the same time as Thunderbird, and hunspell was installed later. I did not have a spell-check until I installed hunspell). ETA: I also installed hunspell-en-gb, and when under Preferences --> Composition --> Language, I choose "English (United Kingdom)", it gives the same result as pictured.
Attached Thumbnails
Click image for larger version

Name:	hunspellcheck.png
Views:	5
Size:	7.3 KB
ID:	25529  

Last edited by mark_alfred; 07-22-2017 at 12:51 AM.
 
Old 07-22-2017, 08:21 AM   #12
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
TBH Mark, I have overlooked this issue for years in Mozilla products, or never cared enough to figure out why all my American English words
do the same thing.
 
Old 07-22-2017, 09:06 AM   #13
sysfce2
Member
 
Registered: Jul 2009
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
I think the only way is to install a fully localized version: if that's not an option in Ubuntu then there is Mozilla's direct link.

Last edited by sysfce2; 07-22-2017 at 09:39 AM.
 
Old 07-22-2017, 11:49 AM   #14
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,788

Rep: Reputation: 2140Reputation: 2140Reputation: 2140Reputation: 2140Reputation: 2140Reputation: 2140Reputation: 2140Reputation: 2140Reputation: 2140Reputation: 2140Reputation: 2140
This is something you'll just have to live with! Programmers will create versions for foreign languages, but not for varieties of the same language. In Open/LibreOffice, you can have British spellchecking, but the only English user interface is US.
 
Old 07-22-2017, 12:13 PM   #15
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,560

Original Poster
Rep: Reputation: 208Reputation: 208Reputation: 208
Historically they have created a language pack for en-gb, and are still doing so. That it's not working may be a bug. Here's the site of the software. https://wiki.mozilla.org/L10n:Teams:en-GB

ETA: I did just now submit a bug report on the package thunderbird-l10n-en-gb using reportbug.

Last edited by mark_alfred; 07-22-2017 at 01:12 PM.
 
  


Reply

Tags
l10n-en-gb, language, spelling, thunderbird


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] firefox esr: no german language pack fsauer Slackware 5 07-02-2013 07:10 AM
i just installed rosetta stone trying to install a language pack baronobeefdip Linux - Software 3 03-30-2012 12:26 AM
Chinese language pack installation help shiokie Linux - Newbie 1 08-15-2010 09:19 AM
Where to get language pack for kde4? Raynus Linux - Software 1 02-04-2009 11:37 PM
openoffice.org language pack evensen Linux - Software 0 06-01-2004 01:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration