-   Linux - Software (
-   -   installed a mythtv client, very choppy video on All meida (tv,video etc) (

zeltak 01-24-2007 09:28 AM

installed a mythtv client, very choppy video on All meida (tv,video etc)
Hi all

i just installed my mythtv client pc today (p4 1.5, 512 mb RdRAM,ATI radeon 9500). All seems to go well except i am having major playback issue. all my live tv,playback of tv records and media library files (avi,mpeg,divx etc..) are very choppy when played. The sound seems to work ok. The music module gives me an error about "Decoder error. DecoderMAD: Failed to open input. Error 5.". i have been able to connect to the backend and watch live tv (in bad quality) and see the program guide so i assume its not a connection problem. the choppy playback also happens in Xine as well but works well in vnc.

any idea guys?



zeltak 01-24-2007 01:28 PM

I thought this may help, i dont know how to attach a file here but here is a suspicious part in the terminal when i run mythfronend manually:

2007-01-24 21:16:52.688 TV: Attempting to change from None to WatchingLiveTV
2007-01-24 21:16:52.690 Using protocol version 31
2007-01-24 21:16:53.970 DPMS Deactivated
2007-01-24 21:16:54.262 AFD: Opened codec 0x9d8f240, id(MPEG2VIDEO) type(Video)
2007-01-24 21:16:54.339 AFD: Opened codec 0x9d8ec00, id(MP2) type(Audio)
2007-01-24 21:16:54.629 Opening OSS audio device '/dev/dsp'.
2007-01-24 21:16:54.714 VideoOutputXv: XvMCTex: Init failed
2007-01-24 21:16:54.716 VideoOutputXv Error: Could not find suitable XVideo surf
2007-01-24 21:16:54.717 VideoOutputXv: Falling back to X shared memory video out
*** May be slow ***
2007-01-24 21:17:01.397 TV: Changing from None to WatchingLiveTV
2007-01-24 21:17:01.405 New DB connection, total: 3
2007-01-24 21:17:01.408 Realtime priority would require SUID as root.
2007-01-24 21:17:01.442 Connected to database 'mythconverg' at host:
2007-01-24 21:17:01.597 Video timing method: USleep with busy wait
2007-01-24 21:17:03.116 NVP: prebuffering pause
2007-01-24 21:17:04.324 NVP: prebuffering pause
2007-01-24 21:17:05.554 NVP: prebuffering pause
2007-01-24 21:17:07.087 NVP: prebuffering pause
2007-01-24 21:17:07.457 VideoOutputXv Error:
* Your system is not capable of displaying the
* full framerate at 800x600 resolution. Frames
* will be skipped in order to keep the audio and
* video in sync.

i have a p4 1.5, 512 mb RdRAM,ATI radeon 9500 so i dont see how thats possible

b0uncer 01-24-2007 01:39 PM

Just to make sure: have you configured your ATI card's drivers or do you use the stock settings that came with the installation? In case you haven't manually checked the drivers or installed fglrx 3d drivers, you should make this sure:


cat /etc/X11/xorg.conf | grep river
'river' because I don't remember right now if it's 'Driver' or 'driver' :) anyway, if you get a driver name 'vesa' instead of 'radeon' or 'fglrx', that might be your problem. It should be 'radeon' at least, that ought to work, but even if it is 'radeon', you could try installing the ATI fglrx driver from Kubuntu's reposities (and reboot after this; for some reason this driver isn't completely loaded before you reboot and the kernel is restarted).

Also: what colour depth and resolution are you using? Did you try on lower resolution, just in case?

zeltak 01-24-2007 01:53 PM

thx for the reply

i am using the fglrx driver. im using it at normal pal resolution.



All times are GMT -5. The time now is 03:31 AM.