LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-17-2017, 04:35 PM   #1
chtsalid
Member
 
Registered: Jan 2017
Posts: 67

Rep: Reputation: Disabled
Install wireshark 2.2.3 in CentOS 7


Hi all,

I installed wireshark using yum and noticed that it installs an old version.

How can we install the newest version 2.2.3?

Many thanks!

[root@srv3 ~]# yum install wireshark
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.copahost.com
* extras: centos.mirror.net-d-sign.de
* updates: centos.mirrors.as250.net
Resolving Dependencies
--> Running transaction check
---> Package wireshark.x86_64 0:1.10.14-10.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
wireshark x86_64 1.10.14-10.el7 base 13 M

Transaction Summary
================================================================================
Install 1 Package

Total download size: 13 M
Installed size: 67 M
Is this ok [y/d/N]: n
Exiting on user command
Your transaction was saved, rerun it with:
yum load-transaction /tmp/yum_save_tx.2017-01-17.23-30.vIlAYn.yumtx
 
Old 01-17-2017, 07:28 PM   #2
Danny Michael
LQ Newbie
 
Registered: Aug 2014
Posts: 21

Rep: Reputation: Disabled
This is how I do it after downloading source tarball from wireshark.org.

# Build Wireshark from source tarball in ~/Downloads

sudo yum install bison flex gtk3-devel qt-devel gcc-c++ libpcap-devel c-ares-devel libsmi-devel gnutls-devel libgcrypt-devel krb5-devel GeoIP-devel ortp-devel portaudio-devel automake autoconf libtool

tar xf ~/Downloads/wireshark-2.2.3.tar.bz2 -C /tmp

cd /tmp/wireshark-2.2.3

./autogen.sh

./configure --enable-setcap-install

make

sudo make install

(there may be some other dependencies needed that I already had installed from previous installations, but this should get you close.)

Last edited by Danny Michael; 01-17-2017 at 07:32 PM.
 
2 members found this post helpful.
Old 01-17-2017, 10:46 PM   #3
Jjanel
Member
 
Registered: Jun 2016
Distribution: any&all, in VBox; Ol'UnixCLI; NO GUI resources
Posts: 999
Blog Entries: 12

Rep: Reputation: 363Reputation: 363Reputation: 363Reputation: 363
Just fyi (since this Thread interested me), here's another: http://blog.jeffli.me/blog/2016/08/1...rk-in-centos-7
(&LFS: http://www.linuxfromscratch.org/blfs...wireshark.html )
Best wishes. And thanks #2
 
2 members found this post helpful.
Old 01-18-2017, 04:49 AM   #4
chtsalid
Member
 
Registered: Jan 2017
Posts: 67

Original Poster
Rep: Reputation: Disabled
Hi both,

thank you for your help! I installed the newest version as you suggested.

The problem now is, when I run the program I receive the message "wireshark: cannot connect to X server"

Any idea how to solve this?

Thanks!


[root@localhost ~]# wireshark -v
Wireshark 2.2.3 (wireshark-2.2.3)

Copyright 1998-2016 Gerald Combs <gerald@wireshark.org> and contributors.
License GPLv2+: GNU GPL version 2 or later <http://www.gnu.org/licenses/old-licenses/gpl-2.0.html>
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Compiled (64-bit) with Qt 4.8.5, with libpcap, without POSIX capabilities,
without libnl, with GLib 2.46.2, with zlib 1.2.7, with SMI 0.4.8, with c-ares
1.10.0, without Lua, with GnuTLS 3.3.24, with Gcrypt 1.5.3, with MIT Kerberos,
with GeoIP, with QtMultimedia, without AirPcap.

Running on Linux 3.10.0-327.el7.x86_64, with locale en_US.UTF-8, with libpcap
version 1.5.3, with GnuTLS 3.3.24, with Gcrypt 1.5.3, with zlib 1.2.7.
Intel Core Processor (Broadwell) (with SSE4.2)

Built using gcc 4.8.5 20150623 (Red Hat 4.8.5-11).
[root@localhost ~]#
[root@localhost ~]# wireshark
wireshark: cannot connect to X server
 
Old 01-18-2017, 06:05 AM   #5
chtsalid
Member
 
Registered: Jan 2017
Posts: 67

Original Poster
Rep: Reputation: Disabled
Hi,

problem is solved, after installing the xorg, by entering yum install xorg-x11*.#

Now, by accessing the server through ssh and having x11 activated and xming runing on windows pc. I get the following problem.


[congiv@lab1sniffer1 ~]$ wireshark
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
wireshark: xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.
Aborted

However, when I access the server from another linux system by entering ssh -X ip_address ... it works fine.

Did you encounter this problem in past? Is this a Xming problem?

Many thanks!
 
Old 01-18-2017, 08:28 AM   #6
chtsalid
Member
 
Registered: Jan 2017
Posts: 67

Original Poster
Rep: Reputation: Disabled
Hi,

in ssh setting of putty I configured localhost:10. However I still receive an error.


[user01@srv1 ~]$
[user01@srv1 ~]$ wireshark
PuTTY X11 proxy: unable to connect to forwarded X server: Network error: Connection refused
QXcbConnection: Could not connect to display localhost:10.0
Aborted (core dumped)

Any idea?

Thanks!
 
Old 01-30-2017, 06:45 AM   #7
chtsalid
Member
 
Registered: Jan 2017
Posts: 67

Original Poster
Rep: Reputation: Disabled
This problem is still unresolved.

While to open remotly wireshark 2.2.3, through a linux device or windows running MobaXterm ssh client works fine, by using putty with xming it is not possible.

[user01@srv1 ~]$ wireshark
PuTTY X11 proxy: unable to connect to forwarded X server: Network error: Connection refused
QXcbConnection: Could not connect to display localhost:10.0
Aborted (core dumped)

This problem is probably related to xming or some settings.

Any idea?

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Wireshark on CentOS 6.4 Axxess Linux - Networking 7 10-17-2013 06:17 PM
how to install wireshark in CentOS 5 kelnel 2.6 server? malli42108 Linux - Newbie 8 11-23-2009 10:28 AM
Wireshark not running on CentOS? deostroll Linux - Software 14 08-18-2009 10:42 AM
Centos - Installing & Using Wireshark tn_nayak Linux - Software 3 09-20-2008 03:24 AM
Wireshark Install On CentOS 64bit krams Linux - Newbie 3 04-24-2007 04:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration