LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-22-2016, 03:43 AM   #1
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Rep: Reputation: Disabled
Unhappy Install RHEL 7.2 with quadro k2200


Hi experts, new guy join today.
Im desperate to look for an solution.
currently i'm installing RHEL 7.2 in my workstation and a NVIDIA graphic card Quadro k2200.
It all went well using onboard VGA, after i boot with Quadro k2200. Its not booting into the OS.
so this is what i done,
  • First, i "blacklist nouveau" at /etc/modprobe.d/blacklist.conf
  • edit /etc/default/grub and append to GRUB_CMDLINE_LINUX:
    "rdblacklist=nouveau nouveau.modset=0"
  • init 5 to install the NVIDIA driver and it successful installed and i do a reboot.

Then the problems come : wait for plymouth boot screen to quit.
The screens just stops here.
i still able to access the command line but not the GUI Interface....
 
Old 06-22-2016, 04:52 AM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Location: Horgau, Germany
Distribution: Manjaro KDE, Win 10
Posts: 2,197

Rep: Reputation: 164Reputation: 164
Can you disable the boot screen.
 
Old 06-22-2016, 05:07 AM   #3
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hi Keruskerfuerst, thanks your reply.

what do you mean by disable the boot screen ?
disable onboard VGA display?
 
Old 06-22-2016, 08:26 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 24,469

Rep: Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243
Quote:
Originally Posted by newGuy@RHEL View Post
Hi experts, new guy join today.
Im desperate to look for an solution.
currently i'm installing RHEL 7.2 in my workstation and a NVIDIA graphic card Quadro k2200. It all went well using onboard VGA, after i boot with Quadro k2200. Its not booting into the OS. so this is what i done,
  • First, i "blacklist nouveau" at /etc/modprobe.d/blacklist.conf
  • edit /etc/default/grub and append to GRUB_CMDLINE_LINUX:
    "rdblacklist=nouveau nouveau.modset=0"
  • init 5 to install the NVIDIA driver and it successful installed and i do a reboot.
Then the problems come : wait for plymouth boot screen to quit. The screens just stops here. i still able to access the command line but not the GUI Interface....
See the bolded part above...INIT 5???? The driver needs to be installed in console mode only...that's "init 3". I would suggest starting over, and re-installing the driver from either single-user mode or as root from mode 3. Also, I'd highly recommend you do NOT use their pre-built module...if you have your kernel source installed (should have installed it at build time...if not, install it from DVD now), and let the nVidia installer build a module for you, that exactly matches your system.

Also, WHY are you using RHEL 7.2??? It is NOT FREE, and unless you're paying for it, you really shouldn't be using it. Load the latest version of CentOS instead, but really, only if you need a SERVER-CLASS distro. RHEL isn't designed for graphics/bluetooth/sound...it's made for back-room servers, that may not even have keyboards attached to them. While you CAN get things working, it may be problematic. Load the latest Fedora if you want to stay within the RHEL ecosystem, or pretty much *ANY* other distro (openSUSE, Debian, Mint, Ubuntu, etc..) that has much better support for such devices.
 
Old 06-22-2016, 07:17 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
to install the nvidia .run ( and NOT the kmod)
gcc and the development tools need to be installed along with the kernel headers

you can groupinstall the compiller
Code:
su -
yum groupinstall "Development Tools"
just double check the spelling of the group with
" yum grouplist "
 
Old 06-23-2016, 02:57 AM   #6
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TB0ne View Post
See the bolded part above...INIT 5???? The driver needs to be installed in console mode only...that's "init 3". I would suggest starting over, and re-installing the driver from either single-user mode or as root from mode 3. Also, I'd highly recommend you do NOT use their pre-built module...if you have your kernel source installed (should have installed it at build time...if not, install it from DVD now), and let the nVidia installer build a module for you, that exactly matches your system.

Also, WHY are you using RHEL 7.2??? It is NOT FREE, and unless you're paying for it, you really shouldn't be using it. Load the latest version of CentOS instead, but really, only if you need a SERVER-CLASS distro. RHEL isn't designed for graphics/bluetooth/sound...it's made for back-room servers, that may not even have keyboards attached to them. While you CAN get things working, it may be problematic. Load the latest Fedora if you want to stay within the RHEL ecosystem, or pretty much *ANY* other distro (openSUSE, Debian, Mint, Ubuntu, etc..) that has much better support for such devices.
Hi TB0ne
Thanks you for your solution.
when i enter init 3 there a prompt saying that
PolicyKit daemon disconnected from the bus
We are no longer a registered authenticated agent

then i proceed with installation of nvidia driver, it fails , noueave driver still using by the system.
How should i proceed with the installation. pls advice
 
Old 06-23-2016, 03:06 AM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
RHEL 7 uses systemd and not systemv
BUT

grub 2 will use the old boot shortcut still

during the 3 second count down and with the curent kernel to boot into selected hit the < e >
then use ther arrows to navagate to the END of the kernel boot line

add a blank space and a 3
hit < F10 >

that boots into the terminal text only boot

login AS ROOT

navigate to where you saved the nvidia.run ( i put it on " /" )

then run it
Code:
sh *.run
BUT

you have to already have installed the kernel headers and gcc and autotools FIRST !!

and for that you HAVE to have a registered install and bought the license

after you blacklist the nouveau driver you will also need to reuild the intred

the olde fedora 22 install guide should work
http://www.forums.fedoraforum.org/sh...d.php?t=305167



but a better option exists

login to the redhat web site ( using the credintials you set up with the support contract

and do a search of the knowledgebase

the full instructions are there

Last edited by John VV; 06-23-2016 at 03:13 AM.
 
Old 06-23-2016, 03:24 AM   #8
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
RHEL 7 uses systemd and not systemv
BUT

grub 2 will use the old boot shortcut still

during the 3 second count down and with the curent kernel to boot into selected hit the < e >
then use ther arrows to navagate to the END of the kernel boot line

add a blank space and a 3
hit < F10 >

that boots into the terminal text only boot

login AS ROOT

navigate to where you saved the nvidia.run ( i put it on " /" )

then run it
Code:
sh *.run
BUT

you have to already have installed the kernel headers and gcc and autotools FIRST !!

and for that you HAVE to have a registered install and bought the license

after you blacklist the nouveau driver you will also need to reuild the intred

the olde fedora 22 install guide should work
http://www.forums.fedoraforum.org/sh...d.php?t=305167



but a better option exists

login to the redhat web site ( using the credintials you set up with the support contract

and do a search of the knowledgebase

the full instructions are there
Thanks your yr solution John.
I do not have a redhat subscription. is it possible for me to download the kernel or development tools fron else where.
 
Old 06-23-2016, 07:58 AM   #9
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 24,469

Rep: Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243
Quote:
Originally Posted by newGuy@RHEL View Post
Hi TB0ne
Thanks you for your solution. when i enter init 3 there a prompt saying that PolicyKit daemon disconnected from the bus We are no longer a registered authenticated agent

then i proceed with installation of nvidia driver, it fails , noueave driver still using by the system.How should i proceed with the installation. pls advice
Read the LQ Rules about text-speak, and about NOT using it, please (not 'pls', and your, not 'yr').

You proceed with the installation, by following the steps/advice you were given. As said, install the kernel source, and build it. But based on this:
Quote:
Originally Posted by newGuy@RHEL
I do not have a redhat subscription. is it possible for me to download the kernel or development tools fron else where.
...you totally ignored what you were told. Again, RHEL is NOT FREE, and unless you're going to pay for it, you SHOULD NOT be using it, period. This is a really good reason as to why. And AGAIN, WHY do you need RHEL???? CentOS is 99.x% IDENTICAL, but totally free....load it instead, but again, as said, ONLY if you need a SERVER. It is REALLY not designed for 'consumer' hardware, like you were told..things like bluetooth, graphics cards, sound, etc., may not work at all, and may be problematic to get working...again, this is a good example.

So:
  • PAY FOR RHEL, and get whatever packages you need from the Red Hat network...
  • ...providing they're not already on the installaton DVD.
  • Load CentOS if you're not planning on paying for RHEL, because you're not doing yourself any favors by making it MUCH more difficult to update/install new packages later
  • And DO NOT load either CentOS or RHEL unless you NEED A SERVER CLASS DISTRO. Chances are, you DO NOT. As you were told before, load the latest Fedora instead, and it will work MUCH better for your needs.
 
Old 06-27-2016, 04:55 AM   #10
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by TB0ne View Post
Read the LQ Rules about text-speak, and about NOT using it, please (not 'pls', and your, not 'yr').

You proceed with the installation, by following the steps/advice you were given. As said, install the kernel source, and build it. But based on this:

...you totally ignored what you were told. Again, RHEL is NOT FREE, and unless you're going to pay for it, you SHOULD NOT be using it, period. This is a really good reason as to why. And AGAIN, WHY do you need RHEL???? CentOS is 99.x% IDENTICAL, but totally free....load it instead, but again, as said, ONLY if you need a SERVER. It is REALLY not designed for 'consumer' hardware, like you were told..things like bluetooth, graphics cards, sound, etc., may not work at all, and may be problematic to get working...again, this is a good example.

So:
  • PAY FOR RHEL, and get whatever packages you need from the Red Hat network...
  • ...providing they're not already on the installaton DVD.
  • Load CentOS if you're not planning on paying for RHEL, because you're not doing yourself any favors by making it MUCH more difficult to update/install new packages later
  • And DO NOT load either CentOS or RHEL unless you NEED A SERVER CLASS DISTRO. Chances are, you DO NOT. As you were told before, load the latest Fedora instead, and it will work MUCH better for your needs.
Thanks for your advise.
Managed to get it done.
NVIDIA Driver is working perfectly fine
 
Old 06-27-2016, 04:59 AM   #11
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Original Poster
Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by John VV View Post
RHEL 7 uses systemd and not systemv
BUT

grub 2 will use the old boot shortcut still

during the 3 second count down and with the curent kernel to boot into selected hit the < e >
then use ther arrows to navagate to the END of the kernel boot line

add a blank space and a 3
hit < F10 >

that boots into the terminal text only boot

login AS ROOT

navigate to where you saved the nvidia.run ( i put it on " /" )

then run it
Code:
sh *.run
BUT

you have to already have installed the kernel headers and gcc and autotools FIRST !!

and for that you HAVE to have a registered install and bought the license

after you blacklist the nouveau driver you will also need to reuild the intred

the olde fedora 22 install guide should work
http://www.forums.fedoraforum.org/sh...d.php?t=305167



but a better option exists

login to the redhat web site ( using the credintials you set up with the support contract

and do a search of the knowledgebase

the full instructions are there
Thanks you for your solution.
i cant find where to put the number 3 after i press <e>.
what i did was set to boot into command line mode (multi-user.default)
 
Old 06-27-2016, 08:51 AM   #12
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 24,469

Rep: Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243
Quote:
Originally Posted by newGuy@RHEL View Post
Thanks for your advise. Managed to get it done. NVIDIA Driver is working perfectly fine
Great...so why don't you post what you actually did to get it working, so others may benefit???
Quote:
Originally Posted by newGuy@RHEL
Thanks you for your solution. i cant find where to put the number 3 after i press <e>. what i did was set to boot into command line mode (multi-user.default)
As said...at the end of the boot line.
 
Old 06-27-2016, 08:57 PM   #13
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Original Poster
Rep: Reputation: Disabled
• Black list nouveau
nano /etc/default/grub > after quit add in “rdblacklist=nouveau”
nano /etc/modprobe.d/blacklist-nouveau.conf
> blacklist nouveau
> nomodeset nouveau=0
• Update Grub2 to take effect for blacklist nouveau
grub2-mkconfig > /boot/grub2/grub.cfg
• Change login to level 3 to install Nvidia Driver
Systemctl set-default multi-user.default
reboot
login in to command line interface, go to the dir where the nvidia driver is.
chmod +x NVIDIA……. run
Sh NVIDIA……run
Click install
• After installation success, change back to GUI Mode
Systemctl set-default graphical.default
Reboot.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Quadro K2000 in RHEL 6.5 problems TronCarter Red Hat 5 01-16-2014 02:45 PM
Nvidia Quadro 980 XGL CentOS 5.4 driver install automation ks.cfg linux_newb Linux - Hardware 3 02-09-2010 06:48 PM
No display on new instal of RHEL 4A 64 with Nvidia Quadro NVS 290 graphics eric_h Linux - Newbie 1 06-03-2009 04:13 PM
NVidia Quadro FX 3450 / RHEL v5 problem. TeamMc Linux - Newbie 1 03-04-2009 06:28 PM
NVIDIA Quadro NVS440 won't start X after RHEL update rdettwyler Linux - Hardware 0 09-19-2006 11:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration