LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Install php-xml fails because php-common is too recent (maybe) (https://www.linuxquestions.org/questions/linux-software-2/install-php-xml-fails-because-php-common-is-too-recent-maybe-4175513299/)

trentham 08-04-2014 09:18 AM

Install php-xml fails because php-common is too recent (maybe)
 
I tried install php-xml on CentOS 6.5, PHP 5.4.30 and got the following

Code:

> yum install php-xml

Loaded plugins: fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: centos.openitc.uk
 * epel: anorien.csc.warwick.ac.uk
 * extras: centos.hyve.com
 * updates: centos.hyve.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-xml.x86_64 0:5.3.3-27.el6_5 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-27.el6_5 for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.24)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.18)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.13)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml-5.3.3-27.el6_5.x86_64
--> Running transaction check
---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be installed
---> Package php-xml.x86_64 0:5.3.3-27.el6_5 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-27.el6_5 for package: php-xml-5.3.3-27.el6_5.x86_64
--> Finished Dependency Resolution
Error: Package: php-xml-5.3.3-27.el6_5.x86_64 (updates)
          Requires: php-common(x86-64) = 5.3.3-27.el6_5
          Installed: php-common-5.4.30-1.el6.remi.x86_64 (@remi)
              php-common(x86-64) = 5.4.30-1.el6.remi
          Available: php-common-5.3.3-26.el6.x86_64 (base)
              php-common(x86-64) = 5.3.3-26.el6
          Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
              php-common(x86-64) = 5.3.3-27.el6_5
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

On the face of it it seems that it's complaining that php-common is TOO up to date. How do I resolve this issue? I've searched around but similar problems seem to focus round php-common being missing.

trentham 08-05-2014 09:28 AM

Solution found
 
I eventually found the package I needed in the 'remi' repository and installed with
Code:

yum --enablerepo remi install php-xml
Now it's all sorted.

Thanks to all who read my question and had a think about it. :cool:


All times are GMT -5. The time now is 08:31 PM.