LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-07-2017, 09:00 AM   #1
Novatian
Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20 KDE and 19 and Android, Windows 10, KDE Neon, Manjaro, Slackware.
Posts: 990

Rep: Reputation: 37
Install latest stable WINE?


Hi on my desktop I am installing WINE the latest stable release. But I did not get to fully install, here is my input into my terminal:
bren@bren-ThinkCentre-M92p ~ $ su
Password:
bren-ThinkCentre-M92p bren # sudo dpkg --add-architecture i386
bren-ThinkCentre-M92p bren # wget -nc https://dl.winehq.org/wine-builds/Release.key
--2017-06-07 23:49:53-- https://dl.winehq.org/wine-builds/Release.key
Resolving dl.winehq.org (dl.winehq.org)... 151.101.80.69
Connecting to dl.winehq.org (dl.winehq.org)|151.101.80.69|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3122 (3.0K) [application/pgp-keys]
Saving to: 'Release.key’

Release.key 100%[===================>] 3.05K --.-KB/s in 0s

2017-06-07 23:49:54 (44.5 MB/s) - 'Release.key’ saved [3122/3122]

bren-ThinkCentre-M92p bren # sudo apt-key add Release.key
OK
bren-ThinkCentre-M92p bren # sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/
> sudo apt-get update
> sudo apt-get install --install-recommends winehq-stable
> sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/
> sudo apt-get install --install-recommends winehq-stable


My computer is 64 bit, my Mint 18.1 install is new.
 
Old 06-07-2017, 09:10 AM   #2
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 3,799

Rep: Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724
And where is the output that tells you that the install is not complete?
We will need that to make a determination (or guess) as to why it might be incomplete or unsuccessful.
 
Old 06-07-2017, 09:33 AM   #3
Novatian
Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20 KDE and 19 and Android, Windows 10, KDE Neon, Manjaro, Slackware.
Posts: 990

Original Poster
Rep: Reputation: 37
It is incomplete, WINE is still not in my list of programs, there was no download or depackage...
 
Old 06-07-2017, 11:24 AM   #4
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
https://help.ubuntu.com/community/Wine
 
Old 06-07-2017, 12:11 PM   #5
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 3,799

Rep: Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724Reputation: 1724
Quote:
Originally Posted by Novatian View Post
It is incomplete, WINE is still not in my list of programs, there was no download or depackage...
So you are saying that you ran the commands, there was no output?
 
Old 06-07-2017, 12:44 PM   #6
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by Novatian View Post
Code:
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/
> sudo apt-get update
> sudo apt-get install --install-recommends winehq-stable
> sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/
> sudo apt-get install --install-recommends winehq-stable
You ran sudo apt-add-repository twice?

in a terminal, please issue
Code:
sudo dpkg -l |grep wine | grep ii
show anything about the package?

if you aren't sure, use
Code:
sudo dpkg -l |grep wine | grep ii | nc termbin.com 9999
and toss us the short link here.

Additionally,
Code:
inxi -Fsxr -c0 | nc termbin.com 9999
may help down the road.
Please post that short link here also.

Thanks.

Last edited by Habitual; 06-07-2017 at 01:26 PM. Reason: fixed typos! Thanks.
 
Old 06-09-2017, 10:20 AM   #7
Novatian
Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20 KDE and 19 and Android, Windows 10, KDE Neon, Manjaro, Slackware.
Posts: 990

Original Poster
Rep: Reputation: 37
OK, I got it going, wine stable, I had to open another terminal and su again and go from where I made an error and include the whole command with "xenial"...

It downloaded but I cannot find WINE in my menu even so.

Can anyone recommend wine tricks? and what is the terminal command or link to the wiki, unless I find it myself.

brendan-ThinkCentre-M92p brendan # sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main'
brendan-ThinkCentre-M92p brendan # sudo apt-get update
Ign:1 http://packages.linuxmint.com sarah InRelease
Hit:2 http://archive.canonical.com/ubuntu xenial InRelease
Hit:3 http://archive.ubuntu.com/ubuntu xenial InRelease
Get:4 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Hit:5 http://packages.linuxmint.com sarah Release
Get:7 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:8 https://dl.winehq.org/wine-builds/ubuntu xenial InRelease [4,686 B]
Ign:8 https://dl.winehq.org/wine-builds/ubuntu xenial InRelease
Get:9 https://dl.winehq.org/wine-builds/ubuntu xenial/main amd64 Packages [9,060 B]
Get:10 https://dl.winehq.org/wine-builds/ubuntu xenial/main i386 Packages [8,992 B]
Get:11 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Fetched 329 kB in 3s (85.6 kB/s)
Reading package lists... Done
W: GPG error: https://dl.winehq.org/wine-builds/ubuntu xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 818A435C5FCBF54A
W: The repository 'https://dl.winehq.org/wine-builds/ubuntu xenial InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
brendan-ThinkCentre-M92p brendan # sudo apt-get install --install-recommends winehq-stable
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
libasn1-8-heimdal:i386 libcapi20-3 libdb5.3:i386 libgl1-mesa-glx:i386
libgl1-mesa-glx libglapi-mesa:i386 libglapi-mesa libgles1-mesa libgles2-mesa
libgsm1:i386 libgssapi3-heimdal:i386 libhcrypto4-heimdal:i386
libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386
libkrb5-26-heimdal:i386 libldap-2.4-2:i386 libodbc1 libosmesa6
libosmesa6:i386 libpcap0.8:i386 libroken18-heimdal:i386 libsasl2-2:i386
libsasl2-modules-db:i386 libwind0-heimdal:i386 wine-stable wine-stable-amd64
wine-stable-i386:i386
Suggested packages:
isdnutils-doc libmyodbc odbc-postgresql tdsodbc unixodbc-bin
The following NEW packages will be installed:
libasn1-8-heimdal:i386 libcapi20-3 libdb5.3:i386 libgsm1:i386
libgssapi3-heimdal:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libkrb5-26-heimdal:i386
libldap-2.4-2:i386 libodbc1 libosmesa6 libosmesa6:i386 libpcap0.8:i386
libroken18-heimdal:i386 libsasl2-2:i386 libsasl2-modules-db:i386
libwind0-heimdal:i386 wine-stable wine-stable-amd64 wine-stable-i386:i386
winehq-stable
The following packages will be upgraded:
libgl1-mesa-glx:i386 libgl1-mesa-glx libglapi-mesa:i386 libglapi-mesa
libgles1-mesa libgles2-mesa
6 to upgrade, 23 to newly install, 0 to remove and 34 not to upgrade.
Need to get 52.4 MB of archives.
After this operation, 387 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
wine-stable-amd64 wine-stable-i386:i386 wine-stable winehq-stable
Install these packages without verification? [y/N] y
Get:1 https://dl.winehq.org/wine-builds/ubuntu xenial/main amd64 wine-stable-amd64 amd64 2.0.1~xenial [23.8 MB]
Get:2 http://archive.ubuntu.com/ubuntu xenial/universe i386 libgsm1 i386 1.0.13-4 [27.0 kB]
Get:3 http://archive.ubuntu.com/ubuntu xenial/main i386 libroken18-heimdal i386 1.7~git20150920+dfsg-4ubuntu1 [44.8 kB]
Get:4 http://archive.ubuntu.com/ubuntu xenial/main i386 libasn1-8-heimdal i386 1.7~git20150920+dfsg-4ubuntu1 [183 kB]
Get:5 http://archive.ubuntu.com/ubuntu xenial/main i386 libhcrypto4-heimdal i386 1.7~git20150920+dfsg-4ubuntu1 [89.6 kB]
Get:6 http://archive.ubuntu.com/ubuntu xenial/main i386 libheimbase1-heimdal i386 1.7~git20150920+dfsg-4ubuntu1 [31.9 kB]
Get:7 http://archive.ubuntu.com/ubuntu xenial/main i386 libwind0-heimdal i386 1.7~git20150920+dfsg-4ubuntu1 [49.1 kB]
Get:8 http://archive.ubuntu.com/ubuntu xenial/main i386 libhx509-5-heimdal i386 1.7~git20150920+dfsg-4ubuntu1 [118 kB]
Get:9 http://archive.ubuntu.com/ubuntu xenial/main i386 libkrb5-26-heimdal i386 1.7~git20150920+dfsg-4ubuntu1 [226 kB]
Get:10 http://archive.ubuntu.com/ubuntu xenial/main i386 libheimntlm0-heimdal i386 1.7~git20150920+dfsg-4ubuntu1 [16.7 kB]
Get:11 http://archive.ubuntu.com/ubuntu xenial/main i386 libgssapi3-heimdal i386 1.7~git20150920+dfsg-4ubuntu1 [107 kB]
Get:12 http://archive.ubuntu.com/ubuntu xenial/main i386 libdb5.3 i386 5.3.28-11 [732 kB]
Get:13 http://archive.ubuntu.com/ubuntu xenial/main i386 libsasl2-modules-db i386 2.1.26.dfsg1-14build1 [15.4 kB]
Get:14 http://archive.ubuntu.com/ubuntu xenial/main i386 libsasl2-2 i386 2.1.26.dfsg1-14build1 [51.8 kB]
Get:15 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 libldap-2.4-2 i386 2.4.42+dfsg-2ubuntu3.2 [173 kB]
Get:16 http://archive.ubuntu.com/ubuntu xenial/main i386 libpcap0.8 i386 1.7.4-2 [121 kB]
Get:17 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libcapi20-3 amd64 1:3.27-1 [28.7 kB]
Get:18 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 libgles2-mesa amd64 12.0.6-0ubuntu0.16.04.1 [13.2 kB]
Get:19 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 libgles1-mesa amd64 12.0.6-0ubuntu0.16.04.1 [8,836 B]
Get:20 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 libgl1-mesa-glx i386 12.0.6-0ubuntu0.16.04.1 [138 kB]
Get:21 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 libgl1-mesa-glx amd64 12.0.6-0ubuntu0.16.04.1 [130 kB]
Get:22 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 libglapi-mesa amd64 12.0.6-0ubuntu0.16.04.1 [22.9 kB]
Get:23 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 libglapi-mesa i386 12.0.6-0ubuntu0.16.04.1 [22.6 kB]
Get:24 http://archive.ubuntu.com/ubuntu xenial/main amd64 libodbc1 amd64 2.3.1-4.1 [180 kB]
Get:25 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 libosmesa6 i386 12.0.6-0ubuntu0.16.04.1 [1,229 kB]
Get:26 https://dl.winehq.org/wine-builds/ubuntu xenial/main i386 wine-stable-i386 i386 2.0.1~xenial [22.6 MB]
Get:27 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 libosmesa6 amd64 12.0.6-0ubuntu0.16.04.1 [1,162 kB]
Get:28 https://dl.winehq.org/wine-builds/ubuntu xenial/main amd64 wine-stable amd64 2.0.1~xenial [1,086 kB]
Get:29 https://dl.winehq.org/wine-builds/ubuntu xenial/main amd64 winehq-stable amd64 2.0.1~xenial [3,160 B]
Fetched 52.4 MB in 22s (2,333 kB/s)
Selecting previously unselected package libgsm1:i386.
(Reading database ... 269013 files and directories currently installed.)
Preparing to unpack .../libgsm1_1.0.13-4_i386.deb ...
Unpacking libgsm1:i386 (1.0.13-4) ...
Selecting previously unselected package wine-stable-amd64.
Preparing to unpack .../wine-stable-amd64_2.0.1~xenial_amd64.deb ...
Unpacking wine-stable-amd64 (2.0.1~xenial) ...
Selecting previously unselected package libroken18-heimdal:i386.
Preparing to unpack .../libroken18-heimdal_1.7~git20150920+dfsg-4ubuntu1_i386.deb ...
Unpacking libroken18-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Selecting previously unselected package libasn1-8-heimdal:i386.
Preparing to unpack .../libasn1-8-heimdal_1.7~git20150920+dfsg-4ubuntu1_i386.deb ...
Unpacking libasn1-8-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Selecting previously unselected package libhcrypto4-heimdal:i386.
Preparing to unpack .../libhcrypto4-heimdal_1.7~git20150920+dfsg-4ubuntu1_i386.deb ...
Unpacking libhcrypto4-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Selecting previously unselected package libheimbase1-heimdal:i386.
Preparing to unpack .../libheimbase1-heimdal_1.7~git20150920+dfsg-4ubuntu1_i386.deb ...
Unpacking libheimbase1-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Selecting previously unselected package libwind0-heimdal:i386.
Preparing to unpack .../libwind0-heimdal_1.7~git20150920+dfsg-4ubuntu1_i386.deb ...
Unpacking libwind0-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Selecting previously unselected package libhx509-5-heimdal:i386.
Preparing to unpack .../libhx509-5-heimdal_1.7~git20150920+dfsg-4ubuntu1_i386.deb ...
Unpacking libhx509-5-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Selecting previously unselected package libkrb5-26-heimdal:i386.
Preparing to unpack .../libkrb5-26-heimdal_1.7~git20150920+dfsg-4ubuntu1_i386.deb ...
Unpacking libkrb5-26-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Selecting previously unselected package libheimntlm0-heimdal:i386.
Preparing to unpack .../libheimntlm0-heimdal_1.7~git20150920+dfsg-4ubuntu1_i386.deb ...
Unpacking libheimntlm0-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Selecting previously unselected package libgssapi3-heimdal:i386.
Preparing to unpack .../libgssapi3-heimdal_1.7~git20150920+dfsg-4ubuntu1_i386.deb ...
Unpacking libgssapi3-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Selecting previously unselected package libdb5.3:i386.
Preparing to unpack .../libdb5.3_5.3.28-11_i386.deb ...
Unpacking libdb5.3:i386 (5.3.28-11) ...
Selecting previously unselected package libsasl2-modules-db:i386.
Preparing to unpack .../libsasl2-modules-db_2.1.26.dfsg1-14build1_i386.deb ...
Unpacking libsasl2-modules-db:i386 (2.1.26.dfsg1-14build1) ...
Selecting previously unselected package libsasl2-2:i386.
Preparing to unpack .../libsasl2-2_2.1.26.dfsg1-14build1_i386.deb ...
Unpacking libsasl2-2:i386 (2.1.26.dfsg1-14build1) ...
Selecting previously unselected package libldap-2.4-2:i386.
Preparing to unpack .../libldap-2.4-2_2.4.42+dfsg-2ubuntu3.2_i386.deb ...
Unpacking libldap-2.4-2:i386 (2.4.42+dfsg-2ubuntu3.2) ...
Selecting previously unselected package libpcap0.8:i386.
Preparing to unpack .../libpcap0.8_1.7.4-2_i386.deb ...
Unpacking libpcap0.8:i386 (1.7.4-2) ...
Selecting previously unselected package wine-stable-i386:i386.
Preparing to unpack .../wine-stable-i386_2.0.1~xenial_i386.deb ...
Unpacking wine-stable-i386:i386 (2.0.1~xenial) ...
Selecting previously unselected package wine-stable.
Preparing to unpack .../wine-stable_2.0.1~xenial_amd64.deb ...
Unpacking wine-stable (2.0.1~xenial) ...
Selecting previously unselected package libcapi20-3:amd64.
Preparing to unpack .../libcapi20-3_1%3a3.27-1_amd64.deb ...
Unpacking libcapi20-3:amd64 (1:3.27-1) ...
Preparing to unpack .../libgl1-mesa-glx_12.0.6-0ubuntu0.16.04.1_i386.deb ...
De-configuring libgl1-mesa-glx:amd64 (11.2.0-1ubuntu2) ...
Unpacking libgl1-mesa-glx:i386 (12.0.6-0ubuntu0.16.04.1) over (11.2.0-1ubuntu2) ...
Preparing to unpack .../libgl1-mesa-glx_12.0.6-0ubuntu0.16.04.1_amd64.deb ...
Unpacking libgl1-mesa-glx:amd64 (12.0.6-0ubuntu0.16.04.1) over (11.2.0-1ubuntu2) ...
Preparing to unpack .../libgles2-mesa_12.0.6-0ubuntu0.16.04.1_amd64.deb ...
Unpacking libgles2-mesa:amd64 (12.0.6-0ubuntu0.16.04.1) over (11.2.0-1ubuntu2) ...
Preparing to unpack .../libgles1-mesa_12.0.6-0ubuntu0.16.04.1_amd64.deb ...
Unpacking libgles1-mesa:amd64 (12.0.6-0ubuntu0.16.04.1) over (11.2.0-1ubuntu2) ...
Preparing to unpack .../libglapi-mesa_12.0.6-0ubuntu0.16.04.1_amd64.deb ...
De-configuring libglapi-mesa:i386 (11.2.0-1ubuntu2) ...
Unpacking libglapi-mesa:amd64 (12.0.6-0ubuntu0.16.04.1) over (11.2.0-1ubuntu2) ...
Preparing to unpack .../libglapi-mesa_12.0.6-0ubuntu0.16.04.1_i386.deb ...
Unpacking libglapi-mesa:i386 (12.0.6-0ubuntu0.16.04.1) over (11.2.0-1ubuntu2) ...
Selecting previously unselected package libodbc1:amd64.
Preparing to unpack .../libodbc1_2.3.1-4.1_amd64.deb ...
Unpacking libodbc1:amd64 (2.3.1-4.1) ...
Selecting previously unselected package winehq-stable.
Preparing to unpack .../winehq-stable_2.0.1~xenial_amd64.deb ...
Unpacking winehq-stable (2.0.1~xenial) ...
Selecting previously unselected package libosmesa6:i386.
Preparing to unpack .../libosmesa6_12.0.6-0ubuntu0.16.04.1_i386.deb ...
Unpacking libosmesa6:i386 (12.0.6-0ubuntu0.16.04.1) ...
Selecting previously unselected package libosmesa6:amd64.
Preparing to unpack .../libosmesa6_12.0.6-0ubuntu0.16.04.1_amd64.deb ...
Unpacking libosmesa6:amd64 (12.0.6-0ubuntu0.16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Setting up libgsm1:i386 (1.0.13-4) ...
Setting up wine-stable-amd64 (2.0.1~xenial) ...
Setting up libroken18-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Setting up libasn1-8-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Setting up libhcrypto4-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Setting up libheimbase1-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Setting up libwind0-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Setting up libhx509-5-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Setting up libkrb5-26-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Setting up libheimntlm0-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Setting up libgssapi3-heimdal:i386 (1.7~git20150920+dfsg-4ubuntu1) ...
Setting up libdb5.3:i386 (5.3.28-11) ...
Setting up libsasl2-modules-db:i386 (2.1.26.dfsg1-14build1) ...
Setting up libsasl2-2:i386 (2.1.26.dfsg1-14build1) ...
Setting up libldap-2.4-2:i386 (2.4.42+dfsg-2ubuntu3.2) ...
Setting up libpcap0.8:i386 (1.7.4-2) ...
Setting up wine-stable-i386:i386 (2.0.1~xenial) ...
Setting up wine-stable (2.0.1~xenial) ...
Setting up libcapi20-3:amd64 (1:3.27-1) ...
Setting up libglapi-mesa:amd64 (12.0.6-0ubuntu0.16.04.1) ...
Setting up libglapi-mesa:i386 (12.0.6-0ubuntu0.16.04.1) ...
Setting up libgl1-mesa-glx:amd64 (12.0.6-0ubuntu0.16.04.1) ...
Setting up libgl1-mesa-glx:i386 (12.0.6-0ubuntu0.16.04.1) ...
Setting up libgles2-mesa:amd64 (12.0.6-0ubuntu0.16.04.1) ...
Setting up libgles1-mesa:amd64 (12.0.6-0ubuntu0.16.04.1) ...
Setting up libodbc1:amd64 (2.3.1-4.1) ...
Setting up winehq-stable (2.0.1~xenial) ...
Setting up libosmesa6:i386 (12.0.6-0ubuntu0.16.04.1) ...
Setting up libosmesa6:amd64 (12.0.6-0ubuntu0.16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu7) ...



I want to configure WINE.
When I did a search in menu, I found WINE svg and png files, notepad... and winefish. But even after a restart, I can't find WINE in my menu.

Last edited by Novatian; 06-09-2017 at 10:59 AM.
 
Old 06-09-2017, 11:01 AM   #8
Novatian
Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20 KDE and 19 and Android, Windows 10, KDE Neon, Manjaro, Slackware.
Posts: 990

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by Habitual View Post
You ran sudo apt-add-repository twice?

in a terminal, please issue
Code:
sudo dpkg -l |grep wine | grep ii
show anything about the package?

if you aren't sure, use
Code:
sudo dpkg -l |grep wine | grep ii | nc termbin.com 9999
and toss us the short link here.

Additionally,
Code:
inxi -Fsxr -c0 | nc termbin.com 9999
may help down the road.
Please post that short link here also.

Thanks.
brendan-ThinkCentre-M92p brendan # sudo dpkg -l |grep wine | grep ii
ii wine-stable 2.0.1~xenial amd64 WINE Is Not An Emulator - runs MS Windows programs
ii wine-stable-amd64 2.0.1~xenial amd64 WINE Is Not An Emulator - runs MS Windows programs
ii wine-stable-i386:i386 2.0.1~xenial i386 WINE Is Not An Emulator - runs MS Windows programs
ii winehq-stable 2.0.1~xenial amd64 WINE Is Not An Emulator - runs MS Windows programs
brendan-ThinkCentre-M92p brendan #
brendan-ThinkCentre-M92p brendan # sudo dpkg -l |grep wine | grep ii | nc termbin.com 9999
http://termbin.com/a0gy
brendan-ThinkCentre-M92p brendan # inxi -Fsxr -c0 | nc termbin.com 9999
http://termbin.com/6j0x
brendan-ThinkCentre-M92p brendan #

Last edited by Novatian; 06-09-2017 at 11:03 AM.
 
Old 06-09-2017, 11:47 AM   #9
Novatian
Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20 KDE and 19 and Android, Windows 10, KDE Neon, Manjaro, Slackware.
Posts: 990

Original Poster
Rep: Reputation: 37
Could one of these commands be worth trying?
LANG=C;sudo apt-get --fix-missing install

LANG=C;sudo apt-get --purge autoremove
 
Old 06-09-2017, 11:48 PM   #10
Novatian
Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20 KDE and 19 and Android, Windows 10, KDE Neon, Manjaro, Slackware.
Posts: 990

Original Poster
Rep: Reputation: 37
Updater now has a fault:

The repository may no longer be available or could not be contacted because of network problems. If available an older version of the failed index will be used. Otherwise the repository will be ignored. Check your network connection and ensure the repository address in the preferences is correct.


GPG error: https://dl.winehq.org/wine-builds/ubuntu xenial InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 818A435C5FCBF54AThe repository 'https://dl.winehq.org/wine-builds/ubuntu xenial InRelease' is not signed.Data from such a repository can't be authenticated and is therefore potentially dangerous to use.See apt-secure(8) manpage for repository creation and user configuration details.Failed to fetch http://archive.ubuntu.com/ubuntu/dis...9cc0bd062acdcb Hash Sum mismatchFailed to fetch http://archive.ubuntu.com/ubuntu/dis...4d99c3d625df6b Some index files failed to download. They have been ignored, or old ones used instead.
 
Old 06-12-2017, 07:18 AM   #11
Novatian
Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20 KDE and 19 and Android, Windows 10, KDE Neon, Manjaro, Slackware.
Posts: 990

Original Poster
Rep: Reputation: 37
Updater still however works.

I went through the instructions from WINEHQ after refreshing a terminal and using my password. It then installed but did not appear in my menu. But it still works through a terminal and runs 2 windows programs so far.

In terminal I need to use:
wine program.exe
wine setup.msi
wine --version
winecfg

There then was a need to install mono and gecko.

WINE is an option on right click of the download to open an .exe file. And it runs.
 
Old 06-12-2017, 09:04 AM   #12
remma12
Member
 
Registered: May 2017
Distribution: Arch
Posts: 65

Rep: Reputation: 28
Wine is CLI so you will not see it appear in your menu
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Stable: How to install NET FRAMEWORK with WINE (ntlm_auth error :( ) frenchn00b Debian 3 02-01-2018 05:18 AM
How do you install latest WINE from source? VoltManEXE Linux - Software 11 09-04-2012 03:09 PM
LXer: Install Or Upgrade To Latest Stable Version Of Rsyslog On CentOS 5 And 6 LXer Syndicated Linux News 0 06-13-2012 12:30 PM
LXer: Wine 1.4 Stable Version Has Been Released and Ready to Install in Ubuntu LXer Syndicated Linux News 0 03-10-2012 04:42 PM
LXer: Howto Install latest wine with patched source and manage wine prefixes LXer Syndicated Linux News 0 12-07-2009 05:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration