LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-18-2019, 12:56 PM   #16
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, KDE Neon, Arch, Void
Posts: 3,152

Rep: Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974

yes, if you were to purge everything KDE from your existing system and then follow that procedure, you'll have a KDE Neon system when you finish (and it will even show as KDE Neon in infocenter and such).

Not 100% certain on the ppa, it MIGHT be:

ppa:kubuntu-ppa/backports
 
1 members found this post helpful.
Old 09-18-2019, 12:57 PM   #17
davide445
Member
 
Registered: Dec 2018
Distribution: KDE Neon
Posts: 73

Original Poster
Rep: Reputation: 1
Final question I think: how to purge?
Thanks!
 
Old 09-18-2019, 12:59 PM   #18
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, KDE Neon, Arch, Void
Posts: 3,152

Rep: Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974
apt purge <package>
To purge dependencies apt autoremove --purge
 
1 members found this post helpful.
Old 09-18-2019, 01:05 PM   #19
davide445
Member
 
Registered: Dec 2018
Distribution: KDE Neon
Posts: 73

Original Poster
Rep: Reputation: 1
"apt purge kde" will be enough?
I have many installed apps, extensions and conda environments, reinstalling will be a safer path? Any procedure to do so?
 
Old 09-18-2019, 01:20 PM   #20
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, KDE Neon, Arch, Void
Posts: 3,152

Rep: Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974
No, it's not called just kde. You'd have to start with kubuntu-desktop plasma-workspace plasma-desktop sddm, and then after them, you'd probably have to do apt list --installed | grep plasma and then kde to make sure you got all the big stuff.

No user settings will be removed from this, so literally to reinstall after upgrading, just apt install <package>. Such as if you use clementine and you purge it before the upgrade, after the upgrade apt install clementine and all your personal preferences would be retained, as your /home directory is completely untouched by a remove/purge. Purge just gets rid of system config files so that if there's a newer system config file, the system won't ask you during upgrade "this already exists, do you want to install the apckage maintainers version or keep existing"
 
Old 09-18-2019, 01:59 PM   #21
davide445
Member
 
Registered: Dec 2018
Distribution: KDE Neon
Posts: 73

Original Poster
Rep: Reputation: 1
Reading this article propose
Quote:
sudo apt-get purge kubuntu-desktop
sudo apt-get autoremove
Since Im not sure want to play safe and ask before doing damage on my unique working installation.
Btw wirting from a Neon live USB to just test it before, nice!
 
Old 09-18-2019, 02:47 PM   #22
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, KDE Neon, Arch, Void
Posts: 3,152

Rep: Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974
Yeah, I REALLY like Neon. It's climbed up to my #2 distro for me (right behind plain Debian, right ahead of Arch).

My work laptop actually did start out as Ubuntu (that's what the developers use at my work), but eventually I just couldn't deal with Gnome anymore, so converted to Neon.

Last edited by Timothy Miller; 09-18-2019 at 02:49 PM.
 
Old 09-19-2019, 03:22 AM   #23
davide445
Member
 
Registered: Dec 2018
Distribution: KDE Neon
Posts: 73

Original Poster
Rep: Reputation: 1
About Neon, all the other Ubuntu parts will be updated at the same rate as in Kubuntu?
Didn't understand if I will switch from a Ubuntu maintained distro to a KDE maintained one (with longer interval between updates?)
 
Old 09-19-2019, 08:25 AM   #24
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, KDE Neon, Arch, Void
Posts: 3,152

Rep: Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974
Everything outside KDE is standard Ubuntu still and still gets updates through canonical.
 
Old 09-19-2019, 05:52 PM   #25
davide445
Member
 
Registered: Dec 2018
Distribution: KDE Neon
Posts: 73

Original Poster
Rep: Reputation: 1
Ok as a stupid I tried to use the first post method without purging, and failed.
Now got these errors that I'm unable to resolve also trying to manually install any package.
Kubuntu to Neon error
Info Center state I'm on Kubuntu 18.04 with Plasma 5.16.5.
Discover state I need to update 181 packages but an error come out when I try to do it.
Any suggestion is Very welcomed

Last edited by davide445; 09-19-2019 at 06:05 PM.
 
Old 09-19-2019, 07:36 PM   #26
Timothy Miller
Moderator
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian, KDE Neon, Arch, Void
Posts: 3,152

Rep: Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974Reputation: 974
The easiest way is probably just to go backward to go forward

Code:
apt purge libkf5 kubuntu-desktop
This will remove...basically EVERYTHING kde from your system, new and old. Have 2-3 konsole windows open to admin when you do this (just in case), as the running konsole won't go away when konsole gets purged. When it's done, DO NOT REBOOT YET.

Code:
apt install neon-desktop
Then you can reboot.
 
1 members found this post helpful.
Old 09-20-2019, 06:57 AM   #27
davide445
Member
 
Registered: Dec 2018
Distribution: KDE Neon
Posts: 73

Original Poster
Rep: Reputation: 1
I was warned so I can't say it's not my should.

this is the result

Quote:
sudo apt purge libkf5 kubuntu-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libkf5
Quote:
sudo apt install neon-desktop
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
akregator : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
kaddressbook : Depends: libkf5akonadisearch-plugins but it is not going to be installed
Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
Depends: libkf5pimcommonakonadi5 but it is not going to be installed
libkf5akonadisearch-bin : Depends: libkf5akonadisearchpim5 (>= 4:16.04.3+p16.10+git20160726.1415) but it is not going to be installed
libkf5calendarsupport5abi1 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5eventviews5 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
libkf5gravatar5 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5incidenceeditor5abi2 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
libkf5kaddressbookgrantlee5 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5kaddressbookimportexport5 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5libkleo5 : Depends: libkf5pimtextedit5 but it is not going to be installed
libkf5mailcommon5abi4 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
Depends: libkf5pimcommonakonadi5 but it is not going to be installed
libkf5mailimporter5abi1 : Depends: libkf5libkdepim-plugins but it is not going to be installed
libkf5messagecomposer5abi2 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5messagecore5abi2 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5messagelist5abi1 : Depends: libkf5akonadisearchpim5 (>= 4:16.04.3+p16.10+git20160726.1415) but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
Depends: libkf5pimcommonakonadi5 but it is not going to be installed
libkf5messageviewer5abi4 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5pimcommon-plugins : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5webengineviewer5abi3 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
neon-desktop : Depends: distro-release-notifier but it is not going to be installed
Depends: docker-neon but it is not going to be installed
Depends: fonts-noto-color-emoji but it is not going to be installed
Depends: lvm2
Depends: neon-hardware-integration but it is not going to be installed
Depends: neon-keyring but it is not going to be installed
Depends: neon-settings but it is not going to be installed
Depends: pm-utils but it is not going to be installed
Depends: xserver-xorg-video-intel-arbiter but it is not going to be installed
Recommends: appimagelauncher but it is not going to be installed
Recommends: drkonqi-pk-debug-installer but it is not going to be installed
Recommends: grub-theme-breeze but it is not going to be installed
Recommends: kde-config-plymouth but it is not going to be installed
Recommends: kwrite but it is not going to be installed
Recommends: neon-adwaita but it is not going to be installed
Recommends: neon-apport but it is not going to be installed
Recommends: neon-ubuntu-advantage-tools but it is not going to be installed
Recommends: phonon4qt5-backend-vlc but it is not going to be installed
Recommends: plasma-browser-integration but it is not going to be installed
Recommends: plasma-calendar-addons but it is not going to be installed
Recommends: plasma-workspace-wayland but it is not going to be installed
Recommends: plymouth-theme-breeze but it is not going to be installed
Recommends: vim
Recommends: xserver-xorg-video-intel-native-modesetting but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Quote:
sudo apt install libkf5
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libkf5
 
Old 09-20-2019, 07:14 AM   #28
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,320

Rep: Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635
I think the purge should have been
Code:
apt purge libkf5* kubuntu-desktop
but try this first
Code:
sudo apt install -f
( shorter version of the fix suggested by apt )


if it wants to uninstall let it

then do the purge again with the *

then try again
if that fails, install aptitude
Code:
sudo apt install aptitude
sudo aptitude --with-recommends install neon-desktop
aptitude tries harder, it is apt with attitude

Last edited by Firerat; 09-20-2019 at 07:16 AM. Reason: edit threw in --with-recommends as without can cause problems
 
Old 09-20-2019, 07:50 AM   #29
davide445
Member
 
Registered: Dec 2018
Distribution: KDE Neon
Posts: 73

Original Poster
Rep: Reputation: 1
Seems there are crossed dependencies is unable to resolve

Any relationship with defined sources?

Quote:
sudo apt install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
kde-l10n-it libkf5libkleo-data libkf5libkleo5 libllvm7 libnvidia-cfg1-410 libnvidia-common-410
libnvidia-decode-410 libnvidia-encode-410 libnvidia-fbc1-410 libnvidia-gl-410 libnvidia-ifr1-410
libpam-kwallet4 libxnvctrl0 nvidia-compute-utils-410 nvidia-dkms-410 nvidia-kernel-common-410
nvidia-kernel-source-410 nvidia-prime nvidia-settings nvidia-utils-410 pkg-config screen-resolution-extra
x11proto-dri2-dev x11proto-gl-dev
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
akonadi-backend-mysql akonadi-contacts-data akonadi-server kde-config-mailtransport kf5-kdepim-apps-libs-data
libkf5akonadi-data libkf5akonadiagentbase5 libkf5akonadicore5 libkf5akonadiprivate5 libkf5akonadisearchdebug5
libkf5akonadiwidgets5 libkf5contacteditor5 libkf5followupreminder5 libkf5gravatar5
libkf5kaddressbookimportexport5 libkf5libkdepim5 libkf5mailtransport-data libkf5mailtransport5
libkf5pimcommon-plugins libkf5pimcommon5 libkf5pimtextedit-plugins libkf5pimtextedit5 libkf5sendlater5
libkf5syndication5 libkf5syndication5abi1
Suggested packages:
akonadi-backend-postgresql akonadi-backend-sqlite
Recommended packages:
libkf5libkdepim-plugins
The following packages will be REMOVED:
akregator kaddressbook libkf5akonadicalendar5abi2 libkf5akonadicontact5abi1 libkf5akonadicore-bin
libkf5akonadicore5abi1 libkf5akonadimime5 libkf5akonadisearch-bin libkf5alarmcalendar5abi1
libkf5calendarsupport5abi1 libkf5contacteditor-data libkf5eventviews5 libkf5incidenceeditor-bin
libkf5incidenceeditor5abi2 libkf5kaddressbookgrantlee5 libkf5kdepimdbusinterfaces5 libkf5mailcommon5abi4
libkf5mailimporter5abi1 libkf5mailimporterakonadi5 libkf5mailtransport5abi2 libkf5mailtransportakonadi5
libkf5messagecomposer5abi2 libkf5messagecore5abi2 libkf5messagelist5abi1 libkf5messageviewer-plugins
libkf5messageviewer5abi4 libkf5mimetreeparser5abi2 libkf5templateparser5abi2 libkf5webengineviewer5abi3
The following NEW packages will be installed:
akonadi-contacts-data libkf5akonadi-data libkf5akonadicore5 libkf5libkdepim5 libkf5mailtransport5
libkf5pimcommon5 libkf5pimtextedit-plugins libkf5pimtextedit5 libkf5syndication5abi1
The following packages will be upgraded:
akonadi-backend-mysql akonadi-server kde-config-mailtransport kf5-kdepim-apps-libs-data
libkf5akonadiagentbase5 libkf5akonadiprivate5 libkf5akonadisearchdebug5 libkf5akonadiwidgets5
libkf5contacteditor5 libkf5followupreminder5 libkf5gravatar5 libkf5kaddressbookimportexport5
libkf5mailtransport-data libkf5pimcommon-plugins libkf5sendlater5 libkf5syndication5
16 upgraded, 9 newly installed, 29 to remove and 160 not upgraded.
359 not fully installed or removed.
Need to get 0 B/3.848 kB of archives.
After this operation, 18,6 MB disk space will be freed.
Do you want to continue? [S/n] s
(Reading database ... 343768 files and directories currently installed.)
Preparing to unpack .../libkf5pimtextedit5_19.08.1-0xneon+18.04+bionic+build24_amd64.deb ...
Unpacking libkf5pimtextedit5:amd64 (19.08.1-0xneon+18.04+bionic+build24) ...
dpkg: error processing archive /var/cache/apt/archives/libkf5pimtextedit5_19.08.1-0xneon+18.04+bionic+build24_amd64.deb (--unpack):
trying to overwrite '/usr/share/locale/ar/LC_MESSAGES/libkpimtextedit.mo', which is also in package libkf5pimtextedit-data 17.12.3-0ubuntu1
Errors were encountered while processing:
/var/cache/apt/archives/libkf5pimtextedit5_19.08.1-0xneon+18.04+bionic+build24_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Quote:
sudo apt purge libkf5* kubuntu-desktop

..........an infinite series of broken dependencies such as ..........


user-manager : Depends: libkf5auth5 (>= 4.96.0) but it is not going to be installed
Depends: libkf5configcore5 (>= 4.97.0) but it is not going to be installed
Depends: libkf5configwidgets5 (>= 4.96.0) but it is not going to be installed
Depends: libkf5coreaddons5 (>= 4.99.0) but it is not going to be installed
Depends: libkf5i18n5 (>= 4.97.0) but it is not going to be installed
Depends: libkf5iconthemes5 (>= 4.96.0) but it is not going to be installed
Depends: libkf5kiocore5 (>= 4.96.0) but it is not going to be installed
Depends: libkf5widgetsaddons5 (>= 4.96.0) but it is not going to be installed
xdg-desktop-portal-kde : Depends: libkf5configcore5 but it is not going to be installed
Depends: libkf5coreaddons5 but it is not going to be installed
Depends: libkf5i18n5 but it is not going to be installed
Depends: libkf5kiofilewidgets5 but it is not going to be installed
Depends: libkf5notifications5 but it is not going to be installed
Depends: libkf5widgetsaddons5 but it is not going to be installed
Depends: libkf5windowsystem5 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Quote:
sudo apt install aptitude
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
akregator : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
aptitude : Depends: aptitude-common (= 0.8.10-6ubuntu1) but it is not going to be installed
Depends: libcwidget3v5 but it is not going to be installed
Depends: libsigc++-2.0-0v5 (>= 2.8.0) but it is not going to be installed
kaddressbook : Depends: libkf5akonadisearch-plugins but it is not going to be installed
Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
Depends: libkf5pimcommonakonadi5 but it is not going to be installed
libkf5akonadisearch-bin : Depends: libkf5akonadisearchpim5 (>= 4:16.04.3+p16.10+git20160726.1415) but it is not going to be installed
libkf5calendarsupport5abi1 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5eventviews5 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
libkf5gravatar5 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5incidenceeditor5abi2 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
libkf5kaddressbookgrantlee5 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5kaddressbookimportexport5 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5libkleo5 : Depends: libkf5pimtextedit5 but it is not going to be installed
libkf5mailcommon5abi4 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
Depends: libkf5pimcommonakonadi5 but it is not going to be installed
libkf5mailimporter5abi1 : Depends: libkf5libkdepim-plugins but it is not going to be installed
libkf5messagecomposer5abi2 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5messagecore5abi2 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5messagelist5abi1 : Depends: libkf5akonadisearchpim5 (>= 4:16.04.3+p16.10+git20160726.1415) but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
Depends: libkf5pimcommonakonadi5 but it is not going to be installed
libkf5messageviewer5abi4 : Depends: libkf5libkdepim-plugins but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5pimcommon-plugins : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5webengineviewer5abi3 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Quote:
sudo apt install libkf5libkdepim-plugins
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
akregator : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
kaddressbook : Depends: libkf5akonadisearch-plugins but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
Depends: libkf5pimcommonakonadi5 but it is not going to be installed
libkf5akonadisearch-bin : Depends: libkf5akonadisearchpim5 (>= 4:16.04.3+p16.10+git20160726.1415) but it is not going to be installed
libkf5calendarsupport5abi1 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5eventviews5 : Depends: libkf5libkdepimakonadi5 but it is not going to be installed
libkf5gravatar5 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5incidenceeditor5abi2 : Depends: libkf5libkdepimakonadi5 but it is not going to be installed
libkf5kaddressbookgrantlee5 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5kaddressbookimportexport5 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5libkdepim-plugins : Depends: libkf5libkdepim5 but it is not going to be installed
Depends: libkf5libkdepimakonadi5 but it is not going to be installed
libkf5libkleo5 : Depends: libkf5pimtextedit5 but it is not going to be installed
libkf5mailcommon5abi4 : Depends: libkf5libkdepimakonadi5 but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
Depends: libkf5pimcommonakonadi5 but it is not going to be installed
libkf5messagecomposer5abi2 : Depends: libkf5libkdepimakonadi5 but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5messagecore5abi2 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5messagelist5abi1 : Depends: libkf5akonadisearchpim5 (>= 4:16.04.3+p16.10+git20160726.1415) but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
Depends: libkf5pimcommonakonadi5 but it is not going to be installed
libkf5messageviewer5abi4 : Depends: libkf5libkdepimakonadi5 but it is not going to be installed
Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5pimcommon-plugins : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
libkf5webengineviewer5abi3 : Depends: libkf5pimcommon5abi3 (>= 4:17.11.60+git20170824) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Quote:
sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
kde-l10n-it libkf5libkleo-data libkf5libkleo5 libllvm7 libnvidia-cfg1-410 libnvidia-common-410
libnvidia-decode-410 libnvidia-encode-410 libnvidia-fbc1-410 libnvidia-gl-410 libnvidia-ifr1-410
libpam-kwallet4 libxnvctrl0 nvidia-compute-utils-410 nvidia-dkms-410 nvidia-kernel-common-410
nvidia-kernel-source-410 nvidia-prime nvidia-settings nvidia-utils-410 pkg-config screen-resolution-extra
x11proto-dri2-dev x11proto-gl-dev
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
akonadi-backend-mysql akonadi-contacts-data akonadi-server kde-config-mailtransport kf5-kdepim-apps-libs-data
libkf5akonadi-data libkf5akonadiagentbase5 libkf5akonadicore5 libkf5akonadiprivate5 libkf5akonadisearchdebug5
libkf5akonadiwidgets5 libkf5contacteditor5 libkf5followupreminder5 libkf5gravatar5
libkf5kaddressbookimportexport5 libkf5libkdepim5 libkf5mailtransport-data libkf5mailtransport5
libkf5pimcommon-plugins libkf5pimcommon5 libkf5pimtextedit-plugins libkf5pimtextedit5 libkf5sendlater5
libkf5syndication5 libkf5syndication5abi1
Suggested packages:
akonadi-backend-postgresql akonadi-backend-sqlite
Recommended packages:
libkf5libkdepim-plugins
The following packages will be REMOVED:
akregator kaddressbook libkf5akonadicalendar5abi2 libkf5akonadicontact5abi1 libkf5akonadicore-bin
libkf5akonadicore5abi1 libkf5akonadimime5 libkf5akonadisearch-bin libkf5alarmcalendar5abi1
libkf5calendarsupport5abi1 libkf5contacteditor-data libkf5eventviews5 libkf5incidenceeditor-bin
libkf5incidenceeditor5abi2 libkf5kaddressbookgrantlee5 libkf5kdepimdbusinterfaces5 libkf5mailcommon5abi4
libkf5mailimporter5abi1 libkf5mailimporterakonadi5 libkf5mailtransport5abi2 libkf5mailtransportakonadi5
libkf5messagecomposer5abi2 libkf5messagecore5abi2 libkf5messagelist5abi1 libkf5messageviewer-plugins
libkf5messageviewer5abi4 libkf5mimetreeparser5abi2 libkf5templateparser5abi2 libkf5webengineviewer5abi3
The following NEW packages will be installed:
akonadi-contacts-data libkf5akonadi-data libkf5akonadicore5 libkf5libkdepim5 libkf5mailtransport5
libkf5pimcommon5 libkf5pimtextedit-plugins libkf5pimtextedit5 libkf5syndication5abi1
The following packages will be upgraded:
akonadi-backend-mysql akonadi-server kde-config-mailtransport kf5-kdepim-apps-libs-data
libkf5akonadiagentbase5 libkf5akonadiprivate5 libkf5akonadisearchdebug5 libkf5akonadiwidgets5
libkf5contacteditor5 libkf5followupreminder5 libkf5gravatar5 libkf5kaddressbookimportexport5
libkf5mailtransport-data libkf5pimcommon-plugins libkf5sendlater5 libkf5syndication5
16 upgraded, 9 newly installed, 29 to remove and 160 not upgraded.
359 not fully installed or removed.
Need to get 0 B/3.848 kB of archives.
After this operation, 18,6 MB disk space will be freed.
Do you want to continue? [S/n] s
(Reading database ... 343768 files and directories currently installed.)
Preparing to unpack .../libkf5pimtextedit5_19.08.1-0xneon+18.04+bionic+build24_amd64.deb ...
Unpacking libkf5pimtextedit5:amd64 (19.08.1-0xneon+18.04+bionic+build24) ...
dpkg: error processing archive /var/cache/apt/archives/libkf5pimtextedit5_19.08.1-0xneon+18.04+bionic+build24_amd64.deb (--unpack):
trying to overwrite '/usr/share/locale/ar/LC_MESSAGES/libkpimtextedit.mo', which is also in package libkf5pimtextedit-data 17.12.3-0ubuntu1
Errors were encountered while processing:
/var/cache/apt/archives/libkf5pimtextedit5_19.08.1-0xneon+18.04+bionic+build24_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Quote:
sudo apt update
Get:1 file:/var/cuda-repo-9-0-local InRelease
Ign:1 file:/var/cuda-repo-9-0-local InRelease
Get:2 file:/var/cuda-repo-9-0-local Release [574 B]
Ign:3 http://archive.canonical.com/ubuntu bionic InRelease
Err:4 http://archive.canonical.com/ubuntu bionic Release
Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1562::1c). - connect (101: Network is unreachable) Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::16). - connect (101: Network is unreachable) Cannot initiate the connection to archive.canonical.com:80 (2001:67c:1360:8c01::1b). - connect (101: Network is unreachable)
Get:2 file:/var/cuda-repo-9-0-local Release [574 B]
Hit:6 http://it.archive.ubuntu.com/ubuntu bionic InRelease
Ign:7 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:8 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu bionic InRelease
Hit:9 http://it.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:10 https://download.docker.com/linux/ubuntu bionic InRelease
Hit:11 http://dl.google.com/linux/chrome/deb stable Release
Hit:12 http://it.archive.ubuntu.com/ubuntu bionic-backports InRelease
Get:13 http://archive.neon.kde.org/user bionic InRelease [153 kB]
Hit:14 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu bionic InRelease
Ign:15 http://developer.download.nvidia.com...ntu1804/x86_64 InRelease
Hit:16 http://developer.download.nvidia.com...ntu1804/x86_64 Release
Get:17 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
appstreamcli: symbol lookup error: appstreamcli: undefined symbol: AS_APPSTREAM_METADATA_PATHS
Reading package lists... Done
E: The repository 'http://archive.canonical.com/ubuntu bionic Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi'
E: Sub-process returned an error code

Last edited by davide445; 09-20-2019 at 07:54 AM.
 
Old 09-20-2019, 08:09 AM   #30
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian sid
Posts: 2,320

Rep: Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635
ok

we have to fix the broken packages before trying to install neon.

Code:
sudo apt install -f
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Solus Readies KDE Plasma Edition Testing ISO with Latest KDE Plasma 5.14 Desktop LXer Syndicated Linux News 0 10-25-2018 03:03 PM
LXer: KDE Plasma 5.13 Desktop Reaches End of Life, KDE Plasma 5.14 Arrives October 9 LXer Syndicated Linux News 0 09-15-2018 10:30 PM
LXer: KDE Plasma 5.6.4 Desktop Environment Launches with Plasma Discover Improvements LXer Syndicated Linux News 0 05-10-2016 07:15 PM
LXer: Sebastian Kügler: KDE's Plasma Mobile is running on Plasma 5 and Kubuntu LXer Syndicated Linux News 0 07-26-2015 01:48 AM
[SOLVED] Please tell me how to tell KDE to run plasma-desktop instead of plasma-netbook Kenny_Strawn Linux - Software 7 07-19-2010 07:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration