LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Install help, please (https://www.linuxquestions.org/questions/linux-software-2/install-help-please-159073/)

vi0lat0r 03-17-2004 04:01 PM

Install help, please
 
First off I would like to go ahead and thank anyone and everyone who posts in this thread to help me with my 2 problems. If you want to go ahead and skip straight to the 2 problems, feel free to.

<ChoseMandrake>
Last night (using Windows) I installed SoftICE and it said it needed to write to autoexec.bat, and so I chose to let it. My computer rebooted, but Windows didn't. All I got was the that terrible BSoD (Blue Screen of Death). So I went into Windows under safe mode, removed the line in autoexec.bat, but Windows still wouldn't load. I am a pretty saavy Windows OS user, so I fumble around inside safe mode, do system restores to 2 weeks back... nothing works.

Finally I give up, go to the other computer, and download Mandrake 10 CD1 and CD2. Well, I put CD1 into my computer, chose install, but it hung at the black screen for ~30 minutes. Thinking it must have been a glitch, I repeated the process 4-5 times. It never worked. So I dug out my Mandrake 9.2 CD(s) and wiped my 3rd hard drive, my 80GB maxtor. Installed Mandrake 9.2 on there, and here I am...
</ChoseMandrake>

Now my 2 problems:

------------------------------------
1) I want to install Mozilla FireFox, simply because its newer than the mozilla being used in 9.2 and I like it better. So I get the rpm for it, and then I double click it, and it says;

Quote:

To satisfy dependencies, the following packages are going to be installed (68 MB):
XFree86-xfs-4.3-29mdk.i586
libxfree86-4.3-29.mdk.i586
libxfree86-devel-4.3-29mdk.i586
mozilla-firefox-0.8-14mdk.i586

Is this OK?
I click ok, and then... "Initializing..."

Then another box comes up and says;

"The following packages have bad signatures:"

It goes on to list all 4 of the above packages, saying each of them:

"Invalid signature (SHA1) DSA sha1 md5 (GPG) (MISSING KEY) GPG#26752624 NOT OK)

I choose to continue, and it says "Installation failed"
BLAH BLAH conflicts with file from package XFree86-xfs-4.3-29mdk.i586

It says the "conflicts with ..." about 12 times. I don't know what to do.

-------------------------------

2)

Quote:

To satisfy dependencies, the following packages are going to be installed (6 MB):
gaim-0.75-0mdk9.2.i596

Is this OK?
Initializing.. Preparing...

Installation failed:
file /usr/lib/libgaim-remote.so.0.0.0 from install of gaim-0.75-0mdk9.2.i596 conflicts with file from package libgaim-remote0-0.67-2.mdk

---------------------------------

Thank you for any help you can provide me with,
-Thomas

tk31337 03-17-2004 04:41 PM

1. You need to upgrade XFree86 just to use Mozilla Firefox?? Sounds like BS to me. Try just grabbing the binary tarball and simply extracting to /usr/local or something. I'm on Mandrake, and that worked for me.
2. Use the "--force" option to overwrite the file, or simply remove the libgaim-remote and gaim packages that are currently installed and then install.

Have you tried using Red Carpet 2? It's a great app for automagically resolving dependency issues.

vi0lat0r 03-17-2004 04:50 PM

Thanks for your post :-)

Resolved both of them with thanks to you! I really appreciate the help :-)

-Thomas


All times are GMT -5. The time now is 07:36 AM.