LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-11-2013, 10:47 AM   #1
DusanR
LQ Newbie
 
Registered: Jun 2013
Posts: 2

Rep: Reputation: Disabled
Install Ghostscript v 9.05 (or newer) on CentOS


I need to use the ghostscript inkcov device on my CentOS server. The device is said to be available on GS versions 9.05 and newer. However, yum install ghostscript installs version 8.70.

What is the easiest way to get the inkcov device to work?
 
Old 06-11-2013, 01:28 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Try this:
Code:
yum --showduplicates list ghostscript
to see if the version you want to install is available from your yum repository.

If it is, then do yum install using the package name for the version you want.
 
Old 06-11-2013, 01:33 PM   #3
DusanR
LQ Newbie
 
Registered: Jun 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Unfortunately it seems like only version 8.70 is available via yum.

Code:
[root@182 ~]# yum --showduplicates list ghostscript
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
epel/metalink                                            |  19 kB     00:00
 * base: ftp.cvut.cz
 * epel: mirror.karneval.cz
 * extras: ftp.cvut.cz
 * updates: ftp.cvut.cz
base                                                     | 3.7 kB     00:00
extras                                                   | 3.5 kB     00:00
updates                                                  | 3.4 kB     00:00
Installed Packages
ghostscript.i686                    8.70-15.el6_4.1                     @updates
Available Packages
ghostscript.i686                    8.70-14.el6_3.1                     base
ghostscript.i686                    8.70-15.el6_4.1                     updates
 
Old 06-11-2013, 07:29 PM   #4
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
I can think of three more options.

1) http://www.ghostscript.com/download/gsdnld.html. Download the 32bit or 64bit compiled static build of ghostscript and unpack it where you want it, and run it from there. Be advised that yum will not recognize it or keep it updated.

2) The link above also has the source code for ghostscript 9.07 which you can download and try to compile. It you are successful, be advised that yum will not recognize it or keep it updated.

3) Wait until someone produces an rpm for the version you want. I haven't been able to find one for CentOS. I have found it for OpenSuse and Fedora. I'm certain the OpenSuse will not work for you. I don't know if the Fedora rpm will work in CentOS.

Last edited by bigrigdriver; 06-11-2013 at 07:30 PM.
 
Old 06-11-2013, 11:43 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,502

Rep: Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617
add to the above
4)
build the source for ghostscript 9.07 .Then use "rpmbuild" to make an rpm to install
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i update flex to 2.5.33 or newer in centos mehdi_abasifar Linux - General 2 05-03-2011 06:51 AM
emerge fails while trying to install ghostscript ub3rj3phf Linux - Software 2 03-19-2007 04:10 PM
Custom install with newer kernel bones996 Red Hat 3 11-12-2003 05:06 AM
How to install ghostscript? riklee Linux - Software 1 09-15-2003 07:21 AM
Requesting Ghostscript Install Help AlfredSka Slackware 1 03-23-2003 02:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration