-   Linux - Software (
-   -   "Input/output error" on files at end of CD (

mfeat 11-11-2005 02:06 AM

"Input/output error" on files at end of CD
I've got a CD drive that had been working properly but now gives "Input/output error" when attempting to read files at the end of the CD. The problem isn't with the disk as I get the same problem with any CD with more than about 625M of data on it. The problem does not appear to be with the drive either because I can read back the entire ISO from the CD (using xcdroast), mount it and then the files are readable. The question I have is how can the drive read the whole ISO without errors but can't read files at the end of the CD when mounted as a filesystem?

The fstab entry for the CD is:

/dev/scd0              /media/cdrecorder1      auto  pamconsole,fscontext=system_u:object_r:removable_t,ro,exec,noauto,managed 0 0
I've also tried mounting manually using:
mount -t iso9660 -r /dev/scd0 /media/cdrecorder1

The drive is not actually connected via SCSI (it's IDE), I had set up the kernel parameter hdc=ide-scsi to get xcdroast to work.

budlightnmyhand 11-11-2005 09:34 AM

post 2

mfeat 11-23-2005 03:01 PM

solved this one by restarting the "hald" process. it also fixed the problem i was having ejecting the cd as a non-root user which was giving this error:

eject: unable to eject, last error: Invalid argument

All times are GMT -5. The time now is 04:40 AM.