-   Linux - Software (
-   -   Input chinese characters (

wizzkid8 01-25-2006 11:51 PM

Input chinese characters
Hi, I wanted to install plugin to be able to input chinese character on Writer, Kate, kopete, gaim and even naming my folders. I tried scim ans gcin but it seems doesnt work.. it when I run the scim configuration tools, its just trying to start and gone, but doesnt open program. I tried runing the scim on terminal by typing scim, and saw the scim icon besides the clock, but no further choices, its just help about and setup, which setup is just like the configuration tools. is there any plugins for chinese character input?

PS --- I am using Kubuntu 5.10 Breezy with KDE 3.5

Hope to receive input from you.


apachedude 01-26-2006 11:30 PM

I use skim with scim, which is a GUI for KDE. It doesn't work until after you reboot after installation--or at least it didn't work for me. It's kind of weird, you have to wait a while before the Chinese input works. I think it's after you start typing something that skim kind of "kicks in".

Sorry if I can't describe it too well. I just started typing in Chinese and use it very minimally, as Chinese input definitely is not a high priority for me. All I can tell you is that on SuSE 10, I was able to successfully install and configure skim. It required a bit of guesswork, as the documentation could be better and some of the options are unintuitive.

JDW 02-05-2006 02:57 PM

Hey Whizzkid8,

Hope you have solved this by now, but if not, make sure you have also installed the additional scim packages you will need for input. In "Synaptic" do a search for "scim" and install packages related to Chinese input such as "scim-chinese" etc.

Hope that helps...


gnoteb 02-06-2006 05:11 AM

if you have the scim box there you should be ok. just open a text editor (that supports chinese) like for instance leafpad press crtl+space (or move the mouse over the box and choose) to change input and you should be fine. i use uim-py for simplified. for some reason uim-pyunihan shows only some strange boxes with numbers in it.

if you press ctrl+space and nothing happens, then chinese probably isnt supported in that program.

good luck

BCarey 03-04-2006 02:22 PM


I have scim and scim-pinyin installed and have the icon showing and am able to configure, but...nothing happens with Ctrl-Space and hovering over the icon does not show anything. I even tried installing leafpad to see if that would work but no luck.

Any ideas would be appreciated.


secretlydead 09-19-2007 10:21 PM


Can you take a look at this thread:


Thank you.

All times are GMT -5. The time now is 02:05 AM.