LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-01-2005, 01:04 PM   #1
kkempter
Member
 
Registered: Dec 2002
Posts: 187

Rep: Reputation: 30
Informix and GLIBC error


I've installed a version of Informix on Fedora Core3 designed for GLIBC v. 2.2.x
When I try and initialize the db I get the following error:
relocation error: /var/lib/libpthread.so.0: symbol _h_errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference

I found a post on the net that says to install a previous version of GLIBC:

Actually, You can try to install another GLIBC
package onto Your existing Linux.
For example, 'glibc-2.2.93-5.i686.rpm' works fine for IDS 9.21+

Here's my questions:
1. Is there another way to fix this other than installing an older
version of GLIBC (Currently I'm at 2.3) Here's an rpm query listing:
root@Issac # rpm -qa | grep -i glib
glibc-2.3.4-2.fc3
dbus-glib-0.22-10.FC3.2
glib-1.2.10-15
glibc-kernheaders-2.4-9.1.87
glibc-devel-2.3.4-2.fc3
glibc-common-2.3.4-2.fc3
glibc-headers-2.3.4-2.fc3
glib2-devel-2.4.8-1.fc3
glib2-2.4.8-1.fc3

2. If I have to install an older version of GLIBC can I add it as an addition
and only point the Informix files to use it?

3. If neither of the above questions are options, will I break my
system by reverting to an older version of GLIBC ?

Thanks in advance for your help.

/Kevin

==============================================
Your Mouse Has Moved.
Windows Must restart to affect the changes.
Reboot Now [Y] ?
==============================================
 
Old 03-01-2005, 01:20 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 255Reputation: 255Reputation: 255
You probably need to install the compat-glibc rpm's for older compatibility, etc.
 
Old 03-01-2005, 01:54 PM   #3
kkempter
Member
 
Registered: Dec 2002
Posts: 187

Original Poster
Rep: Reputation: 30
Thanks for the info however it looks like the compat-glibc rpm's are designed to give one the ability to link to the older libs at compile time. What I need is the ability to point the informix binaries to a new set of shared libs at run time.

Will the compat-glibc rpm's do this for me?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
informix error while compile 4gl programs gpereira Red Hat 3 06-03-2005 02:59 PM
Glibc error alexchao Linux From Scratch 2 05-23-2005 01:37 PM
glibc error ChrisR(SQL DBA) Linux - Newbie 4 11-23-2004 12:22 AM
glibc 2.3.2 error rahul_jain_9684 Linux From Scratch 3 08-06-2003 11:36 PM
PHP and Informix kaiozero General 0 11-12-2001 11:42 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration