LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Infinite loop while trying to install mplayer. (https://www.linuxquestions.org/questions/linux-software-2/infinite-loop-while-trying-to-install-mplayer-653703/)

dr_zayus69 07-05-2008 05:35 AM

Infinite loop while trying to install mplayer.
 
Hi. I have this annoying problem while trying to reinstall mplayer. I had it installed and got this error message.

Quote:

gmplayer: error while loading shared libraries: libdts.so.0: cannot open shared object file: No such file or directory
I did yum provides libdts.so.0 and it says libdca, which is already on my system. So I tried uninstalling libdca with yum, then reinstalled it. Uninstalled mplayer with yun and then tried to install it again and get the error message that libdts.so.0 is needed. I am stuck as to what to do because I've searched for libdts.so.0 on my system but can't find it so libdca is not providing it somehow. Any ideas how how to fix this? Thanks for reading and thanks for any replies in advance.

edit: I am using FC7 and here is my uname -a
Quote:

Linux localhost.localdomain 2.6.22.5-76.fc7 #1 SMP Thu Aug 30 13:47:21 EDT 2007 i686 i686 i386 GNU/Linux

Samotnik 07-05-2008 06:50 AM

try to add a directory where libdts.so.0 is, to the /etc/ld.so.conf file, than execute ldconfig as root.

dr_zayus69 07-05-2008 07:23 AM

thanks for the reply. The weird thing is I can't find it on my system. Yum says it is provided by libdca, which is installed on my system but I don't have libdts.so.0 somehow.

dr_zayus69 07-05-2008 07:34 AM

i read the libdca from freshrpms doesn't include the shared library but the one from livna does. But I am having a hard time disabling the freshrpms repo so that yum gets it from livna instead.
Quote:

[root@localhost Jeff]# yum --disablerepo=freshrpms.repo
Error getting repository data for freshrpms.repo, repository not found
I've also tried without the .repo suffice. Have never disabled a repo before so not too sure what I am doing wrong.

edit: I just disabled the repo manual through the file in the /etc/yum/repos.d directory and that worked. That was pretty confusing.


All times are GMT -5. The time now is 05:02 AM.