-   Linux - Software (
-   -   Impossible package dependencies!!! (

moistTowelette 05-07-2005 12:15 AM

Impossible package dependencies!!!
I'm trying to install the latest Gnome on my Debian 3.0 Woody install, but unfortunately when i type 'apt-get install gnome', there a whole lot of unmet package dependencies.

To cut a long story short, I've been through all the unmet dependencies and tried to install them manually only to find that the dependencies have dependencies, and those dependencies have dependencies, and finally I'm down to one package i have to install called 'libc6'.

Now here's the problem: 'libc6' depends on a package called 'libdb1-compat', so i downloaded that and tried to install it, only to find that it's dependent on 'libc6' (!). What the hell? Isn't that an impossible situation? Can anyone help me out with this?

darkleaf 05-07-2005 02:51 AM

Trying to run the latest gnome on woody is probably going to be pretty hard ;) Woody is a couple of years out now and the Sarge is going to be the stable branch soon. Newer packages are in testing (packages have been tested for the large bugs in unstable) and unstable (only means the packages haven't had much testing yet so you might run into a few errors or a package might be broken which barely happens in my experience). You can upgrade this with apt-get if you like. Look for info on "apt-get dist-upgrade".

For your problem. Did you use apt-get when you tried to install them or dpkg? If you use apt the packages are downloaded to /var/cache/apt. If you used dpkg you know where the packages are ;)

Do this:

dpkg -i /path/to/libdb1-compatpackage
dpkg -i /path/to/libc6package

This will both give the dependency errors you encountered before. Now run:

dpkg --pending --configure
It could be that this step alone works too.

SharpyWarpy 05-07-2005 06:06 AM

Try installing them both at the same time, like this:
rpm -ivh first-package.rpm second-package.rpm

darkleaf 05-07-2005 08:53 AM

Debian doesn't use rpms sharpywarpy ;)

SharpyWarpy 05-07-2005 06:05 PM


Originally posted by darkleaf
Debian doesn't use rpms sharpywarpy ;)
Oops, sorry about that, ya'll.
So, does Debian use tgz like Slackware, then?

Drake1132 05-07-2005 07:28 PM

Debian uses debian packages... they end in the file extension .deb :)

Otherwise you can also use source


moistTowelette 05-07-2005 08:46 PM

Thanks for the help guys, I actually managed to get Gnome 2.2 running on Woody. It looks awesome.

All times are GMT -5. The time now is 05:13 AM.