-   Linux - Software (
-   -   "ImportError: No module named gobject", Exaile fails to run. Python problem. (

kummiliim 07-14-2007 10:18 AM

"ImportError: No module named gobject", Exaile fails to run. Python problem.

Decided to install Exaile today. After installing all the dependencies without much problem I Installed the player itself and tried to run it.


bash-3.1$ ./exaile
Traceback (most recent call last):
  File "", line 21, in <module>
    import traceback, sys, gobject
ImportError: No module named gobject

Following recommendations from #exaile@freenet I've tried recompiling both pyGTK and pygobject, no gain.

Following some other thread I also checked if I had in my system which I didn't. Since pygobject itself installs fine, I don't know what to think of this.

GERSON 12-11-2008 01:12 PM


So I think sometimes the problem has to do with PYTHONPATH in case you already have those bindings installed.

For example if I 'export PYTHONPATH=""' then I can't even 'import pygtk'. If I 'export PYTHONPATH="/usr/local/lib/python2.5/site-packages/"' I can 'import pygtk' but can't 'import gtk' or 'import gobject'.

And finally, what did it for me was 'export PYTHONPATH="/usr/local/lib/python2.5/site-packages/:/usr/local/lib/python
2.5/site-packages/gtk-2.0/"'. After that I could import everything and didn't even need to pay custom taxes.

You can put this export command on your .bash_login. That's what I did.

Maybe it will work for somebody out there.


All times are GMT -5. The time now is 07:23 AM.