LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-06-2004, 11:38 PM   #1
snofink
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
Question imagemagick on debian make error libperl.a


Hello,

I have been trying to install ImageMagick from source and I have been having the following error when I do "make" ... my ./configure is :

Quote:
make[3]: Entering directory `/root/ImageMagick-5.5.7/PerlMagick'
make[3]: *** No rule to make target `/usr/lib/perl/5.6.1/CORE/libperl.a', needed by `PerlMagick'. Stop.
make[3]: Leaving directory `/root/ImageMagick-5.5.7/PerlMagick'
make[2]: *** [PerlMagick] Error 2
make[2]: Leaving directory `/root/ImageMagick-5.5.7/PerlMagick'
make[1]: *** [PerlMagick/PerlMagick] Error 2
make[1]: Leaving directory `/root/ImageMagick-5.5.7'
make: *** [all-recursive] Error 1

I tried doing "apt-get install libperl-dev" but then it gives me this error:

Quote:
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
libperl-dev: Depends: libperl5.6 (= 5.6.1-8.3) but 5.6.1-8.6 is to be installed
E: Sorry, broken packages
I am using Debian (woody) on my webserver I am installing imagemagick to. any help would be appreciated. Thanks.

Last edited by snofink; 04-06-2004 at 11:45 PM.
 
Old 04-06-2004, 11:53 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Try another apt-get update, then retry the install. I just check the reposity and libperl-dev is dependant on libperl5.6.1-8.6 now. You may have just got a partial update, or the reposity your using hasn't updated fully.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vim dependency problem libperl.so error loading kprasanna_79 Linux - Software 1 03-09-2005 05:22 AM
make glibc 2.3.2 debian error storma Linux - Software 0 01-01-2004 02:29 AM
ImageMagick libperl.a error gbg Linux - Software 3 09-25-2003 07:09 PM
Debian woody : make menuconfig ERROR pedro99 Linux - Newbie 7 01-23-2003 02:10 PM
debian make xconfig error? augamecock Linux - Distributions 2 04-11-2002 07:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration