LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   (II) [GLX]: Initializing GLX extension - X wont go (https://www.linuxquestions.org/questions/linux-software-2/ii-%5Bglx%5D-initializing-glx-extension-x-wont-go-46182/)

hydro 02-19-2003 02:36 PM

(II) [GLX]: Initializing GLX extension - X wont go
 
Well I Installed the nvidia kernel and glx drviers

I have the latest XFree86


My config if prob all good.... when I run
startx all i get is

(II) [GLX]: Initializing GLX extension

waiting for X server to shut down


--
and it shuts down :/ what could be wrong?

p.s.: i ran redhat-config-xfree86 and it went into a gui config screen, but still gave that error :/

p.p.s: If i type "X" it goes to a screen with a cursor on it,, and thats all, i fthen i do ctrl+alt+f1, and it goes to console.. it just says (II) [GLX]: Initializing GLX extension and is waiting....

verigoth 02-20-2003 01:28 AM

the README file for the NVidia drivers says not to load the glx module. comment the line LoadModule "glx" in your x config file

verigoth

Obi Perrin 02-20-2003 10:14 AM

Dude, wrong way around. From the NVidia readme file:

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore"

if they exist. There are also numerous options that can be added to
the XF86Config file to fine-tune the NVIDIA XFree86 driver. Please see
Appendix D for a complete list of these options.

Emphasis is my own.

Obi Perrin 02-20-2003 07:12 PM

I'm not quite clear what's happening, first it sounded as if X wasn't working at all, but the edit comment about the X cursor makes it sound as if X is working, but instead of loading a real window manager, it's using the X default (xwm I think?). Can you post the contents of /etc/X11/XF86Config-4 and ~/.xinitrc? Also, please further describe what happens after startx is run. So you get an X cursor up, does it move when you move the mouse? Does a menu appear when you left click?

I'm pretty sure that it's just a case of your ~/.xinitrc file being overwritten (perhaps by that redhat utility you talked about, haven't used redhat). If that file is blank, you would add a line like "exec startkde". Obviously, that's a kde only command, if you use Gnome or someother window manager, you'll have to find their equivalent.


All times are GMT -5. The time now is 01:15 PM.