-   Linux - Software (
-   -   ignoring the "non-portable whitespace encountered at line " warning (

Jake13 08-18-2004 09:20 AM

ignoring the "non-portable whitespace encountered at line " warning
I just moved up to Linux 9.0, and my C code that I'm trying to port over works properly, but when I do a make clean on my program, I get pages and pages of

"non-portable whitespace encountered at line..."

I know why the warning is being thrown but I just don't have to time to go back through the hundreds of files in my program and change the problem.

Is there a gcc complier option to ignore this warning?? I've spent some time on google but haven't found anything very useful. Any help would be greatly appreciated.


rjlee 08-18-2004 09:50 AM

I'm surprised that gcc gets invoked on a make clean; are you sure that's what's generating the warning?

If it's gcc, you can pass an option like -Wno-something or -Wnone. See your gcc manual; I don't seem to have that particular warning.

man gcc
( By the way, I assume you mean version 9.0 of your distribution, not 9.0 of Linux itself (the kernel), as the latest major version of Linux is still only 2.6 )

Jake13 08-18-2004 10:05 AM

sorry, wasn't paying attention(not enough coffee this morning) is with the make clean.

durning the "make clean", I do a "make -s depend"'s here where it throws those warnings

rjlee 08-18-2004 12:34 PM

“Make” itself isn't giving you these warnings; rather it calls another program or script to set up the dependencies. It's that that's generating these warnings.

What do you have in the “depend” section of your Makefile?

All times are GMT -5. The time now is 09:03 AM.