-   Linux - Software (
-   -   ies4linux x86_64 gtk library error (

ThumbTack 05-17-2009 08:51 PM

ies4linux x86_64 gtk library error
I need IE in order to access one website important to me. It appears that there is some incompatibility between the x86_64 gtk libraries, and what the ies4 routines require. I already have WINE installed and working for other routines.

I have previously loaded 32 bit versions of most X11 and gtk shared object libraries, but obviously something is still missing or wrong.

I am running Fedora 10 x86_64. I have no doubt that if I was running the pure 32 bit version of Fedora 10 I would have no problems, but then I would lose 4 GB of memory.

Netscape Communicator would also work for me, but the same kind of gtk/X11 incompatibility occurred when I tried to install and use it.

Does anyone know which libraries I need to give ies4 in order for it to work?

ThumbTack 05-18-2009 11:05 AM

ies4linux needs i386 gtk libraries
When you look at the package manager for Fedora 10 x86_64, you will find a long list of libraries. Most are x86_64, but some are i386 only. I assumed that ies4linux needed some i386 libraries that had not been installed. So, I scrolled through the list, and installed every i386 library that corresponded to an already installed x86_64 library. In addition, there were a few developmental libraries which I installed in both the i386 and x86_64 form.

All in all, I would say I installed about tweleve new libraries. I did not pay attention to exactly which ones they were.

After doing that, I was able to get Netscape Navigator to run, and ies4linux to install.

With an x86_64 machine, the i386 libraries are not automatically installed. When you have a compatibility issue, one or more missing i386 libraries may be the problem.

When you have a source code tarball, it usually doesn't matter because gcc has the libraries it needs.

In this case, since I didn't have the source code, my guess was correct. I needed some of the
gtk i386 libraries. I do not have a clue as to which of the many i386 libraries I installed were the critical ones. It is probably the case that not all were needed, and that what I did was overkill.

No matter. It worked.

All times are GMT -5. The time now is 11:24 AM.