LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-21-2012, 02:53 AM   #1
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,062

Rep: Reputation: Disabled
IDE / AHCI mode decides what system is booted?


Or, more precisely, the mode decides what boot loader is read from the hard disk, how does it do it? Reason I ask is, when I use IDE Linux is booted via GRUB, when I switch to AHCI in the BIOS FreeBSD starts with its own boot-loader. Nothing else must be changed to provoke this behaviour. What is the cause for this?

Here is the setup:

The mainboard (see my signature) has two controllers for harddisks. One is for 6G-SATA and holds the sda-device. The other is PATA-capable (and thus uses IDE) and holds an older PATA-disk and the CD/DVD-burner from which I installed all systems. This is the layout of the SATA (system) disk (the IDE disk just holds some data):
  • sda1 ext2 /boot
  • sda2 ufs FreeBSD-slice
  • sda3 ext4 unused
  • sda4 extended
  • sda5 ext4 / (root SuSE 11.4)
  • sda6 ext4 /home (SuSE 11.4 and 12.1
  • sda7 swap
  • sda8 ext4 (Ubuntu)
  • ...
Originally sda1 had the bootable flag, but during the installation of FreeBSD sda2 became bootable.

Now, when I use IDE sda1 fires up GRUB but when I switch to AHCI FreeBSD comes up. What is the technical reason?!?

And, as an aside, yes, I can chainload the FreeBSD boot loader (and run it with IDE-mode). The GRUB developers or SuSE disabled the ufs file system in GRUB . Anybody knows why this happened (unrelated question, I know)?

Last edited by JZL240I-U; 02-22-2012 at 02:24 AM.
 
Old 02-22-2012, 12:18 PM   #2
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,753

Rep: Reputation: 934Reputation: 934Reputation: 934Reputation: 934Reputation: 934Reputation: 934Reputation: 934Reputation: 934
Interesting!

I'd guess that you by 'change mode' you mean changing the SATA HDD controller from 'IDE mode' to ACHI. If you have have GRUB on the IDE drive, and FREEBSD on the SATA drive, its possible when you change mode to ACHI the SATA device is booted before the IDE device.

Check your BIOS settings.
 
Old 02-23-2012, 02:06 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,062

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by cascade9 View Post
Interesting! .
Indeed.

Quote:
Originally Posted by cascade9 View Post
I'd guess that you by 'change mode' you mean changing the SATA HDD controller from 'IDE mode' to ACHI.
Yes.

Quote:
Originally Posted by cascade9 View Post
If you have have GRUB on the IDE drive, and FREEBSD on the SATA drive...
No, no, no, and no again. They are on one and the same drive. Please read my first post agan and in particular note the layout of the partitions of sda. sdb is not bootable and holds only data, no bootloader in the MBR, I zeroed the drive before inserting it on its current position.

Quote:
Originally Posted by cascade9 View Post
Check your BIOS settings.
Guess what I do, when I switch between FreeBSD and Linux... .
 
Old 02-23-2012, 04:09 PM   #4
jefro
Moderator
 
Registered: Mar 2008
Posts: 17,101

Rep: Reputation: 2552Reputation: 2552Reputation: 2552Reputation: 2552Reputation: 2552Reputation: 2552Reputation: 2552Reputation: 2552Reputation: 2552Reputation: 2552Reputation: 2552
Still seems to be a boot order in bios issue but I can't prove it from here. I can't say why say an active or marked active partition would cause this. Dunno why the mode should cause a chance to how bios selects the order.

I assume you have two boot loaders on two different drives and not two on one drive.
 
Old 02-24-2012, 01:58 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,062

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jefro View Post
Still seems to be a boot order in bios issue but I can't prove it from here.
I know where the boot order is changed in the BIOS, it is on a different screen / menu and I never touched it during these cavortings.

Quote:
Originally Posted by jefro View Post
...I assume you have two boot loaders on two different drives and not two on one drive.
Actually I have five on sda (and none on sdb):
  1. /dev/sda1 "master" GRUB for SuSE 11.4, 12.1, chainload FreeBSD's loader and the other GRUBs
  2. /dev/sda2 FreeBSD's loader
  3. /dev/sda8 SuSE 12.1 original GRUB also chainloading all the others
  4. /dev/sda10 GRUB2 of Ubuntu also loading all the others
  5. /dev/sda12 GRUB2 of Fedora also loading all the others
HTH .
 
Old 03-16-2012, 09:15 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,062

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by JZL240I-U View Post
... sdb is not bootable and holds only data, no bootloader in the MBR, I zeroed the drive before inserting it on its current position...
Well, in a way I wish it were so . In my quest for knowledge I dumped the MBRs of both drives and had a look at the contents. /dev/sda I didn't recognize, must be the FreeBSD boot sequencer(?). /dev/sdb contains three messages of GRUB, so there must still be GRUB on it. Obviously I zeroed the partition(s) and not the drive, my apologies, jefro.

So, what I think happens is this: In ACHI mode the SATA-controller gets preference to search and launch its MBR while in IDE-mode the other controller can have its way and launches his own MBR.

Funny and labyrinthine are the ways of information technology .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Loss of data when switching to ahci from ide? JZL240I-U Linux - Hardware 23 11-30-2011 11:49 AM
Getting kernel to boot on both IDE and AHCI mode galapogos Linux - General 7 10-25-2011 02:06 AM
[SOLVED] Can't install from DVD with AHCI enabled, only IDE quiescere Slackware 3 05-12-2011 03:36 PM
AHCI/IDE configuration not found in BIOS==kernel panic sync shashank.neocfc Linux - Laptop and Netbook 2 10-25-2010 01:26 AM
Can't get SATA drive in AHCI mode, stuck with ata_piix Silverpike Linux - Hardware 3 04-07-2010 10:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration