LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-29-2004, 12:32 PM   #1
lamberpeople
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Rep: Reputation: 0
Angry IBM G40 Laptop + SuSE 9.2 = Boot screen resolution problem


I had SuSE 9.0 laptop and boot screen resolution was fine. I could select Linux/Windows/Safe mode etc. SuSE 9.2 shows black screen with some flares. How Can I change screen resolution for this boot screen or even switch it to text mode ?
 
Old 12-29-2004, 04:28 PM   #2
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
For text mode bootup, you need to change the default run-level in your /etc/inittab, right now it's no doubt 5, you need to change it to 3. You'll probably have to boot from cd and mount the hd, then edit the file and reboot sans cd. The line in question will look similar to this before:

id:5:initdefault:

and after like this:

id:3:initdefault:

the operative character there being the 3, this is assuming that 9.2 still does things similarly to 9.1 (and the rest of the linux world)
 
Old 12-29-2004, 05:09 PM   #3
lamberpeople
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by akaBeaVis
For text mode bootup, you need to change the default run-level in your /etc/inittab, right now it's no doubt 5, you need to change it to 3. You'll probably have to boot from cd and mount the hd, then edit the file and reboot sans cd. The line in question will look similar to this before:

id:5:initdefault:

and after like this:

id:3:initdefault:

the operative character there being the 3, this is assuming that 9.2 still does things similarly to 9.1 (and the rest of the linux world)
No the problem is not my current run level. It is not a big problem to change it. The problem is the boot screen itself. The screen that must show menu Linux/Windows/Safe mode, this screen is not rendered well. (black screen with some flares). If I press Enter then it starts loading the system and KDE starts very well. I belive that Linux has default screen resolution for each mode (run level 3,5). I think in Windows it is very simple that you just use either memory of videoadapter if you work in text mode or use Win32 API that in turns use graphic driver. But I have an assumptiion that there are several different ways to displays something on the screen in Linux. Each of this ways uses some library and this library has specific configuration. And what is worth there are no drivers for this libraries. For exmple I have Intel 852GM video card. It was detected as Intel 855GM. So probably this card works somehow different in cerain graphic modes. This is so petty. New version of SuSE is mo buggy then prior one. My hardware is brand new IBM laptop. So could only imaging how SuSE works on other less know laptops.
 
Old 12-29-2004, 05:23 PM   #4
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Ah, then perhaps what you need to change would be something in your /etc/lilo.conf (assuming you're using lilo as your boot mgr, I don't know about grub), and in the section for your desired/default kernel you may need to add/change the line: vga=normal. And of course you would need to run lilo after editing the file, I have had similar sorts of issues after compiling new kernels (but I was leaving important things out like fb support and yet having lilo set to some vesa resolution)

Also, does the fn+f8 key change anything?
 
Old 12-29-2004, 06:41 PM   #5
lamberpeople
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by akaBeaVis
Ah, then perhaps what you need to change would be something in your /etc/lilo.conf (assuming you're using lilo as your boot mgr, I don't know about grub), and in the section for your desired/default kernel you may need to add/change the line: vga=normal. And of course you would need to run lilo after editing the file, I have had similar sorts of issues after compiling new kernels (but I was leaving important things out like fb support and yet having lilo set to some vesa resolution)

Also, does the fn+f8 key change anything?
Actually I don't use Lilo. I use GRAB. So it probably will take a time. It is possible to select screen resolution pressing F2 but it affects only next step of system boot up. The first screen is not affected by F2 command. Probably it makes sense to return back to SuSE 9.0 or switch to another distributive that can recognise my hardware. Changing from GRAB to LiLO is to big compromise that I could not bear :-)
 
Old 01-06-2005, 12:06 AM   #6
NeoMagick
LQ Newbie
 
Registered: Sep 2004
Location: Seattle, Wa
Distribution: Debian/Elive Rl2 - E17
Posts: 20

Rep: Reputation: 0
Before you scratch your install, it *is* a configuration option. There's a flag you can set in the GRUB loader cfg file (just as with lilo, it was a simple 'vga=xxx' option).

I'm researching this myself right now (i've got the same issue).. i'll post more details here when I find the answer.
 
Old 01-06-2005, 10:50 AM   #7
lamberpeople
LQ Newbie
 
Registered: Dec 2004
Posts: 5

Original Poster
Rep: Reputation: 0
It is cool

Please don't forget to do it. It will be GREAT.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wired Ethernet won't work on IBM G40 SUSE 9.1 hairymnstr Linux - Laptop and Netbook 2 04-14-2005 04:29 PM
IBM G40 Built-in Wireless is 'intermittant' ollywompus Linux - Laptop and Netbook 0 02-07-2005 11:24 AM
IBM G40 Laptop + SuSE 9.2 = Boot screen resolution problem lamberpeople Linux - Hardware 0 12-29-2004 12:03 PM
Problem with dual boot on IBM laptop cain_eve Linux - Laptop and Netbook 1 12-13-2004 12:03 PM
Install SuSE 9.1 Linux on IBM Thinkpad G40. leessusan Linux - Laptop and Netbook 3 08-04-2004 10:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration