LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-10-2002, 11:20 AM   #1
I_NEED_HELP
LQ Newbie
 
Registered: Feb 2002
Posts: 2

Rep: Reputation: 0
i810 module needed


Has anyone managed to succesfully compile the 1.2 versione drivers for the intel i810 graphics chips from the intel website. I need them so i can get decent frame rates in openGL. However when i compile them it tells me i need a 2.2 version of the kernel. However despite my best efforts at compiling a 2.2 kernel i cant get it to work. If anyone has compiled the 2.2 version, could they please email me the i810.o file so i can just overwrite my old version. I know this might not work but this is my last hope. Ive tried everything i can think off to get this graphics chip to do its work.
 
Old 02-10-2002, 02:40 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Sully!

does the error say that you need 2.2 kernel or 2.2 OR newer? I would guess that it's simply not being able to find the correct kernel version for some reason. Downgrading to a different kernel version is a pretty drastic thing to do. if you're trying to compile from code and are using ./confgure, yuo should have a confg.log file to give more verbose specific errors
 
Old 02-10-2002, 07:19 PM   #3
ryanstrayer
Member
 
Registered: Jan 2002
Location: Kansas City
Distribution: RedHat 7.2 Kernel 2.4.17
Posts: 250

Rep: Reputation: 30
Correct me if I'm wrong, but aren't there DRI drivers out there made by someone else besides off the Intel web site? I don't recall the web site off hand .. whomever is making all the DRI stuff for XFree86... also are you running 4.2.0 X or 4.1.0 - there is a drastic improvement between these versions in FB and DRI support.
 
Old 02-11-2002, 05:36 AM   #4
I_NEED_HELP
LQ Newbie
 
Registered: Feb 2002
Posts: 2

Original Poster
Rep: Reputation: 0
First when trying to compile the intel module it tells me that it does not work on non 2.2 kernels, so it will not work on 2.4 kernels

Second the DRI website does not have anything on at the momment i think they took of binaries etc whilst theyre upgrading everything to mesa v4

Thirdly, the message i get when i XFree86 4.2.0-2mdk loads is that it finds v1.1 of the i810 module and i need v1.2.

Hope that clears up everything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error loading i810 module : installing Xserver on gentoo Sredhar Linux - Distributions 11 12-08-2004 05:38 PM
i810 module errors while load emcoder Linux - Hardware 2 06-20-2004 11:29 PM
no screen i810 module Canadian_2k2 Linux - Hardware 4 12-30-2003 02:25 AM
i810-tco module problems forkvoid Linux - General 3 09-28-2003 08:32 PM
Unloading Module i810.o suriyamohan Linux - Software 3 05-30-2003 04:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration