LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-11-2009, 06:25 AM   #1
rich13348
Member
 
Registered: Apr 2009
Posts: 31

Rep: Reputation: 15
i updated a package now nothing works


i updated debhelper on debian and it updated a load of files now nothing works synaptic manager doesnt run apt-get doesnt work just lists a whole load of unmet dependencies for everything it all seems to stem back to libapt-pkg-libc thats mentioned in a lot if not all of the dependencies when trying to do apt-get install
 
Old 04-11-2009, 11:08 AM   #2
TITiAN
Member
 
Registered: Mar 2008
Location: NRW, Germany
Distribution: Arch Linux, using KDE/Plasma
Posts: 392

Rep: Reputation: 49
did you try the "apt-get -f install" command?
 
Old 04-11-2009, 12:42 PM   #3
rich13348
Member
 
Registered: Apr 2009
Posts: 31

Original Poster
Rep: Reputation: 15
yes this is the result

Code:
debian:/home/richard# apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies...Done
The following extra packages will be installed:
  apt cups dpkg dpkg-dev gedit-common gtk2-engines libblas3gf libcairo-perl
  libcamel1.2-14 libcolamd-3.2.0 libcurl3-gnutls libebook1.2-9 libecal1.2-7
  libedataserver1.2-11 libenchant1c2a libffi5 libgail-common libgail18
  libgfortran3 libglade2-0 libgnome-desktop-2-7 libgnome2-canvas-perl
  libgnome2-perl libgnomecups1.0-1 libgnomeprint2.2-0 libgnomeprint2.2-data
  libgnomeprintui2.2-0 libgnomeprintui2.2-common libgtk2-perl libgtk2.0-0
  libgtkhtml2-0 libgtksourceview2.0-0 libgtksourceview2.0-common
  libhunspell-1.2-0 libhyphen0 liblapack3gf liblocale-gettext-perl libmalaga7
  libnautilus-burn4 libneon27 libnss3-1d libpanel-applet2-0 libpango-perl
  libpq5 libraptor1 librasqal1 librdf0 libsemanage1 libsoup2.4-1
  libtext-charwidth-perl libtext-iconv-perl libtimedate-perl
  libtotem-plparser12 libustr-1.0-1 libvoikko1 libvte9 libwnck22 libwpg-0.1-1
  libwps-0.1-1 lp-solve openoffice.org-base-core openoffice.org-calc
  openoffice.org-common openoffice.org-core openoffice.org-draw
  openoffice.org-gnome openoffice.org-gtk openoffice.org-impress
  openoffice.org-math openoffice.org-style-galaxy openoffice.org-style-tango
  openoffice.org-writer perl perl-base python python-apt python-bugbuddy
  python-evolution python-gconf python-gnomeapplet python-gnomedesktop
  python-gnomekeyring python-gnomeprint python-gobject python-gtkhtml2
  python-gtksourceview python-gtksourceview2 python-gtop python-mediaprofiles
  python-minimal python-nautilusburn python-numpy python-selinux
  python-semanage python-totem-plparser python-wnck uno-libs3 ure
Suggested packages:
  apt-doc cups-driver-gutenprint xpdf-korean xpdf-japanese
  xpdf-chinese-traditional xpdf-chinese-simplified cups-pdf debian-keyring
  libgtk2-perl-doc gvfs voikko-fi openoffice.org-base
  openoffice.org-style-industrial openoffice.org-style-hicontrast
  openoffice.org-evolution tango-icon-theme openoffice.org-gcj
  libterm-readline-gnu-perl libterm-readline-perl-perl python-doc python-tk
  python-profiler python-apt-dbg python-gnome2-doc python-gobject-dbg
  libgtksourceview2.0-dev python-numpy-doc python-numpy-dbg python-nose
  java2-runtime cli-uno-bridge
Recommended packages:
  avahi-utils build-essential gnome-mount raptor-utils redland-utils
  openoffice.org-style-crystal openoffice.org-filter-binfilter default-jre
  java-gcj-compat openjdk-6-jre sun-java5-jre sun-java6-jre
  openoffice.org-java-common openoffice.org-writer2latex
  openoffice.org-emailmerge
The following packages will be REMOVED
  metacity python-gnome2-desktop
The following NEW packages will be installed
  cups libblas3gf libcamel1.2-14 libcolamd-3.2.0 libcurl3-gnutls libebook1.2-9
  libecal1.2-7 libedataserver1.2-11 libffi5 libgail18 libgfortran3
  libgnome-desktop-2-7 libgtksourceview2.0-0 libgtksourceview2.0-common
  libhunspell-1.2-0 libhyphen0 liblapack3gf libmalaga7 libnautilus-burn4
  libneon27 libnss3-1d libpango-perl libpq5 libraptor1 librasqal1 librdf0
  libsoup2.4-1 libtimedate-perl libtotem-plparser12 libustr-1.0-1 libvoikko1
  libvte9 libwnck22 libwpg-0.1-1 libwps-0.1-1 lp-solve
  openoffice.org-base-core openoffice.org-style-galaxy
  openoffice.org-style-tango python-bugbuddy python-evolution python-gconf
  python-gnomeapplet python-gnomedesktop python-gnomekeyring python-gnomeprint
  python-gobject python-gtkhtml2 python-gtksourceview python-gtksourceview2
  python-gtop python-mediaprofiles python-nautilusburn python-numpy
  python-totem-plparser python-wnck uno-libs3 ure
The following packages will be upgraded:
  apt dpkg dpkg-dev gedit-common gtk2-engines libcairo-perl libenchant1c2a
  libgail-common libglade2-0 libgnome2-canvas-perl libgnome2-perl
  libgnomecups1.0-1 libgnomeprint2.2-0 libgnomeprint2.2-data
  libgnomeprintui2.2-0 libgnomeprintui2.2-common libgtk2-perl libgtk2.0-0
  libgtkhtml2-0 liblocale-gettext-perl libpanel-applet2-0 libsemanage1
  libtext-charwidth-perl libtext-iconv-perl openoffice.org-calc
  openoffice.org-common openoffice.org-core openoffice.org-draw
  openoffice.org-gnome openoffice.org-gtk openoffice.org-impress
  openoffice.org-math openoffice.org-writer perl perl-base python python-apt
  python-minimal python-selinux python-semanage
40 upgraded, 58 newly installed, 2 to remove and 259 not upgraded.
109 not fully installed or removed.
Need to get 1815kB/134MB of archives.
After unpacking 95.0MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get: 1 ftp://ftp.debian.org unstable/main libgnomecups1.0-1 0.2.3-3 [75.2kB]
Get: 2 ftp://ftp.debian.org unstable/main libgnomeprint2.2-0 2.18.6-1 [292kB]
Get: 3 ftp://ftp.debian.org unstable/main libgnomeprint2.2-data 2.18.6-1 [173kB]Get: 4 ftp://ftp.debian.org unstable/main libgnomeprintui2.2-0 2.18.4-1 [172kB]
Get: 5 ftp://ftp.debian.org unstable/main libgnomeprintui2.2-common 2.18.4-1 [262kB]
Get: 6 ftp://ftp.debian.org unstable/main libtotem-plparser12 2.26.0-1 [332kB]
Get: 7 ftp://ftp.debian.org unstable/main python-evolution 2.24.1-1+b2 [55.6kB]
Get: 8 ftp://ftp.debian.org unstable/main python-gnomeapplet 2.24.1-1+b2 [32.3kB]
Get: 9 ftp://ftp.debian.org unstable/main python-gnomedesktop 2.24.1-1+b2 [33.8kB]
Get: 10 ftp://ftp.debian.org unstable/main python-gnomekeyring 2.24.1-1+b2 [39.7kB]
Get: 11 ftp://ftp.debian.org unstable/main python-gnomeprint 2.24.1-1+b2 [98.5kB]
Get: 12 ftp://ftp.debian.org unstable/main python-gtksourceview 2.24.1-1+b2 [78.2kB]
Get: 13 ftp://ftp.debian.org unstable/main python-gtop 2.24.1-1+b2 [34.0kB]
Get: 14 ftp://ftp.debian.org unstable/main python-mediaprofiles 2.24.1-1+b2 [28.8kB]
Get: 15 ftp://ftp.debian.org unstable/main python-nautilusburn 2.24.1-1+b2 [35.3kB]
Get: 16 ftp://ftp.debian.org unstable/main python-totem-plparser 2.24.1-1+b2 [28.7kB]
Get: 17 ftp://ftp.debian.org unstable/main python-wnck 2.24.1-1+b2 [42.5kB]
Fetched 1815kB in 11s (155kB/s)
apt-extracttemplates: error while loading shared libraries: libapt-pkg-libc6.7-6.so.4.6: cannot open shared object file: No such file or directory
debconf: apt-extracttemplates failed: Bad file descriptor
Extracting templates from packages: 30%apt-extracttemplates: error while loading shared libraries: libapt-pkg-libc6.7-6.so.4.6: cannot open shared object file: No such file or directory
debconf: apt-extracttemplates failed: Bad file descriptor
Extracting templates from packages: 61%apt-extracttemplates: error while loading shared libraries: libapt-pkg-libc6.7-6.so.4.6: cannot open shared object file: No such file or directory
debconf: apt-extracttemplates failed: Bad file descriptor
Extracting templates from packages: 91%apt-extracttemplates: error while loading shared libraries: libapt-pkg-libc6.7-6.so.4.6: cannot open shared object file: No such file or directory
debconf: apt-extracttemplates failed: Bad file descriptor
Extracting templates from packages: 100%
(Reading database ... 85597 files and directories currently installed.)
Preparing to replace libgnomecups1.0-1 0.2.2-5 (using .../libgnomecups1.0-1_0.2.3-3_amd64.deb) ...
Unpacking replacement libgnomecups1.0-1 ...
Preparing to replace libgnomeprint2.2-0 2.12.1-7 (using .../libgnomeprint2.2-0_2.18.6-1_amd64.deb) ...
Unpacking replacement libgnomeprint2.2-0 ...
Preparing to replace libgnomeprint2.2-data 2.12.1-7 (using .../libgnomeprint2.2-data_2.18.6-1_all.deb) ...
Unpacking replacement libgnomeprint2.2-data ...
dpkg: regarding .../python-apt_0.7.10.1_amd64.deb containing python-apt:
 package uses Breaks; not supported in this dpkg
dpkg: error processing /var/cache/apt/archives/python-apt_0.7.10.1_amd64.deb (--unpack):
 unsupported dependency problem - not installing python-apt
Errors were encountered while processing:
 /var/cache/apt/archives/python-apt_0.7.10.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
it seems to get further than the rest but then it fails and cant find anything maybe doe to the fact that synaptic or aptitude is not working
 
Old 04-11-2009, 02:35 PM   #4
TITiAN
Member
 
Registered: Mar 2008
Location: NRW, Germany
Distribution: Arch Linux, using KDE/Plasma
Posts: 392

Rep: Reputation: 49
It seems that there is the file libapt-pkg-libc6.7-6.so.4.6 missing or corupt.
Maybe you should try downloading apt/dpkg manually, extracting the file (e.g. with file-roller) and placing it
yourself.
Here are search links for "dpkg" and "apt":
apt
dpkg

Any luck with this?
 
Old 04-11-2009, 04:25 PM   #5
rich13348
Member
 
Registered: Apr 2009
Posts: 31

Original Poster
Rep: Reputation: 15
you cannot download libapt-pkg-libc(version number) because it is a virtual package so im afraid thats a no go there im not sure which packages provide that virtual package so i cant download them not least until i know what they are!!!
 
Old 04-11-2009, 04:31 PM   #6
TITiAN
Member
 
Registered: Mar 2008
Location: NRW, Germany
Distribution: Arch Linux, using KDE/Plasma
Posts: 392

Rep: Reputation: 49
there is a search funktion on the debian site where you can search for filenames:
link
any luck with this?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I get an updated libcgi-perl package built that runs on hardy? exodist Ubuntu 0 12-18-2008 04:12 PM
How does Mandriva package manager works? help_a_newbie Linux - Distributions 2 08-07-2007 05:30 AM
Can the Pupget package manager be updated? jacatone Puppy 1 05-29-2007 10:00 PM
Updated kernel, now thing works jsolanky Linux - Software 3 12-05-2004 01:18 AM
accounting package that works with linux shamz Linux - Software 4 08-29-2003 05:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration