LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-15-2003, 02:40 AM   #31
sput
Member
 
Registered: Jul 2002
Location: MN
Distribution: Slackware 9.1+
Posts: 70

Original Poster
Rep: Reputation: 15

Alright.. sounds like a weekend project..

I'll keep you posted.

Thanks!
 
Old 08-15-2003, 03:31 AM   #32
Hendrix
LQ Newbie
 
Registered: Jul 2003
Location: UK
Distribution: Migrating to Slackware from Redhat
Posts: 6

Rep: Reputation: 0
Hi Sput,
To check your port 25, Would a valid test not be to try and send an email through another ISP using their servers. ie set up your email client to relay through their servers. If your mail client then complains that you are not allowed to relay through their servers. eg:

The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was '123@123.comm'. Subject '', Account: 'TEST ACCOUNT', Server: 'xxx.xx', Protocol: SMTP, Server Response: '554 <123@123.comm>: Recipient address rejected: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79

You can be sure that your port 25 is open.

I remember when I first started seting up mail servers on Linux, I had loads and Loads of problems. I have never had the same trouble again. The whole experience is character building..... My heart goes out to you....

Good Luck
 
Old 08-16-2003, 06:30 AM   #33
sput
Member
 
Registered: Jul 2002
Location: MN
Distribution: Slackware 9.1+
Posts: 70

Original Poster
Rep: Reputation: 15
ready for some more confusion?

I downloaded a free smtp server for windows and installed it. The first message I tried to send went out to my hotmail account. Success! Soo.. my ISP is NOT blocking port 25 afterall. *sigh* so why oh why does my linux server not work? Looks like I got more work ahead of me.
 
Old 08-16-2003, 06:35 AM   #34
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu ; CentOS ; Raspbian
Posts: 12,613

Rep: Reputation: 69
Cool, well that's good then!

Look at installing fresh from the latest source from www.postfix.org and follow the README exactly.

Make sure IPTables are ALL down, no firewall issues going on, and then go for it

Good to hear your ISP isn't blocking your port, that is such a shame when that happens..

Cool
 
Old 08-16-2003, 08:01 AM   #35
sput
Member
 
Registered: Jul 2002
Location: MN
Distribution: Slackware 9.1+
Posts: 70

Original Poster
Rep: Reputation: 15
OMFG!!!!

I fixed it!!

After searching vigorously through pages and pages of log files.. I discovered this:

/etc/resolv.conf did not match /var/spool/postfix/etc/resolv.conf

Which I didn't even know existed.

Long story short, /var/spool/postfix/etc/resolv.conf was still set to my old isp's dns server.

MasterC - I have to thank you again man, you were a big help!

*phew*

 
Old 08-16-2003, 08:03 AM   #36
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu ; CentOS ; Raspbian
Posts: 12,613

Rep: Reputation: 69
Sweeeeett!

Glad you got it working finally

Cool
 
Old 08-16-2003, 12:00 PM   #37
charles168
LQ Newbie
 
Registered: Aug 2003
Posts: 11

Rep: Reputation: 0
I am also using RH9. Have tried to use Postfix and
Sendmail as MTA. I found that I cannot telnet to
the mail server [port 25] from outside when using Postfix
as MTA. Then I switch to SENDMAIL as MTA. It's working
fine. I think you can try to use SENDMAIL. I do
think that the ISP will not block your port.

Please check.
 
Old 08-17-2003, 10:48 PM   #38
sput
Member
 
Registered: Jul 2002
Location: MN
Distribution: Slackware 9.1+
Posts: 70

Original Poster
Rep: Reputation: 15
Charles,

I already have it working again, read above. As far as my choice of MTA, I use postfix because I also use squirrelmail and squirrelmail only works with postfix.

Peace.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix send mail problem(In RH9, kernal 2.4.20, postfix 2.1.5) minor Linux - General 6 09-23-2019 11:09 PM
can't start postfix ./postfix status error jules_fraser Linux - Software 3 12-06-2003 07:33 PM
Postfix Help jglazner Linux - Software 0 10-16-2003 04:58 PM
POSTFIX Help Micro Linux - Software 2 05-06-2003 11:29 AM
move postfix mails from server to another postfix server onetwo Linux - Software 2 03-18-2003 03:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration