LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-14-2003, 03:56 AM   #1
dboyer
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
I like Vi in RH9, but Vi on other OSs (slack and freebsd) are... scary


I love Vi on redhat... when i hit "i" it goes into insert mode, and says so by printing * INSERT * on the screen... when i hit backspace and delete keys, they do what they're expected to do (delete characters). the arrow keys move the cursor around. All is well with the world.

I have been looking at switching to something else, if even for just a little while to play with it. I tried slackware. Installed fine, blah blah. I tried editing a text file... and i ran into "hell". Hit "i" to go into insert mode.... it says nothing, but does one character before reverting back... i go back into insert mode, and type something, but make a typo. So i try and delete it... won't delete... try and move the cursor, and it starts doing weird things (i would be much more specific but my laptop with slack on it died and i can't remember exactly what it was doing)...

what is causing this? i thought it was slack, but i tried freebsd and its the same way. how can i get whatever it is that RH is doing to happen on slack? im glad i started with RH... Vi is annoying enough on other Distros/OSs to have made me turn my back on linux again (ive been trying it every 6-8 months for a couple years, and just recently found it useful enough to become my main OS).

Its kind of a generic question, but it really boils down to this: Is it some sort of terminal option? Vi option? version of Vi? something i can change on slack or FBSD to make them act the same.
 
Old 10-14-2003, 04:06 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
On RedHat you are probably using vim (www.vim.org) in compatibility mode to make it act only like vi and don't do any surprising vim-only maneuvers. On other OS's you might find that you are facing a vi clone much more similar than the original.

I suggest you install vim everywhere you go. I know I do.


hw
 
Old 10-14-2003, 05:02 AM   #3
yapp
Member
 
Registered: Apr 2003
Location: Netherlands
Distribution: SuSE (before: Gentoo, Slackware)
Posts: 613

Rep: Reputation: 30
add this to your profile:
Code:
alias vi=vim
For example add it to your ~/.bashrc, ~/.bash_profile, or for a system wide setting:, /etc/profile (system wide), or /etc/profile.d/<add an executable script here>.sh. I've created a /etc/profile.d/default-aliases.sh script, and activated it with:
chmod +x /etc/profile.d/default-aliases.sh
source /etc/profile
(rerun the script in your shell)

I think redhat has already created a vimrc file with settings. Slackware doesn't do things for you, because it can be annoying if you need to find out what they did.

Here is my ~/vimrc:
Code:
syntax on
set number
set autoindent
set ignorecase
set hlsearch
set incsearch

set ruler
set background=dark

Last edited by yapp; 10-14-2003 at 05:05 AM.
 
Old 10-14-2003, 09:21 PM   #4
pr1sg
LQ Newbie
 
Registered: Feb 2003
Distribution: Debian
Posts: 17

Rep: Reputation: 0
also try gvim if you are GUI-inclined. pretty, syntax highlighting, etc etc.
 
Old 10-15-2003, 02:09 PM   #5
dboyer
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Original Poster
Rep: Reputation: 0
yay.

Next time I get some wacky OS up and running, ill give these a try...

Quote:
I suggest you install vim everywhere you go. I know I do.
At least it isn't just me :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound under FreeBSD, no devices in xmms/oss-plugin Fonk *BSD 4 03-14-2005 09:04 AM
how to use OSS instead of ALSA slack 9.1 coffeedemon Slackware 2 11-16-2004 01:30 PM
Esound and oss on Slack 9.1 astronanard Slackware 1 12-05-2003 03:52 PM
Starting OSS sound at Boot in Slack 8.1 or BSD shepper Slackware 0 07-09-2003 12:20 PM
OSS sound in Slack 8? DiscoStoo Linux - Hardware 2 03-13-2002 09:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration