Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 11-03-2004, 02:48 AM   #1
LQ Newbie
Registered: Oct 2004
Posts: 4

Rep: Reputation: 0
I know nothing :( telnet is killing me

telnet localhost
Connected to localhost.
Escape character is '^]'.
Red Hat Linux release 9 (Shrike)
Kernel 2.4.20-8 on an i686
login: -h for super-user only

a) don't know how to set rights for not super-user only and if it help to solve a problem -> b)

b) I have to configure "adiXein HFC" for HylaFax to use MS Exchange address book - all is done but ... adiXein needs telnet to work correctly , but I cannot connect to my linux machine using telnet

I'm so confused ...
xinetd starts telet
telnet is also on the services list

but when I open services window and click on telnet I can see information that telenet needs to be set under xinetd to be started , in my opinion xinetd.conf is fine and should start telnet service

in addition I think that xinetd.conf dosn't include configuration from xinetd.d folder

maybe I'll paste here my configuration cos nothing smart comes to my midnd ...

# Simple configuration file for xinetd
# Some defaults, and include /etc/xinetd.d/

# defaults
# {
# instances = 60
# log_type = SYSLOG authpriv
# log_on_success = HOST PID
# log_on_failure = HOST
# cps = 25 30
# }

service telnet
disable = no
flags = REUSE
socket_type = stream
wait = no
user = nobody
groups = yes
server = /usr/sbin/in.telnetd
log_on_failure += USERID

service swat
port = 901
socket_type = stream
wait = no
only_from =
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = No
groups = yes

includedir /etc/xinetd.d
Old 11-03-2004, 04:05 AM   #2
LQ Newbie
Registered: Oct 2004
Posts: 6

Rep: Reputation: 0
I don't know if it's like this...

i've always thought that you can connect over telnet with all the users which you have on your linux machine.

eventually your firewall disturbs your telnet session.
you can stop it with /etc/init.d/iptables stop.
Old 11-03-2004, 07:00 AM   #3
LQ Newbie
Registered: Oct 2004
Posts: 4

Original Poster
Rep: Reputation: 0
I've changed in telnet section:

user = nobody ---> user = root

and right now I can telnet linux host but ...

all users including root cannot login ("Login incorrect" , than "Connection to host lost")


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
This is killing me UncleEricB Linux - Networking 2 02-01-2005 10:41 PM
How do I setup telnet on Fedorac1 so I can telnet to it from winxp? mman49 Fedora 6 05-02-2004 01:40 PM
can not telnet localhost 25 but telnet 25 exper Linux - Software 0 02-25-2004 06:13 AM
enable telnet but can't telnet from the computer guanyu Linux - Networking 8 08-26-2002 07:34 AM
telnet local but no-telnet via internet blacksheep Linux - Networking 7 11-26-2001 03:33 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:44 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration