-   Linux - Software (
-   -   I have been hunting down firmware for my RTL8188CE wireless card for hours... (

darkstarbyte 03-03-2012 08:57 PM

I have been hunting down firmware for my RTL8188CE wireless card for hours...
I am looking for the firmware form my RTL8188CE wireless adapter, and I can only find the firmware for the 8192 model; which was in the package for the 8188 model. I tried the firmware for the 8192 model and that did not work, so I was hoping someone knew where I could get it. I can work with an rpm, and the raw bin file. So far I had to build my own kernel to get the driver on my slackware machine.

coralfang 03-03-2012 09:34 PM

Well, heres the link to the source tarball on realtek's website after a quick search:

I checked the tarball, it contains firmware for RTL8192CE and multiple others, however it does mention in the release notes file:

Release driver version = 0001.0105.2011
Change history =
        1. First Release for 8192CE/8188CE.

Have you tried using the 8192 firmware files? I would assume they are cross compatible.

darkstarbyte 03-03-2012 10:24 PM

I have tried, but I still can't get the darn thing to work. I put the bin files in /lib/firmware, and kept track of the names in case they would need to be removed. Later I removed them after a couple of reboots. My wifi device does not show up on ifconfig, but does show up on "lspci -k" which is what I used to find out about the missing driver. I did resolve the driver problem when I compiled my kernel.

darkstarbyte 03-04-2012 12:29 AM

I have built a package for this, and I still can't get wireless to work even after a reboot.

darkstarbyte 03-04-2012 01:02 PM

Well if I have the driver, and the firmware, then perhaps I just need to add it to ifconfig. I wonder how I would do this? After I got the firmware it shows up on iwconfig.

kuser:) 03-04-2012 01:26 PM


if you try to download the binary firmware for RTL8188CE, you
get it for RTL8192CE but the readme file says: "This driver supports
RealTek rtl8192CE/8188CE PCI Wireless LAN NIC
Instructions are there too. ;)

darkstarbyte 03-04-2012 01:44 PM


Originally Posted by kuser:) (Post 4618317)

I have the firmware installed, but I can't figure out to get to work with any gui for wireless cards.

I was told to get my wireless card to work with wicd I need to comment out everything in files that involve networking in /etc/rc.d

darkstarbyte 03-05-2012 04:06 PM

The answer after all of that work was:

Compiling my own kernel for the modules I needed.
Built a package for the firmware
commented out much of the networking stuff in /etc/rc.d that applied,
and then was able to use wicd.

All times are GMT -5. The time now is 10:05 AM.